Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Updating eclipse 3.7.1
Updating eclipse 3.7.1 [message #800622] Fri, 17 February 2012 09:35 Go to next message
amos sz is currently offline amos szFriend
Messages: 6
Registered: February 2012
Junior Member
I downloaded eclipse classic 3.7.1.
The first thing I tried to do is to check for updates, it seems to start doing it but at some point the progress bat stalls until I receive the following error:

Unable to read repository at download.eclipse.org/releases/indigo/201109230900/content.jar.
Read timed out

When I tried to install a Scala plugin, I selected the relevant components, and clicked on Next... eclipse waited for some time and again I receive the above error (I don't understand why as it is not part of Scala urls).

I read several links but everything I did, lead to nothing. Then I saw the following link: bugs.eclipse.org/bugs/show_bug.cgi?id=362741 , it describes the exact same problem. The only thing I didn't understand is the last comment about java.util.Arrays.useLegacyMergeSort=true - I didn't understand where to set it exactly.

Notice that the connection is established and the progress bar progresses, but at some point it just stuck until the read time out error appears... Please help
Thanks!
Re: Updating eclipse 3.7.1 [message #800623 is a reply to message #800622] Fri, 17 February 2012 09:37 Go to previous messageGo to next message
amos sz is currently offline amos szFriend
Messages: 6
Registered: February 2012
Junior Member
As this is my first topic, I couldn't enter a full link (Forum limitation) for you to click on, so please excuse me for posting urls without the prefix
Re: Updating eclipse 3.7.1 [message #800630 is a reply to message #800622] Fri, 17 February 2012 09:44 Go to previous messageGo to next message
Dani Megert is currently offline Dani MegertFriend
Messages: 3802
Registered: July 2009
Senior Member
On 17.02.2012 10:35, amos sz wrote:
> I downloaded eclipse classic 3.7.1.
> The first thing I tried to do is to check for updates, it seems to
> start doing it but at some point the progress bat stalls until I
> receive the following error:
>
> Unable to read repository at
> download.eclipse.org/releases/indigo/201109230900/content.jar.
> Read timed out
There's a known issue with JRE 7. If you start Eclipse with JRE 7, then
switch back to JRE 6 (at least for the update).

Dani
>
> When I tried to install a Scala plugin, I selected the relevant
> components, and clicked on Next... eclipse waited for some time and
> again I receive the above error (I don't understand why as it is not
> part of Scala urls).
>
> I read several links but everything I did, lead to nothing. Then I saw
> the following link: bugs.eclipse.org/bugs/show_bug.cgi?id=362741 , it
> describes the exact same problem. The only thing I didn't understand
> is the last comment about java.util.Arrays.useLegacyMergeSort=true - I
> didn't understand where to set it exactly.
>
> Notice that the connection is established and the progress bar
> progresses, but at some point it just stuck until the read time out
> error appears... Please help
> Thanks!
Re: Updating eclipse 3.7.1 [message #800667 is a reply to message #800630] Fri, 17 February 2012 10:36 Go to previous messageGo to next message
amos sz is currently offline amos szFriend
Messages: 6
Registered: February 2012
Junior Member
As I'm new to all this, can you please tell me how to switch to JRE 6?
Thanks
Re: Updating eclipse 3.7.1 [message #800671 is a reply to message #800667] Fri, 17 February 2012 10:41 Go to previous messageGo to next message
Dani Megert is currently offline Dani MegertFriend
Messages: 3802
Registered: July 2009
Senior Member
On 17.02.2012 11:36, amos sz wrote:
> As I'm new to all this, can you please tell me how to switch to JRE 6?
Download and install a JRE 6 from Oracle and then launch Eclipse with
it. For details see:
-
http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html
- http://wiki.eclipse.org/FAQ_How_do_I_run_Eclipse%3F

Dani
> Thanks
Re: Updating eclipse 3.7.1 [message #800698 is a reply to message #800671] Fri, 17 February 2012 11:17 Go to previous messageGo to next message
amos sz is currently offline amos szFriend
Messages: 6
Registered: February 2012
Junior Member
I already had 6.30 and 7 update 1 installed, so I simply uninstalled 7 update 1 and now it works ok, thanks a lot
Will there be a fix soon, for this problem with 7?
Re: Updating eclipse 3.7.1 [message #800703 is a reply to message #800698] Fri, 17 February 2012 11:21 Go to previous messageGo to next message
Dani Megert is currently offline Dani MegertFriend
Messages: 3802
Registered: July 2009
Senior Member
On 17.02.2012 12:17, amos sz wrote:
> I already had 6.30 and 7 update 1 installed, so I simply uninstalled 7
> update 1 and now it works ok, thanks a lot
> Will there be a fix soon, for this problem with 7?

Yes, the fix is included in 3.7.2 which is coming out next Friday.

Dani
Re: Updating eclipse 3.7.1 [message #800764 is a reply to message #800698] Fri, 17 February 2012 13:13 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2012.02.17 4:17, amos sz wrote:
> I already had 6.30 and 7 update 1 installed, so I simply uninstalled 7
> update 1 and now it works ok, thanks a lot
> Will there be a fix soon, for this problem with 7?

You didn't need to uninstall Java 7, just download Java 6 and point
Eclipse at it instead of at Java 7.
Previous Topic:Installing Eclipes second time
Next Topic:Non Functional Requirement (NFR)
Goto Forum:
  


Current Time: Fri Jun 25 08:12:18 GMT 2021

Powered by FUDForum. Page generated in 0.03618 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top