Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Teneo - Migrating 0.75 to 0.8
Teneo - Migrating 0.75 to 0.8 [message #93368] Wed, 15 August 2007 15:52 Go to next message
Shane Coughlan is currently offline Shane CoughlanFriend
Messages: 16
Registered: July 2009
Junior Member
Hi,

We are migrating from teneo 0.7.5 to 0.8

in 0.7.5 we implemented a method to load a hibernate file


public class ConfigurationFactory extends HbContextImpl
{

@Override
public Configuration createConfiguration()
{
// code to load hibernate.hbm.xml file

return config;
}
}

In 0.8 what changes do we need to make to implement this??


Thanks,
Shane
Re: Teneo - Migrating 0.75 to 0.8 [message #93462 is a reply to message #93368] Thu, 16 August 2007 17:55 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Shane,
You have to extend the HbSessionDataStore or the HbEntityManagerDataStore to accomplish this. The
reason that this was removed from the HbContext is that Teneo supports both the classic Hibernate
Session and the Hibernate EntityManager. Both require their own configuration. Instead of creating
two types of HbContext I decided to move this method back to the datastore level. Also because
HbContext will probably disappear sometime in the future and be replaced by the extension mechanism
which I added to Teneo.

gr. Martin

Shane Coughlan wrote:
> Hi,
>
> We are migrating from teneo 0.7.5 to 0.8
>
> in 0.7.5 we implemented a method to load a hibernate file
>
>
> public class ConfigurationFactory extends HbContextImpl {
>
> @Override
> public Configuration createConfiguration()
> {
> // code to load hibernate.hbm.xml file
>
> return config;
> }
> }
>
> In 0.8 what changes do we need to make to implement this??
>
> Thanks,
> Shane


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo - Migrating 0.75 to 0.8 [message #609475 is a reply to message #93368] Thu, 16 August 2007 17:55 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Shane,
You have to extend the HbSessionDataStore or the HbEntityManagerDataStore to accomplish this. The
reason that this was removed from the HbContext is that Teneo supports both the classic Hibernate
Session and the Hibernate EntityManager. Both require their own configuration. Instead of creating
two types of HbContext I decided to move this method back to the datastore level. Also because
HbContext will probably disappear sometime in the future and be replaced by the extension mechanism
which I added to Teneo.

gr. Martin

Shane Coughlan wrote:
> Hi,
>
> We are migrating from teneo 0.7.5 to 0.8
>
> in 0.7.5 we implemented a method to load a hibernate file
>
>
> public class ConfigurationFactory extends HbContextImpl {
>
> @Override
> public Configuration createConfiguration()
> {
> // code to load hibernate.hbm.xml file
>
> return config;
> }
> }
>
> In 0.8 what changes do we need to make to implement this??
>
> Thanks,
> Shane


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Previous Topic:[Teneo] Turn off lazy-loading
Next Topic:[Teneo] Problem with the length of element names
Goto Forum:
  


Current Time: Mon Aug 15 17:18:24 GMT 2022

Powered by FUDForum. Page generated in 0.02682 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top