Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » can connect to dl.google.com but not download.eclipse.org(unable to to install new software from download.eclipse.org)
can connect to dl.google.com but not download.eclipse.org [message #793404] Wed, 08 February 2012 04:57 Go to next message
Phil A is currently offline Phil AFriend
Messages: 8
Registered: February 2012
Junior Member
hi all,

i'm running eclipse indigo ("eclipse-java-indigo-SR1-win32") and jdk ("jdk-7u2-windows-i586") on windows 7.

under "help", "install new software", i'm able to see updates with "http //dl.google.com/eclipse/plugin/3.7" in the "works with" field, but i cannot see updates for any "download.eclipse.org" url (for example "http //download.eclipse.org/eclipse/updates/3.7") - it gets stuck saying "pending..." and goes nowhere.

since i'm able to see updates from "dl.google.com" but not from "download.eclipse.org", i have to believe my connection setup is good. however, when i go to "download.eclipse.org" in a browser i can see the site is currently up. i've been having this problem throughout multiple attempts for 2 days now.

i'm stumped. any thoughts?

[Updated on: Wed, 08 February 2012 05:07]

Report message to a moderator

Re: can connect to dl.google.com but not download.eclipse.org [message #793910 is a reply to message #793404] Wed, 08 February 2012 18:35 Go to previous messageGo to next message
Denis Roy is currently offline Denis RoyFriend
Messages: 477
Registered: October 2004
Location: Ottawa, Ontario, Canada
Senior Member

Oddly, your Eclipse installation (Indigo SR1) doesn't seem to be looking for the correct p2 repositories on our site.

[08/Feb/2012:00:04:19 -0500] "GET /releases/indigo/p2.index
[08/Feb/2012:00:04:19 -0500] "HEAD /releases/indigo/content.jar
[08/Feb/2012:00:04:19 -0500] "GET /releases/indigo/content.jar
[08/Feb/2012:08:36:27 -0500] "GET /releases/indigo/p2.index
[08/Feb/2012:08:40:27 -0500] "HEAD /releases/indigo/content.jar
[08/Feb/2012:08:40:28 -0500] "GET /releases/indigo/content.jar
[08/Feb/2012:08:52:49 -0500] "GET /releases/indigo/p2.index
[08/Feb/2012:08:57:10 -0500] "GET /releases/indigo/p2.index
[08/Feb/2012:08:57:26 -0500] "GET /releases/indigo/p2.index
[08/Feb/2012:09:51:39 -0500] "GET /releases/indigo/p2.index
[08/Feb/2012:09:55:39 -0500] "HEAD /releases/indigo/content.jar
[08/Feb/2012:09:55:40 -0500] "GET /releases/indigo/content.jar

What do you see in Window > Preferences > Install/Update > Available Software sites for Indigo?


Denis Roy
Eclipse Webmaster -- webmaster@eclipse.org
Re: can connect to dl.google.com but not download.eclipse.org [message #793959 is a reply to message #793910] Wed, 08 February 2012 19:32 Go to previous messageGo to next message
Phil A is currently offline Phil AFriend
Messages: 8
Registered: February 2012
Junior Member
I show this (ignore space after http, had to manually add that to post):
Eclipse 3.7 GPE Repo http ://dl.google.com/eclipse/plugin/3.7
Indigo http ://download.eclipse.org/releases/indigo
Mylyn for Eclipse Indigo http ://download.eclipse.org/mylyn/releases/indigo
The Eclipse Project Updates http ://download.eclipse.org/eclipse/updates/3.7
Re: can connect to dl.google.com but not download.eclipse.org [message #794044 is a reply to message #793959] Wed, 08 February 2012 21:40 Go to previous messageGo to next message
Denis Roy is currently offline Denis RoyFriend
Messages: 477
Registered: October 2004
Location: Ottawa, Ontario, Canada
Senior Member

Phil, that all looks correct to me... But I'm not an expert. Hopefully someone else can chime in and help.

Denis Roy
Eclipse Webmaster -- webmaster@eclipse.org
Re: can connect to dl.google.com but not download.eclipse.org [message #794052 is a reply to message #794044] Wed, 08 February 2012 21:53 Go to previous messageGo to next message
Phil A is currently offline Phil AFriend
Messages: 8
Registered: February 2012
Junior Member
Thanks for taking a look anyway. What kills me is that I can connect to the dl.google.com. Could it be a problem with my JDK installation and what is being done with those files once they are found on download.eclipse.org?
Re: can connect to dl.google.com but not download.eclipse.org [message #794058 is a reply to message #794052] Wed, 08 February 2012 22:01 Go to previous messageGo to next message
Denis Roy is currently offline Denis RoyFriend
Messages: 477
Registered: October 2004
Location: Ottawa, Ontario, Canada
Senior Member

You can connect just fine -- but it's as if Eclipse isn't requesting the correct files.

Just for giggles, can you try changing your Indigo site URL to this:

http://download.eclipse.org/releases/indigo/201109230900/


Denis Roy
Eclipse Webmaster -- webmaster@eclipse.org
Re: can connect to dl.google.com but not download.eclipse.org [message #794065 is a reply to message #794058] Wed, 08 February 2012 22:10 Go to previous messageGo to next message
Phil A is currently offline Phil AFriend
Messages: 8
Registered: February 2012
Junior Member
Looks like it's stalled in "pending..." again. I'll let you know what error comes back, probably ~20 minutes from now. What does this tell us?
Re: can connect to dl.google.com but not download.eclipse.org [message #794079 is a reply to message #794065] Wed, 08 February 2012 22:26 Go to previous messageGo to next message
Phil A is currently offline Phil AFriend
Messages: 8
Registered: February 2012
Junior Member
What's this? Looks like I got results back - so what does THAT mean?
Re: can connect to dl.google.com but not download.eclipse.org [message #794232 is a reply to message #794079] Thu, 09 February 2012 03:30 Go to previous messageGo to next message
Phil A is currently offline Phil AFriend
Messages: 8
Registered: February 2012
Junior Member
So I connected to download.eclipse.org using the '://download.eclipse.org/releases/indigo/201109230900/' path. I then went on to start installing GWT. Midway through, I think the same issue happened again when it went back out to download.eclipse.org. Please see error output below and let me know your thoughts on what the root cause could be. Thanks much!

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.datatools.connectivity,1.2.3.v201108101135
No repository found containing: osgi.bundle,org.eclipse.datatools.connectivity.db.generic,1.0.1.v200908130547
No repository found containing: osgi.bundle,org.eclipse.datatools.connectivity.dbdefinition.genericJDBC,1.0.1.v200906161815
No repository found containing: osgi.bundle,org.eclipse.datatools.connectivity.sqm.core,1.2.3.v201109022323
No repository found containing: osgi.bundle,org.eclipse.datatools.connectivity.ui,1.2.1.v201010211430
No repository found containing: osgi.bundle,org.eclipse.datatools.help,1.5.0.v200906020553
No repository found containing: osgi.bundle,org.eclipse.datatools.modelbase.dbdefinition,1.0.2.v201002130228
No repository found containing: osgi.bundle,org.eclipse.datatools.modelbase.sql,1.0.4.v201002250945
No repository found containing: osgi.bundle,org.eclipse.jst.common.project.facet.core,1.4.200.v201103170302
No repository found containing: osgi.bundle,org.eclipse.jst.server.core,1.2.202.v20110419
No repository found containing: osgi.bundle,org.eclipse.pde.build,3.7.0.v20110512-1320
No repository found containing: osgi.bundle,org.eclipse.pde.core,3.7.1.v20110822-2108
No repository found containing: osgi.bundle,org.eclipse.wst.css.core,1.1.500.v201104191926
No repository found containing: osgi.bundle,org.eclipse.wst.css.ui,1.0.600.v201103022054
No repository found containing: osgi.bundle,org.eclipse.wst.html.core,1.1.501.v201109080146
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.core,1.1.101.v201108151912
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.manipulation,1.0.300.v201104272153
No repository found containing: osgi.bundle,org.eclipse.wst.jsdt.ui,1.1.101.v201108151912
No repository found containing: osgi.bundle,org.objectweb.asm,3.3.1.v201105211655
Re: can connect to dl.google.com but not download.eclipse.org [message #794679 is a reply to message #794232] Thu, 09 February 2012 15:13 Go to previous messageGo to next message
Denis Roy is currently offline Denis RoyFriend
Messages: 477
Registered: October 2004
Location: Ottawa, Ontario, Canada
Senior Member

Frankly, I'm at wit's end on this one... Sorry.

Denis Roy
Eclipse Webmaster -- webmaster@eclipse.org
Re: can connect to dl.google.com but not download.eclipse.org [message #795045 is a reply to message #794679] Fri, 10 February 2012 01:57 Go to previous message
Phil A is currently offline Phil AFriend
Messages: 8
Registered: February 2012
Junior Member
Thanks anyway - I've searched the net through and through - it seems no one has cracked this exact issue. I'll try to open a bug for it.

One more thing, what made you have me try appending the "201109230900/"? That worked but I'm not sure what it means and cannot find anything relevant about it online.
Previous Topic:How do i use resource.rc files with eclipse
Next Topic:Cannot unzip eclipse
Goto Forum:
  


Current Time: Sun Jun 20 16:58:21 GMT 2021

Powered by FUDForum. Page generated in 0.03476 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top