Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Activator not found after product export(Class not found exception ONLY after export)
Activator not found after product export [message #793188] Tue, 07 February 2012 21:32 Go to next message
Mirco F. is currently offline Mirco F.Friend
Messages: 4
Registered: February 2012
Junior Member
I wrote 4 plug-ins, one of them defining the product, one library plug-in and two plug-ins providing functionality including a perspective. During development I tested via "start rcp" directly from workbench. So far, everything worked.
Now I exported the product for the first time realizing that one plug-in could not be activated due to a class not found exception. I checked the plug-in jar and found the binary as expected. I checked my plugin.xml and but could not find anything weired.
As the perspective of that plug-in is being offered I think the plug-in itself was found. How come the Activator could not be called?

Does anybody have an idea what else I could do to find the error?

thank you.
Re: Activator not found after product export [message #824958 is a reply to message #793188] Tue, 20 March 2012 09:36 Go to previous messageGo to next message
Sabir pasha is currently offline Sabir pashaFriend
Messages: 70
Registered: February 2010
Usually 'Activator not found' error occurs when there is some problem with the Manifest file of the Activator Plugin
Make sure all the values in the Manifest file are correct , and ensure the Bundle-Classpath (if used) refers to the exact path of the libraries used.
Re: Activator not found after product export [message #825041 is a reply to message #824958] Tue, 20 March 2012 11:41 Go to previous message
Thorsten Schlathölter is currently offline Thorsten SchlathölterFriend
Messages: 309
Registered: February 2012
Location: Düsseldorf
Senior Member
we had this problem in the beginning as well. In our cases it always turned out that the "." was not part of the classpath.
So in the MANIFEST.MF you should at least have:

Bundle-ClassPath: .
Previous Topic:[SOLVED] Enable Keybinding only when menu visible
Next Topic:Updating treeviewer from editor
Goto Forum:

Current Time: Fri Dec 04 06:10:38 GMT 2020

Powered by FUDForum. Page generated in 0.01997 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top