Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » [ANN] RAP 1.5 M5
[ANN] RAP 1.5 M5 [message #791879] Mon, 06 February 2012 11:09 Go to next message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Hi all,

those who follow our flight plan [1] or twitter account [2] know about
the new milestone already, for everyone else here's the announcement:

RAP 1.5 M5 is finished and available for download [1]. Among other
improvements, we completed a major rework of the key events in this
milestone. With these changes, it's possible to drastically reduce the
amount of requests issued by the client for key events. If you've used
the doit flag in key or traverse events, you'll have to change your code
to use the new CANCEL_KEYS constant.

If you've developed a custom theme, please check it again with M5. We've
completely decoupled custom themes from the default theme and changed
the default values that are used as fallback for undefined properties.
This will make custom themes more stable in the future.

Read about the details in the New and Noteworthy [3].

Cheers,
the RAP team


[1] http://eclipse.org/rap/download
[2] https://twitter.com/#!/EclipseRAP
[3] http://eclipse.org/rap/noteworthy/1.5/news_M5.php

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: [ANN] RAP 1.5 M5 [message #792131 is a reply to message #791879] Mon, 06 February 2012 16:49 Go to previous messageGo to next message
Angelo ZERR is currently offline Angelo ZERRFriend
Messages: 122
Registered: July 2009
Senior Member
Hi Ralf,

Thank a lot for this great announce. I'm waiting fixes about ContentProposalAdapter to deploy our XDocReport RAP Application which will use a lot completion. (I'm developping ModelPicker that i would like give to Nebula to select a model (ex:Person, etc...) with completion or custom dialog, etc...)

We use a *.target file to have references to RAP and I have tried with this URL :

http://download.eclipse.org/rt/rap/1.5/runtime


and I have that (for the last version) :

    Rich Ajax Platform (RAP) Basic Target Requirements	1.5.0.20111108-1028
    Rich Ajax Platform (RAP) Target Components	1.5.0.20111108-1028


Is it normal that version is 1.5.0.20111108-1028?

Thank a lot for your help.

Regards Angelo
Re: [ANN] RAP 1.5 M5 [message #792665 is a reply to message #792131] Tue, 07 February 2012 08:59 Go to previous message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Hi Angelo,

you're right, M5 did not end up in the composite repository. Thanks for
pointing this out! I've just fixed the repositories.

BTW, as a backup in case of any trouble with the repository, you can
also use the zip files from the download page as a local repository.

Best regards, Ralf

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:HTML 5/ Web Worker support
Next Topic:RAP 1.5 M5 - invalid software site
Goto Forum:
  


Current Time: Sun Oct 17 18:22:17 GMT 2021

Powered by FUDForum. Page generated in 0.02419 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top