Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Test and Performance Tools Platform (TPTP) » IWAT0284E errors on linux x86_64
IWAT0284E errors on linux x86_64 [message #92743] Wed, 21 February 2007 18:24 Go to next message
Erik Putrycz is currently offline Erik PutryczFriend
Messages: 25
Registered: July 2009
Junior Member
I've been trying to profile an application on Eclipse 3.2, opensuse
10.2, jdk 6 64 bits. I just installed TPTP using the callisto site, then
installed all the updates. I'd just tried to launch the eclipse
context menu "Profile..." instead of run. Everytime I get "IWAT0284E The
agent controller is not available..."
I deleted my tmp directory but it did no do anything.
Also when I look on the "Profiling monitor" view there is something
there but the PID is 0. It is impossible to stop it. Also after looking
at netstat there is nothing listening on port 10002. Also nothing in the
Eclipse error logs. How to see if the integrated agent is working and
installed?

Erik
Re: IWAT0284E errors on linux x86_64 [message #95757 is a reply to message #92743] Fri, 13 April 2007 11:52 Go to previous message
Paul Slauenwhite is currently offline Paul SlauenwhiteFriend
Messages: 975
Registered: July 2009
Senior Member
Hi Erik,
A couple of comments:

1) Are you running a firewall? If so, trying disabling it or opening ports
10002 - 10006.

2) The Integrated Agent Controller automatically runs if the Agent
Controller is not running. You can test this my Window >> Preferences >>
Profiling and Logging >> Hosts >> Local Direct Connection >> Test
Connection. Conversely, selecting localhost:10002 >> Test Connection will
do the same for the Agent Controller.

3) After Eclipse is shutdown, ensure all of the Java processes are killed
and delete the /tmp/IBMRAC directory.

4) Try running your profiling scenario using the Agent Controller.

Paul
"Erik Putrycz" <erik.putrycz@nrc-cnrc.gc.ca> wrote in message
news:eri2o6$9sg$1@utils.eclipse.org...
> I've been trying to profile an application on Eclipse 3.2, opensuse 10.2,
> jdk 6 64 bits. I just installed TPTP using the callisto site, then
> installed all the updates. I'd just tried to launch the eclipse context
> menu "Profile..." instead of run. Everytime I get "IWAT0284E The agent
> controller is not available..."
> I deleted my tmp directory but it did no do anything.
> Also when I look on the "Profiling monitor" view there is something there
> but the PID is 0. It is impossible to stop it. Also after looking at
> netstat there is nothing listening on port 10002. Also nothing in the
> Eclipse error logs. How to see if the integrated agent is working and
> installed?
>
> Erik
Previous Topic:URL recorder - session handeling
Next Topic:JUnit and Data Files
Goto Forum:
  


Current Time: Sat Aug 08 12:18:36 GMT 2020

Powered by FUDForum. Page generated in 0.01737 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top