Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Test and Performance Tools Platform (TPTP) » Problems starting agent on Windows - tptpProcessController.exe uses 100% cpu
Problems starting agent on Windows - tptpProcessController.exe uses 100% cpu [message #8289] Fri, 04 March 2005 15:27 Go to next message
Eclipse UserFriend
Originally posted by: webmail.andreaundstefanhoehn.de

When I start the agent under windows, the cpu goes up to 100%.

What I noticed, though, is that installation directory of the agent files is
flat. no /bin for example and there is no serviceconfig.xml around (only
under /eclipse/config, which is 0 Bytes). There is no batch-file helping me
to create serviceconfig.xml. The directory contains the following files:

I downloaded the client from
http://eclipse.org/tptp/home/downloads/drops/TPTP-4.0-200502 222137.html :
Agent Controller.


Directory of C:\eclipse\profileragent

[.] [..] agentBase.dll
agentBase.exp agentBase.lib client.dll
client.exp client.lib namedPipeTL.dll
namedPipeTL.exp namedPipeTL.lib
processControlUtil.dll
processControlUtil.exp processControlUtil.lib sharedMemTL.dll
sharedMemTL.exp sharedMemTL.lib socketTL.dll
socketTL.exp socketTL.lib
tptpAgentController.exe
tptpProcessController.exe tptpProcessController.exp
tptpProcessController.lib
tptpUtils.dll tptpUtils.exp tptpUtils.lib
transportSupport.dll transportSupport.exp transportSupport.lib


1) What is agent controller (new) on the above download site?

2) I am wondering whether I use the right agent?

3) Any idea why "tptpProcessController.exe" goes up to 100% when I start
tptpAgentController.exe?

The output of tptpProcesscontroller is:
Create pipe: \\.\pipe\IBMAC\ramaster
startTransportListener (named pipe)...
startTransportListener (shared memory)...
Named pipe server is running and listening at "ramaster" pipe.
Ready to accept next named pipe request...
Shared memory server is running and listening at "rabuffer" name.
Ready to accept another new shared memory connection request...
Received(48 bytes). CONNECTION REQUESTED COMMAND.
COMMAND: 6f70c123-a841-400f-80c1-4ea7926d1352.
Connection ID: 100
UUID: 6f70c123-a841-400f-80c1-4ea7926d1352.
Open pipe: \\.\pipe\IBMAC\6f70c123-a841-400f-80c1-4ea7926d1352
Sent out(16 bytes). CONNECTION COMPLETE RESPONSE.
Connection ID (100).
Ready to accept next named pipe request...
Received(213 bytes). COMMAND: <Cmd src="100" dest="10001" ctxt="100">
<registerAgentiid="org.eclipse.tptp.agentManager"><agentID >100</agentID><pro
cessID>460</processID><agentName>ProcessController</agentName ></registerAgen
t></Cmd>.
sendMessage (named pipe) to this connection id(100)...
Sent out(128 bytes). COMMAND: <Cmd src="10001" dest="100"
ctxt="100"><agentRegis
tered iid="org.eclipse.tptp.agentManager"></agentRegistered></Cmd >.
Ready to accept next named pipe request...
Socket server is running at port number of 10002.
Ready to accept next socket connection request...

Thanks for your help,
Stefan
Re: Problems starting agent on Windows - tptpProcessController.exe uses 100% cpu [message #8515 is a reply to message #8289] Mon, 07 March 2005 18:27 Go to previous messageGo to next message
Andy Kaylor is currently offline Andy KaylorFriend
Messages: 23
Registered: July 2009
Junior Member
Stefan,

We are in the process of developing a new version of the Agent Controller,
which is targeted for the 4.0 release, but the old version is still active
and the one that you probably want for now. The new version is what you've
found under "agent controller (new)".

Currently, it isn't integrated with the TPTP Eclipse plug-ins and can only
be called from the sample client. The reason this new agent controller is
posted is so that people who want to develop agents using the new protocol
we are introducing can get started on that. (I'm not sure why
tptpProcessController would be using 100% CPU, but I'll look into it.)

If you are just trying to use the latest version of TPTP, you should still
be using the RAServer found under "agent controller" (without the "new").

-Andy
Re: Problems starting agent on Windows - tptpProcessController.exe uses 100% cpu [message #9407 is a reply to message #8515] Tue, 08 March 2005 14:03 Go to previous message
Eclipse UserFriend
Originally posted by: webmail.andreaundstefanhoehn.de

I downloaded the last version (from the 7th) and this one works now (the
RAserver, the RAservice which I don't need goes 100%). The "new"-version is
not on the download-site anymore which reduces confusion.

Thx so far.
Stefan

"Andy Kaylor" <andrew.kaylor@intel.com> wrote in message
news:d0i6f2$ckp$1@www.eclipse.org...
> Stefan,
>
> We are in the process of developing a new version of the Agent Controller,
> which is targeted for the 4.0 release, but the old version is still active
> and the one that you probably want for now. The new version is what
you've
> found under "agent controller (new)".
>
> Currently, it isn't integrated with the TPTP Eclipse plug-ins and can only
> be called from the sample client. The reason this new agent controller is
> posted is so that people who want to develop agents using the new protocol
> we are introducing can get started on that. (I'm not sure why
> tptpProcessController would be using 100% CPU, but I'll look into it.)
>
> If you are just trying to use the latest version of TPTP, you should still
> be using the RAServer found under "agent controller" (without the "new").
>
> -Andy
>
>
>
Previous Topic:An error has occurred when creating this editor
Next Topic:Getting Started with tptp
Goto Forum:
  


Current Time: Thu Jun 27 00:54:43 GMT 2019

Powered by FUDForum. Page generated in 0.01422 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top