Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Marketplace Maven not updating dependencies
Eclipse Marketplace Maven not updating dependencies [message #787439] Tue, 31 January 2012 15:29 Go to next message
Stephane Eybert is currently offline Stephane EybertFriend
Messages: 3
Registered: January 2012
Junior Member
Hello,

I have Eclipse Indigo SR1 and have installed the Maven plugin from the Eclipse Marketplace called m2e Maven Integration for Eclipse by Eclipse.org EPL.

I can now see an item called Maven in the contextual menu when right clicking on the project name in the left pane.

But when I choose the option to update the maven dependencies, I still have on dependency, the one for the spring framework, that is not taken into account, resulting in the import org.springframework.. giving an error in Eclipse.

Eclipse says: The import org.springframework could not be resolved.

And of course I do a mvn eclipse:eclipse beforehand.

The mvn clean install command works fine on the command line though.

Any idea ?

Stephane
  • Attachment: pom.xml
    (Size: 2.09KB, Downloaded 139 times)
  • Attachment: pom.xml
    (Size: 4.40KB, Downloaded 144 times)
  • Attachment: pom.xml
    (Size: 2.45KB, Downloaded 150 times)

[Updated on: Tue, 31 January 2012 15:30]

Report message to a moderator

Re: Eclipse Marketplace Maven not updating dependencies [message #788490 is a reply to message #787439] Wed, 01 February 2012 21:54 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
m2e has its own dedicated forum group. Find it on the Forums home page
under the section "Eclipse Projects."


On 1/31/12 10:29 AM, Stephane Eybert wrote:
> Hello,
>
> I have Eclipse Indigo SR1 and have installed the Maven plugin from the Eclipse Marketplace called m2e Maven Integration for Eclipse by Eclipse.org EPL.
>
> I can now see an item called Maven in the contextual menu when right clicking on the project name in the left pane.
>
> But when I choose the option to update the maven dependencies, I still have on depndency, the one for the spring framework, that is not taken into account, resulting in the import org.springframework.. giving an error in Eclipse.
>
> Eclipse says: The import org.springframework could not be resolved.
>
> And of course I do a mvn eclipse:eclipse beforehand.
>
> The mvn clean install command works fine on the command line though.
>
> Any idea ?
>
> Stephane
Re: Eclipse Marketplace Maven not updating dependencies [message #788842 is a reply to message #788490] Thu, 02 February 2012 09:37 Go to previous messageGo to next message
Stephane Eybert is currently offline Stephane EybertFriend
Messages: 3
Registered: January 2012
Junior Member
Thanks for pointing it to me. I had not seen the project forum, I missed the little + icon to click on so as to display the Eclipse project forums.

I now looked for a way to move my post to this other forum but could not find any way to do that, so I'll repost again over there.

Cheers,
Re: Eclipse Marketplace Maven not updating dependencies [message #788860 is a reply to message #788842] Thu, 02 February 2012 09:55 Go to previous messageGo to next message
Stephane Eybert is currently offline Stephane EybertFriend
Messages: 3
Registered: January 2012
Junior Member
I'm trying to post a new thread but cannot because the form to post asks me for a password even though I'm already logged in.

I just reset my password to be sure. It still refuses it.

I then went to the Help page which advises to:

If cannot remember your password for FUDforum, you should go to the reset password page, on that page enter your email address inside the text box and press the Reset Password button. This will send you an email with a special URL, when you access that URL your password will be reset and you will receive a new email with your password.

Clicking on the link "reset password page" does not take you to such a page however, but to the welcome page.

I found another registration page and successfully registered there as well.

I received an email containing a random password.

I tried to use this password in the post form but it was refused.

1- Are there two kind of user / password details ? One for the forum and one for..?

2- How come a password is being asked for when posting a new thread if we are logged in already ?

I failed to post this new thread for now.

Cheers,

Stephane
Re: Eclipse Marketplace Maven not updating dependencies [message #789288 is a reply to message #788860] Thu, 02 February 2012 20:21 Go to previous message
Eclipse Webmaster is currently offline Eclipse WebmasterFriend
Messages: 607338
Registered: July 2009
Senior Member
On 02/02/2012 04:56 AM, Stephane Eybert wrote:
> I'm trying to post a new thread but cannot because the form to post asks
> me for a password even though I'm already logged in.

Actually, the first post on the m2e forum says that forum is closed.

http://www.eclipse.org/forums/index.php/t/204324/

I'll see if we can't just delete these "closed" forums. It just makes
things more confusing.


That project (m2e) appears to prefer mailing lists for user discussions.
Not everyone agrees, but it is what it is. Here's a link to their
mailing list subscription form:

https://dev.eclipse.org/mailman/listinfo/m2e-users

I apologize for the apparent runaround. Hang in there -- I'm sure
someone will answer your question.

Denis
Previous Topic:subclipse
Next Topic:Eclipse runs but can't build anything
Goto Forum:
  


Current Time: Fri Jun 25 11:19:03 GMT 2021

Powered by FUDForum. Page generated in 0.02785 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top