Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Conflict dependencies upgrading Eclipse
Conflict dependencies upgrading Eclipse [message #785209] Sat, 28 January 2012 17:05 Go to next message
Luís de Sousa is currently offline Luís de SousaFriend
Messages: 214
Registered: July 2009
Senior Member
Dear all,

I'd like to upgrade Eclipse from Helios to Indigo but I'm running into conflicting dependencies. I added the Indigo update site to the software sources and requested the available updates. The available updates page then shows "The operation cannot be completed" message and list the dependencies reproduced below. I've tried unchecking the offending packages: Web Development Tools, Java Persistence Tools and XML Editors and Tools but the conflicts remain.

Is there any way I can overcome this? Thanks.

Cannot complete the install because of a conflicting dependency.
  Software being installed: Dali Java Persistence Tools 2.3.4.v201104192310-7N7UF77FD3wTgcVbmmf0cT (org.eclipse.jpt.feature.feature.group 2.3.4.v201104192310-7N7UF77FD3wTgcVbmmf0cT)
  Software being installed: Eclipse Web Developer Tools 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL (org.eclipse.wst.web_ui.feature.feature.group 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL)
  Only one of the following can be installed at once: 
    Structured Source Editor 1.3.1.v201108191312 (org.eclipse.wst.sse.ui 1.3.1.v201108191312)
    Structured Source Editor 1.2.5.v201108191505 (org.eclipse.wst.sse.ui 1.2.5.v201108191505)
    Structured Source Editor 1.2.4.v201103231819 (org.eclipse.wst.sse.ui 1.2.4.v201103231819)
    Structured Source Editor 1.2.2.v201008232126 (org.eclipse.wst.sse.ui 1.2.2.v201008232126)
    Structured Source Editor 1.2.0.v201006030742 (org.eclipse.wst.sse.ui 1.2.0.v201006030742)
    Structured Source Editor 1.3.0.v201105101529 (org.eclipse.wst.sse.ui 1.3.0.v201105101529)
    Structured Source Editor 1.2.3.v201102102045 (org.eclipse.wst.sse.ui 1.2.3.v201102102045)
    Structured Source Editor 1.2.1.v201007141733 (org.eclipse.wst.sse.ui 1.2.1.v201007141733)
  Cannot satisfy dependency:
    From: Dali Java Persistence Tools 2.3.4.v201104192310-7N7UF77FD3wTgcVbmmf0cT (org.eclipse.jpt.feature.feature.group 2.3.4.v201104192310-7N7UF77FD3wTgcVbmmf0cT)
    To: org.eclipse.jpt.ui [2.3.2.v201008252310]
  Cannot satisfy dependency:
    From: Dali Java Persistence Tools - UI 2.3.2.v201008252310 (org.eclipse.jpt.ui 2.3.2.v201008252310)
    To: bundle org.eclipse.wst.sse.ui [1.1.0,1.3.0)
  Cannot satisfy dependency:
    From: Eclipse Web Developer Tools 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL (org.eclipse.wst.web_ui.feature.feature.group 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL)
    To: org.eclipse.wst.xml_ui.feature.feature.group [3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL]
  Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL (org.eclipse.wst.xml_ui.feature.feature.group 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL)
    To: org.eclipse.wst.sse.ui [1.3.1.v201108191312]
Re: Conflict dependencies upgrading Eclipse [message #788485 is a reply to message #785209] Wed, 01 February 2012 21:51 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
The simplest route is to download a new package of Indigo, install it
into a different location than your Helios installation, then run it and
select your existing workspace(s). The only other thing you might have
to do is re-install any third-party plugins that you might have
installed into Helios, but you'd likely have to do that anyway as most
plugins are updated with new major releases of Eclipse.

Eric


On 1/28/12 12:05 PM, Luís de Sousa wrote:
> Dear all,
>
> I'd like to upgrade Eclipse from Helios to Indigo but I'm running into
> conflicting dependencies. I added the Indigo update site to the software
> sources and requested the available updates. The available updates page
> then shows "The operation cannot be completed" message and list the
> dependencies reproduced below. I've tried unchecking the offending
> packages: Web Development Tools, Java Persistence Tools and XML Editors
> and Tools but the conflicts remain.
> Is there any way I can overcome this? Thanks.
>
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Dali Java Persistence Tools
> 2.3.4.v201104192310-7N7UF77FD3wTgcVbmmf0cT
> (org.eclipse.jpt.feature.feature.group
> 2.3.4.v201104192310-7N7UF77FD3wTgcVbmmf0cT)
> Software being installed: Eclipse Web Developer Tools
> 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL
> (org.eclipse.wst.web_ui.feature.feature.group
> 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL)
> Only one of the following can be installed at once: Structured Source
> Editor 1.3.1.v201108191312 (org.eclipse.wst.sse.ui 1.3.1.v201108191312)
> Structured Source Editor 1.2.5.v201108191505 (org.eclipse.wst.sse.ui
> 1.2.5.v201108191505)
> Structured Source Editor 1.2.4.v201103231819 (org.eclipse.wst.sse.ui
> 1.2.4.v201103231819)
> Structured Source Editor 1.2.2.v201008232126 (org.eclipse.wst.sse.ui
> 1.2.2.v201008232126)
> Structured Source Editor 1.2.0.v201006030742 (org.eclipse.wst.sse.ui
> 1.2.0.v201006030742)
> Structured Source Editor 1.3.0.v201105101529 (org.eclipse.wst.sse.ui
> 1.3.0.v201105101529)
> Structured Source Editor 1.2.3.v201102102045 (org.eclipse.wst.sse.ui
> 1.2.3.v201102102045)
> Structured Source Editor 1.2.1.v201007141733 (org.eclipse.wst.sse.ui
> 1.2.1.v201007141733)
> Cannot satisfy dependency:
> From: Dali Java Persistence Tools
> 2.3.4.v201104192310-7N7UF77FD3wTgcVbmmf0cT
> (org.eclipse.jpt.feature.feature.group
> 2.3.4.v201104192310-7N7UF77FD3wTgcVbmmf0cT)
> To: org.eclipse.jpt.ui [2.3.2.v201008252310]
> Cannot satisfy dependency:
> From: Dali Java Persistence Tools - UI 2.3.2.v201008252310
> (org.eclipse.jpt.ui 2.3.2.v201008252310)
> To: bundle org.eclipse.wst.sse.ui [1.1.0,1.3.0)
> Cannot satisfy dependency:
> From: Eclipse Web Developer Tools
> 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL
> (org.eclipse.wst.web_ui.feature.feature.group
> 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL)
> To: org.eclipse.wst.xml_ui.feature.feature.group
> [3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL]
> Cannot satisfy dependency:
> From: Eclipse XML Editors and Tools
> 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL
> (org.eclipse.wst.xml_ui.feature.feature.group
> 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL)
> To: org.eclipse.wst.sse.ui [1.3.1.v201108191312]
>
Re: Conflict dependencies upgrading Eclipse [message #794846 is a reply to message #788485] Thu, 09 February 2012 19:28 Go to previous message
Luís de Sousa is currently offline Luís de SousaFriend
Messages: 214
Registered: July 2009
Senior Member
Quote:
The simplest route is to download a new package of Indigo, install it
into a different location than your Helios installation


That's an interesting concept of simplicity. But thanks for the advice anyway, I'll follow that route.
Previous Topic:The string value does not changed
Next Topic:Eclipse Mozilla as Browser Context Menu
Goto Forum:
  


Current Time: Thu Jun 24 10:22:02 GMT 2021

Powered by FUDForum. Page generated in 0.02850 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top