Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » WidgetUtil.CUSTOM_VARIANT(WidgetUtil.CUSTOM_VARIANT not working)
WidgetUtil.CUSTOM_VARIANT [message #783417] Wed, 25 January 2012 17:20 Go to next message
Sudesh Bulathsinhala is currently offline Sudesh BulathsinhalaFriend
Messages: 193
Registered: October 2010
Senior Member
Hi,

I'm applying the following style using WidgetUtil.CUSTOM_VARIANT to mimic a gradient effect on my composite.

composite.setData(WidgetUtil.CUSTOM_VARIANT, "gradient_metal");


and my css file contains the following snippet :
Composite.gradient_metal {
	background-image: gradient(linear, left top, left bottom, from(#FFFFFF),
		color-stop(100%, #E5EFF9), color-stop(100%, #FFFFFF), to(#E5EFF9) );
}


The above code snippet was working perfect, until RAP 1.5.

Is this a bug, or am I missing something here in 1.5 ?

Regards,
Sudesh Bulathsinhala
Re: WidgetUtil.CUSTOM_VARIANT [message #783427 is a reply to message #783417] Wed, 25 January 2012 17:37 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Sudesh,
just checked your code with current CVS HEAD and it's working without
problem. Which milestone are you using? Could you provide a complete
test project that demonstrate the issue?
Best,
Ivan

On 1/25/2012 7:20 PM, Sudesh Bulathsinhala wrote:
> Hi,
>
> I'm applying the following style using WidgetUtil.CUSTOM_VARIANT to
> mimic a gradient effect on my composite.
>
>
> composite.setData(WidgetUtil.CUSTOM_VARIANT, "gradient_metal");
>
>
> and my css file contains the following snippet :
>
> Composite.gradient_metal {
> background-image: gradient(linear, left top, left bottom,
> from(#FFFFFF),
> color-stop(100%, #E5EFF9), color-stop(100%, #FFFFFF),
> to(#E5EFF9) );
> }
>
>
> The above code snippet was working perfect, until RAP 1.5.
>
> Is this a bug, or am I missing something here in 1.5 ?
>
> Regards,
> Sudesh Bulathsinhala

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: WidgetUtil.CUSTOM_VARIANT [message #783438 is a reply to message #783427] Wed, 25 January 2012 18:05 Go to previous messageGo to next message
Sudesh Bulathsinhala is currently offline Sudesh BulathsinhalaFriend
Messages: 193
Registered: October 2010
Senior Member
Hi Ivan,

Thanks for the quick reply as usual from you.
I'm using 1.5 M4 Milestone Build.

I just installed the latest build 1.5M4 and imported our project.
With 1.4 it was working perfect.

I also encountered the following errors in console :

!ENTRY org.eclipse.rap.rwt.testfixture 4 0 2012-01-25 23:26:05.381
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702 [10]" could not be resolved. Reason: Missing Constraint: Import-Package: javax.servlet; version="[3.0.0,4.0.0)"
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1328)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1312)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1177)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
2012-01-25 23:26:05.469:INFO:org.mortbay.log:Logging to STDERRorg.mortbay.log via org.mortbay.log.Slf4jLog
2012-01-25 23:26:05.530:INFO::jetty-6.1.x
2012-01-25 23:26:05.586:INFO::Started SelectChannelConnector@0.0.0.0:52436

!ENTRY org.eclipse.osgi 4 0 2012-01-25 23:26:08.918
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702.jar/ was not resolved.

!ENTRY org.eclipse.osgi 2 0 2012-01-25 23:26:08.941
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-01-25 23:26:08.941
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.942
!MESSAGE Missing imported package javax.servlet_[3.0.0,4.0.0).
!SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.942
!MESSAGE Missing imported package org.json_0.0.0.
!SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.942
!MESSAGE Missing imported package javax.servlet.descriptor_[3.0.0,4.0.0).
!SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.943
!MESSAGE Missing imported package javax.servlet.http_[3.0.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2012-01-25 23:26:08.948
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-01-25 23:26:08.948
!MESSAGE Bundle org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702 [10] was not resolved.
!SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.948
!MESSAGE Missing imported package javax.servlet_[3.0.0,4.0.0).
!SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.949
!MESSAGE Missing imported package javax.servlet.descriptor_[3.0.0,4.0.0).
!SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.950
!MESSAGE Missing imported package javax.servlet.http_[3.0.0,4.0.0).
!SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.950
!MESSAGE Missing imported package org.json_0.0.0.


Any idea what it could be ?

Thanks,
Sudesh
Re: WidgetUtil.CUSTOM_VARIANT [message #783450 is a reply to message #783438] Wed, 25 January 2012 18:31 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Sudesh,
org.eclipse.rap.rwt.testfixture bundle is only needed to run the RAP
JUnit tests. It's safe to remove this bundle from your launch
configuration. About the theming issue - please provide a complete tests
project that demonstrate the issue. You could test the latest nightly
build as well.
Best,
Ivan

On 1/25/2012 8:05 PM, Sudesh Bulathsinhala wrote:
> Hi Ivan,
>
> Thanks for the quick reply as usual from you.
> I'm using 1.5 M4 Milestone Build.
>
> I just installed the latest build 1.5M4 and imported our project.
> With 1.4 it was working perfect.
>
> I also encountered the following errors in console :
>
>
> !ENTRY org.eclipse.rap.rwt.testfixture 4 0 2012-01-25 23:26:05.381
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle
> "org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702 " could not
> be resolved. Reason: Missing Constraint: Import-Package:
> javax.servlet; version="[3.0.0,4.0.0)"
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1328)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1312)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1177)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
> 2012-01-25 23:26:05.469:INFO:org.mortbay.log:Logging to
> STDERRorg.mortbay.log via org.mortbay.log.Slf4jLog
> 2012-01-25 23:26:05.530:INFO::jetty-6.1.x
> 2012-01-25 23:26:05.586:INFO::Started
> SelectChannelConnector@0.0.0.0:52436
>
> !ENTRY org.eclipse.osgi 4 0 2012-01-25 23:26:08.918
> !MESSAGE Bundle
> initial@reference:file:plugins/org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 2 0 2012-01-25 23:26:08.941
> !MESSAGE One or more bundles are not resolved because the following
> root constraints are not resolved:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2012-01-25 23:26:08.941
> !MESSAGE Bundle
> initial@reference:file:plugins/org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702.jar/
> was not resolved.
> !SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.942
> !MESSAGE Missing imported package javax.servlet_[3.0.0,4.0.0).
> !SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.942
> !MESSAGE Missing imported package org.json_0.0.0.
> !SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.942
> !MESSAGE Missing imported package javax.servlet.descriptor_[3.0.0,4.0.0).
> !SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.943
> !MESSAGE Missing imported package javax.servlet.http_[3.0.0,4.0.0).
>
> !ENTRY org.eclipse.osgi 2 0 2012-01-25 23:26:08.948
> !MESSAGE The following is a complete list of bundles which are not
> resolved, see the prior log entry for the root cause if it exists:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2012-01-25 23:26:08.948
> !MESSAGE Bundle org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702
> [10] was not resolved.
> !SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.948
> !MESSAGE Missing imported package javax.servlet_[3.0.0,4.0.0).
> !SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.949
> !MESSAGE Missing imported package javax.servlet.descriptor_[3.0.0,4.0.0).
> !SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.950
> !MESSAGE Missing imported package javax.servlet.http_[3.0.0,4.0.0).
> !SUBENTRY 2 org.eclipse.rap.rwt.testfixture 2 0 2012-01-25 23:26:08.950
> !MESSAGE Missing imported package org.json_0.0.0.
>
>
> Any idea what it could be ?
>
> Thanks,
> Sudesh

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: WidgetUtil.CUSTOM_VARIANT [message #793917 is a reply to message #783450] Wed, 08 February 2012 18:40 Go to previous messageGo to next message
Sudesh Bulathsinhala is currently offline Sudesh BulathsinhalaFriend
Messages: 193
Registered: October 2010
Senior Member
hello Ivan,

i just replaced the following gradient configuration in css and it worked !

not-working
background-image: gradient(linear, left top, left bottom, from(#ffffff),
		color-stop(48%, #f0f0f0), color-stop(52%, #e0e0e0), to(#cccccc) );


working
background-image: url("/themes/icons/header_bg.png");


where "header_bg.png" is an image with predefined gradient.

Regards,
Sudesh
Re: WidgetUtil.CUSTOM_VARIANT [message #793922 is a reply to message #783450] Wed, 08 February 2012 18:40 Go to previous messageGo to next message
Sudesh Bulathsinhala is currently offline Sudesh BulathsinhalaFriend
Messages: 193
Registered: October 2010
Senior Member
hello Ivan,

i just replaced the following gradient configuration in css and it worked !

not-working

background-image: gradient(linear, left top, left bottom, from(#ffffff),
color-stop(48%, #f0f0f0), color-stop(52%, #e0e0e0), to(#cccccc) );


working

background-image: url("/themes/icons/header_bg.png");


where "header_bg.png" is an image with predefined gradient.

Regards,
Sudesh
Re: WidgetUtil.CUSTOM_VARIANT [message #795410 is a reply to message #793917] Fri, 10 February 2012 12:51 Go to previous message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Sudesh,
a I said before, setting Composite background gradient through the
custom variant is working form me. If it doesn't work for you, please
open a bugzilla and attach a simple project to reproduce the issue.
Note: Setting composite background color from a Java code will remove
the background gradient set by theming.
Thanks,
Ivan

On 2/8/2012 8:40 PM, Sudesh Bulathsinhala wrote:
> hello Ivan,
>
> i just replaced the following gradient configuration in css and it
> worked !
>
> not-working
>
> background-image: gradient(linear, left top, left bottom, from(#ffffff),
> color-stop(48%, #f0f0f0), color-stop(52%, #e0e0e0),
> to(#cccccc) );
>
>
> working
>
> background-image: url("/themes/icons/header_bg.png");
>
>
> where "header_bg.png" is an image with predefined gradient.
>
> Regards,
> Sudesh

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:How to create combo with images
Next Topic:org.eclipse.rwt.widgets.styledtext
Goto Forum:
  


Current Time: Sun Oct 24 10:30:36 GMT 2021

Powered by FUDForum. Page generated in 0.01866 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top