Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Installation issue RAP 1.5M4(Can't install RAP 1.5M4 - RWT launcher could not be found)
Installation issue RAP 1.5M4 [message #780451] Wed, 18 January 2012 00:09 Go to next message
Mike Gingell is currently offline Mike GingellFriend
Messages: 4
Registered: July 2011
Location: Canada
Junior Member
Hi All!
I am trying to install RAP 1.5M4 on a fresh Indigo "Eclipse for RCP and RAP Developers" installation. The installer fails with the following message:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Rich Ajax Platform (RAP) Tooling 1.5.0.20111212-1416 (org.eclipse.rap.tooling.feature.group 1.5.0.20111212-1416)
  Missing requirement: RWT Launcher Plug-in 1.5.0.20111212-1416 (org.eclipse.rap.ui.launch.rwt 1.5.0.20111212-1416) requires 'bundle org.eclipse.jetty.continuation [8.1.0,9.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Rich Ajax Platform (RAP) Tooling 1.5.0.20111212-1416 (org.eclipse.rap.tooling.feature.group 1.5.0.20111212-1416)
    To: org.eclipse.rap.ui.launch.rwt [1.5.0.20111212-1416]

I am relatively new to the RWT/RAP project. Can anyone help me get this installed please?
Thanks,
- Mike
Re: Installation issue RAP 1.5M4 [message #780820 is a reply to message #780451] Thu, 19 January 2012 14:03 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Mike,
RAP 1.5M4 tooling is not compatible with Eclipse 3.7. See bug:
366614: [Tooling] Breaking changes in the latest org.eclipse.pde.core bundle
https://bugs.eclipse.org/bugs/show_bug.cgi?id=366614
The latest 1.5M4 tooling requires Eclipse 3.8M4 or Eclipse 4.2M4 [1].

[1] http://download.eclipse.org/eclipse/downloads/
Best,
Ivan

On 1/18/2012 2:09 AM, Mike Gingell wrote:
> Hi All!
> I am trying to install RAP 1.5M4 on a fresh Indigo "Eclipse for RCP
> and RAP Developers" installation. The installer fails with the
> following message:
>
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: Rich Ajax Platform (RAP) Tooling
> 1.5.0.20111212-1416 (org.eclipse.rap.tooling.feature.group
> 1.5.0.20111212-1416)
> Missing requirement: RWT Launcher Plug-in 1.5.0.20111212-1416
> (org.eclipse.rap.ui.launch.rwt 1.5.0.20111212-1416) requires 'bundle
> org.eclipse.jetty.continuation [8.1.0,9.0.0)' but it could not be found
> Cannot satisfy dependency:
> From: Rich Ajax Platform (RAP) Tooling 1.5.0.20111212-1416
> (org.eclipse.rap.tooling.feature.group 1.5.0.20111212-1416)
> To: org.eclipse.rap.ui.launch.rwt [1.5.0.20111212-1416]
>
> I am relatively new to the RWT/RAP project. Can anyone help me get
> this installed please?
> Thanks,
> - Mike

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Installation issue RAP 1.5M4 [message #780925 is a reply to message #780820] Thu, 19 January 2012 23:26 Go to previous messageGo to next message
Raj  is currently offline Raj Friend
Messages: 74
Registered: August 2011
Member
Hi

I am trying to run the RAP 1.5M4 on Eclipse 4.2(Juno). But i do not get the option for running the RAP application.(Run - Run Configuration - RAP Application)is missing. So i am not able to launch the application.

Is anyone able to run the app?

Thanks
Raj
Re: Installation issue RAP 1.5M4 [message #780948 is a reply to message #780925] Fri, 20 January 2012 07:07 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Raj,
did you install RAP Tooling 1.5M4 [1]?
[1] http://www.eclipse.org/rap/downloads/
Best,
Ivan

On 1/20/2012 1:26 AM, Raj wrote:
> Hi
>
> I am trying to run the RAP 1.5M4 on Eclipse 4.2(Juno). But i do not
> get the option for running the RAP application.(Run - Run
> Configuration - RAP Application)is missing. So i am not able to launch
> the application.
>
> Is anyone able to run the app?
>
> Thanks
> Raj
>

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Installation issue RAP 1.5M4 [message #782386 is a reply to message #780948] Mon, 23 January 2012 16:29 Go to previous message
Raj  is currently offline Raj Friend
Messages: 74
Registered: August 2011
Member
Yes, it is working now.

Thanks
Raj
Previous Topic:Initializing the indicator
Next Topic:About perspective in RAP
Goto Forum:
  


Current Time: Wed Oct 20 02:07:56 GMT 2021

Powered by FUDForum. Page generated in 0.02143 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top