Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Target Management » RSE - Connecting to a server via SSH(SSH Connection Failing)
RSE - Connecting to a server via SSH [message #755855] Wed, 09 November 2011 20:11
Chris King is currently offline Chris KingFriend
Messages: 1
Registered: November 2011
Junior Member
Hi Guys,
I have two ssh connections setup on my RSE window.
One connection works, this one uses a standard ssh port.
The Second does not connect, upon trying to connect I get this error stack

!ENTRY org.eclipse.rse.ui 4 0 2011-11-09 19:38:01.711
!MESSAGE RSEG1066U: SUB#0:timeout: socket is not established
com.jcraft.jsch.JSchException: timeout: socket is not established
at com.jcraft.jsch.Util.createSocket(
at com.jcraft.jsch.Session.connect(
at org.eclipse.rse.internal.connectorservice.ssh.SshConnectorService.internalConnect(
at org.eclipse.rse.core.subsystems.AbstractConnectorService.connect(
at org.eclipse.rse.ui.operations.SystemFetchOperation.execute(
at org.eclipse.rse.ui.view.AbstractSystemViewAdapter.fetchDeferredChildren(

In the interface when I try to browse the server it just says "fetching children" for a minute or so and I get the following error in a dialog box "Operation failed with exception 'timeout: socket is not established'"

I should mention that this connection does require a non standard ssh port of 2020 that I have set by right clicking on sftp -> properties -> subsystem -> port.

So its almost (at a guess) the port isnt being configured properly as a standard ssh connection to a server works and another connection setup in exactly the same way using a non standard port doesnt.

I can also confirm that I can connect to this server on the same pc using both filezilla and ssh on a terminal, so I am assuming that rules out firewalls etc.
I have also tried restarting eclipse, deleting and remaking the connection and using a fresh new workspace and creating a new connection there... nothing so far has worked.

Any advice would be great.



Previous Topic:How to escalate to root over a remote SSH session to sshd-allowed non-root user?
Next Topic:SSH/SFTP to support "sudo -u <user> sudosh" on login
Goto Forum:

Current Time: Mon Sep 26 06:42:46 GMT 2022

Powered by FUDForum. Page generated in 0.02100 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top