Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Still get nothing to build error
Still get nothing to build error [message #755841] Wed, 09 November 2011 19:04 Go to next message
serkan.ozer is currently offline serkan.ozerFriend
Messages: 1
Registered: November 2011
Junior Member
I am getting this error when im trying to run a project.I added the C:\mingw\bin to my path variable and here is my path variable C:\Program Files (x86)\MiKTeX 2.9\miktex\bin;%CommonProgramFiles%\Microsoft Shared\Windows Live;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\FPC\2.4.4\bin\i386-Win32;C:\MinGW\bin;

After I build the project " nothing to build for x " is printed on console and suddenly it disappears resulting with a blank screen instead of an output. Only time I got the output properly is that I manually add a path variable(C:\mingw\bin ) in run configurations but I don't want to make this for every different file. Please help.

##I am using windows 7 64 bit by the way.
Re: Still get nothing to build error [message #756422 is a reply to message #755841] Sun, 13 November 2011 07:21 Go to previous messageGo to next message
Gerald Kozina is currently offline Gerald KozinaFriend
Messages: 7
Registered: November 2011
Junior Member
If it built once, then you may still have .obj's and an .exe
Try using the clean option to delete them and rebuild.

I see the same problem with MinGW.

For Visual C the problem is worse, I get no obj and no exe
and it tells me it has nothing to build any way.

But I can get visual C to build using an existing make file or
using a batch file that executes the build steps.

So far I have been quite frustrated as there seems no
easy way to get any information on why it does not see anything to build.
Or detail of the path it takes internally.

Re: Still get nothing to build error [message #829645 is a reply to message #756422] Mon, 26 March 2012 15:37 Go to previous messageGo to next message
TimMarc Cannon is currently offline TimMarc CannonFriend
Messages: 1
Registered: March 2012
Junior Member
I have exactly the same problem. I am making my first attempt to run a program under Eclipse. I am using C++ under Windows XP with the MinGW toolchain. I precisely followed the tutorial instructions for creating the "HelloWorld" program. When I attempt to run, I get the error "Nothing to build for HelloWorld".

The executable gets created. I have tried running it directly (outside the Eclipse debugger), and I get the message: "libgcc_s_dw2-1.dll was not found". Since that file is on mingw\bin, I suspect there may be a problem with my path.

There are still some things I can try. But I think the best option may be to use a different SDK.
Re: Still get nothing to build error [message #1402973 is a reply to message #829645] Sat, 19 July 2014 03:40 Go to previous messageGo to next message
Cesar Gonzales is currently offline Cesar GonzalesFriend
Messages: 1
Registered: July 2014
Junior Member
I had the same problem. I finally resolved everything by carefully following the directions for installing MinGW which require that you install the C and C++ compilers and MSYS basic system, and MinGW developer toolk packages. Also make sure that C:\MinGW\bin;C:\MinGW\msys\1.0\bin are added to your Path system variables. Insuring all of these did the trick for me.
Re: Still get nothing to build error [message #1726775 is a reply to message #1402973] Wed, 16 March 2016 12:30 Go to previous messageGo to next message
Desmond McCabe is currently offline Desmond McCabeFriend
Messages: 1
Registered: March 2016
Junior Member
I had this problem and must have searched every thread for a solution. In the end my problem was with the compiler installation minGW . When installing this ensure that your virus protection is turned off as this can prevent some of the dll files from being downloaded and will not flag up an error.
After installing the compiler without the virus protection, reinstall eclipse and it should work. I had tried everything else before that and nothing worked.
But now thankfully it has . Good luck
Re: Still get nothing to build error [message #1833187 is a reply to message #1402973] Tue, 06 October 2020 07:43 Go to previous messageGo to next message
Nishith Thottam is currently offline Nishith ThottamFriend
Messages: 3
Registered: October 2020
Junior Member
Will u please elaborate how you did it. Its been several days , still couldn't figure it out. Help please.
Re: Still get nothing to build error [message #1837718 is a reply to message #1833187] Thu, 04 February 2021 16:23 Go to previous message
Rohan Kshirsagar is currently offline Rohan KshirsagarFriend
Messages: 1
Registered: February 2021
Junior Member
You are probably missing DOING "Refresh" after "Build".
Right click on project and "Refresh" or just "press F5" after building the project.
You need to do this just once
Previous Topic:paths and symbols missing
Next Topic:Adding a new module as a dependency
Goto Forum:

Current Time: Sat Aug 13 15:44:51 GMT 2022

Powered by FUDForum. Page generated in 0.02581 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top