Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Broken Code Folding(It was working before but has now stopped. Only for that file!)
Broken Code Folding [message #755797] Wed, 09 November 2011 15:49 Go to next message
Khono is currently offline KhonoFriend
Messages: 5
Registered: November 2011
Location: Ontario, Canada
Junior Member
I'm not even certain what I'm referring to is called code folding. It's from the small graphical + and - signs in the left-hand column that collapse sections of code.

I'm using:

"Eclipse IDE for Java Developers

Version: Indigo Service Release 1
Build id: 20110916-0149"

with pydev for programming in python.

I checked Window>>Preferences>PyDev>Editor>Code Folding
and code folding is still check with all of the optional code segments to fold still checked. I tried unchecking, pressing OK, then checking it again and pressing enter. No dice.

The code folding worked well before today. Today, I double clicked the shortcut for eclipse but I didn't see a 'wait' graphic on my cursor so double clicked again. I got an error about the workspace already in use and it prompted me to open a new one, to which I hit cancel and thought all was well.

I started using eclipse as normal but, at some point, found that the dropdown menus weren't showing their options until I moused over them (then they properly appeared on the screen). They were otherwise functional. This was limited to eclipse and hadn't happened before. I kept using eclipse for another hour or so without further issues. Code folding still functioned at this time. I then discovered that, after deleting a function, the folding icon didn't go away. At some point, possibly at this time or possibly earlier, I restarted eclipse and the problem(s) remained.

I restarted the computer and tried booting up eclipse again. The menu dropdowns now worked fine but I noticed that all the code folding icons were gone. Again, don't know how to restore them.

----------------------------------------------------------------

EDIT: I just opened up an earlier version of my program and found that it still has its code folding icons. SO it seems to just be a setting that got changed somewhere but I have no idea where it is! Sorry if this is a PyDev issue... I have no idea if it is or not. But any assistance would be greatly appreaciated as I don't want to try to navigate unfolded 780 line + program Sad

----------------------------------------------------------------

EDIT 11:54am EST, 9 Nov, 2011: The plot thickens. Since other files still have functional (seems to be fully functional with no problems) code wrapping, I decided to try to copy-paste my latest version into a new file. Doing so in eclipse didn't solve the problem. Doing so into notepad and saving it as a slightly different filename then loading it into eclipse didn't fix it either!

So I next tried to create some new functions to see if they'd gain folding. They did but it's very glitchy. The function doesn't get a folding icon but the if statements in there do. However, folding it only folds the first line in the if statement, not the entire statement.

So I went into a file that's working properly and tried creating new functions there. They work exactly as I believe they're supposed to, none of the bugs in the other files. I have NO IDEA how the bug transferred into notepad then back into eclipse.

Now I just tried creating a new source file. Worked fine. I tried copying and pasting my program into that file. The wrapping still worked for the original code but none were generated for the old code. Creating a new function in the pasted old code does not create any (even glitchy) code wrapping.

*pulls hair out*

I'm now pretty sure this is PyDev so I'm gonna ask this question there, if I can.

----------------------------------------------------------------

Edit 1:14 EST, 9 Nov: Okay so I tried uninstalling pydev and reinstalling. No change. I deleted eclipse, downloaded a new copy, installed pydev, set things up. Same thing.

I started to do trial and error to find out what is 'breaking' the file so that it stops code folding. So far no luck and it looks like it's going to be VERY slow going. I did notice some other things, however. When code wrapping starts to fail, brackets are still automatically added when creating a new function, as well as the colon, but they don't get overwritten automatically if I type them out manually anyway.

So, when working properly, if I write:
def test(

then it will autocomplete and make it:
def test():

If I continue typing with the cursor in between the brackets, the bracket and colon I type will overwrite the bracket and colon that were put there automatically. But if it's gotten glitched again, they will NOT be overwritten, resulting in:
def test():):


So, the reason I'm even mentioning this is that it seems like something in the eclipse or pydev program is getting jammed and other tasks somehow related to that (like everything in one class, maybe?) also stops working. Just more info that might help someone help me fix this.

[Updated on: Wed, 09 November 2011 18:25]

Report message to a moderator

Re: Broken Code Folding [message #755843 is a reply to message #755797] Wed, 09 November 2011 19:13 Go to previous message
Khono is currently offline KhonoFriend
Messages: 5
Registered: November 2011
Location: Ontario, Canada
Junior Member
FOUND THE CAUSE!!

Editing a list of strings I'd created, the apostrophes got all kinds of weird moved around automatically as eclipse/pydev tried to do something or other to make things "easier" for me and in the process of dealing with that, using \' to escape character the apostrophe, a bracket got shifted one spot to the right, putting it outside the closing apostrophe for that string. Fixing that little bug returned, what appears to be, complete functionality of eclipse to me.

*sigh* Far too much time and aggravation just for that Sad
Previous Topic:Creating an AVD
Next Topic:ATG development tool for eclipse
Goto Forum:
  


Current Time: Mon Jun 14 07:29:05 GMT 2021

Powered by FUDForum. Page generated in 0.02610 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top