Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to Install Plugins from Repositories(Unable to Install Plugins from Repositories)
Unable to Install Plugins from Repositories [message #755731] Wed, 09 November 2011 12:14
Adam  is currently offline Adam Friend
Messages: 1
Registered: November 2011
Junior Member
Operating System: Windows 7 Home Premium

Installation fails whenever I try to install software from a repository.

The one I am currently trying to install from is: <removed>://subclipse.tigris.org/update_1.8.x

The installation process gets to about 45%, hangs for several minutes, then spits out this error message.

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at <removed>://subclipse.tigris.org/update_1.8.x/plugins/org.tigris.subversion.clientadapter.javahl_1.7.1.1.jar.
Read timed out
Unable to read repository at <removed>://subclipse.tigris.org/update_1.8.x/plugins/org.tigris.subversion.clientadapter.javahl.win64_1.7.1.1.jar.
Connection reset
Unable to read repository at <removed>://subclipse.tigris.org/update_1.8.x/plugins/org.tigris.subversion.subclipse.core_1.8.2.jar.
Connection reset
Unable to read repository at <removed>://subclipse.tigris.org/update_1.8.x/plugins/org.tigris.subversion.subclipse.doc_1.3.0.jar.
Connection reset
Unable to read repository at <removed>://subclipse.tigris.org/update_1.8.x/plugins/org.tigris.subversion.subclipse.ui_1.8.2.jar.
Connection reset


I am able to access these files through web browsers, and even the internal browser in eclipse. I get this same type of message, no matter what I am trying to install. Even when trying to do a software update, a similar message appears.

I downloaded and reinstalled a fresh copy of eclipse from here: <removed>://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/indigo/SR1/eclipse-jee-indigo-SR1-win32-x86_64.zip

I got this error report once I unzipped the contents:
!SESSION 2011-11-09 01:57:24.727 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2011-11-09 01:57:25.335
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1386)




I seriously have no idea what else I can do to get this working.
Previous Topic:Eclipse build path library not being updated
Next Topic:The specified JRE installation does not exist
Goto Forum:
  


Current Time: Sat Jun 19 10:34:05 GMT 2021

Powered by FUDForum. Page generated in 0.02721 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top