Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] problem with with xmi output
[ATL] problem with with xmi output [message #83782] Fri, 06 June 2008 14:04
Eclipse UserFriend
Originally posted by: mjakubowski84.gmail.com

Hello Everyone!

I have a problem with the result of my transformation to UML 2.1 file.
When I run it from ant file then everything is OK. But, when I run my
transofrmation from Java code then I obtain the same data but in XMI 2.0!
Correct version is XMI 2.1. What could I have done wrong? How can I change
the output format in Java?

Below is a fragment of my code:

umlMetamodelRes = URI.createURI("http://www.eclipse.org/uml2/2.1.0/UML",
false);

umlMetamodel = (ASMEMFModel) modelHandler.loadModel("UML", modelHandler
.getMof(), umlMetamodelRes);

mdl2umlLib = ATLRunner.class.getClassLoader().getResource(
"atl/MDL2UML21.asm");
[...]

ASMEMFModel umlOutputModel = (ASMEMFModel) modelHandler.newModel("OUT",
location.toString(), umlMetamodel);

AtlLauncher.getDefault().launch(this.mdl2umlLib, libs, models,
Collections.EMPTY_MAP, Collections.EMPTY_LIST, Collections.EMPTY_MAP);

[...]

Thanks in advance!
Previous Topic:[QVT] Call QVT from Java code/command line
Next Topic:[QVT XSD EMF] How to get a xsd complexType from a model
Goto Forum:
  


Current Time: Mon May 27 09:53:58 GMT 2019

Powered by FUDForum. Page generated in 0.01770 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top