Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » All Eclipse Plugins Have Vanished
All Eclipse Plugins Have Vanished [message #749953] Tue, 25 October 2011 14:38
chrisspen is currently offline chrisspenFriend
Messages: 1
Registered: October 2011
Junior Member
I'm running Eclipse 3.5.2 on Ubuntu 10.04. I tried to install the EGit plugin for Eclipse, and after Eclipse restarted, I found *all* plugins had effectively vanished (Subclipse, PyDev, Webtools, C/C++ Dev, OpenExtern, Colorer, etc). Oddly enough, Eclispe still lists them all as installed, but their functionality is no longer apparent anywhere. PyDev still shows in the "Open Perspective" menu, but clicking it does nothing. No plugin functionality is shown in the File->Project menu or on right-click context menus.

If I run `eclipse -clean -debug -consolelog`, I see the following error for each project I checked out through Subclipse:

!ENTRY 4 0 2011-10-25 09:52:36.022
!MESSAGE Could not instantiate provider org.tigris.subversion.subclipse.core.svnnature for project myproject.
!STACK 1 Could not instantiate provider org.tigris.subversion.subclipse.core.svnnature for project myproject.
	at org.eclipse.ui.internal.decorators.LightweightDecoratorDefinition.decorate(
	at org.eclipse.ui.internal.decorators.LightweightDecoratorManager$
	at org.eclipse.ui.internal.decorators.LightweightDecoratorManager.decorate(
	at org.eclipse.ui.internal.decorators.LightweightDecoratorManager.getDecorations(
	at org.eclipse.ui.internal.decorators.DecorationScheduler$1.ensureResultCached(
	at org.eclipse.ui.internal.decorators.DecorationScheduler$

Apparently it's a been a known issue for years, but nobody's done anything about it, nor figured out how to resolve it.

I've tried uninstalling EGit.

I tried going to Help->About->Installation Details->Installation History and reverted to the day before this issue appeared.

I tried installing all updates listed in Eclipse's update dialog.

I tried deleting my ~/.eclipse folder and reinstalling the plugins.

Nothing has worked.

I've found a few similar posts about it, but I haven't seen any fixes mentioned, short of uninstalling and reinstalling the ENTIRE Eclipse install.

This is driving me nuts. Does anyone know what's caused this, and how I might fix it?

Note, I would have posted relevant links to similar issues reported, but this forum apparently requires that have a long history before allowing me to do so...sigh.
Previous Topic:Why application run fail when share same workspace for two eclipse product?
Next Topic:Where are the source build scripts???
Goto Forum:

Current Time: Mon Sep 28 13:37:54 GMT 2020

Powered by FUDForum. Page generated in 0.01741 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top