Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] exporting plugin doesn't work
[ATL] exporting plugin doesn't work [message #82832] Fri, 30 May 2008 08:34 Go to next message
Eclipse UserFriend
Originally posted by: r.c.ladan.tue.nl

Hi,

I tried to export the latest CVS version (2008-05-30) as a plugin (individual files), but it fails with this message:

Problems during export
C:\Documents and Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:119: The following error occurred while executing this line:
C:\Documents and Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20: The following error occurred while executing this line:
C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67: Execute failed: java.io.IOException: Cannot run program "sh" (in directory "C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc"): CreateProcess error=2, The system cannot find the file specified
The following error occurred while executing this line:
C:\Documents and Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20: The following error occurred while executing this line:
C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67: Execute failed: java.io.IOException: Cannot run program "sh" (in directory "C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc"): CreateProcess error=2, The system cannot find the file specified
C:\Documents and Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:119: The following error occurred while executing this line:
C:\Documents and Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20: The following error occurred while executing this line:
C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67: Execute failed: java.io.IOException: Cannot run program "sh" (in directory "C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc"): CreateProcess error=2, The system cannot find the file specified
The following error occurred while executing this line:
C:\Documents and Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20: The following error occurred while executing this line:
C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67: Execute failed: java.io.IOException: Cannot run program "sh" (in directory "C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc"): CreateProcess error=2, The system cannot find the file specified

I included the following projects:
org.eclipse.m2m.atl
org.eclipse.m2m.atl-feature
org.eclipse.m2m.atl.doc-feature
org.eclipse.m2m.atl.drivers.mdr4atl-feature
org.eclipse.m2m.atl.examples-feature
org.eclipse.m2m.atl.sdk-feature
org.eclipse.m2m.atl.tests-feature
org.antlr.runtime
org.eclipse.m2m.atl.adt.builder
org.eclipse.m2m.atl.adt.debug
org.eclipse.m2m.atl.adt.editor
org.eclipse.m2m.atl.adt.perspective
org.eclipse.m2m.atl.adt.wizard
org.eclipse.m2m.atl.compilers.atl2006
org.eclipse.m2m.atl.doc
org.eclipse.m2m.atl.drivers.emf4atl
org.eclipse.m2m.atl.drivers.mdr4atl
org.eclipse.m2m.atl.drivers.uml24atl
org.eclipse.m2m.atl.engine
org.eclipse.m2m.atl.engine.emfvm
org.eclipse.m2m.atl.engine.vm
org.eclipse.m2m.atl.examples
org.eclipse.m2m.atl.ocl.core
org.eclipse.m2m.atl.service.core


org.eclipse.m2m.atl.tests was excluded, because it contains build errors (missing EMF plugin?) :
Bundle 'org.eclipse.emf.compare.diff' cannot be resolved
Bundle 'org.eclipse.emf.compare.match' cannot be resolved

Regards,
Rene
Re: [ATL] exporting plugin doesn't work [message #82867 is a reply to message #82832] Fri, 30 May 2008 08:46 Go to previous messageGo to next message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
Hello,

The doc plugin uses an external script to export itself, in order to
build the Javadoc. That's why you encounter this error.
So to correctly export the plugins the best thing is to avoid the doc
plugin.

Best regards,

William

Rene Ladan a écrit :
> Hi,
>
> I tried to export the latest CVS version (2008-05-30) as a plugin
> (individual files), but it fails with this message:
>
> Problems during export
> C:\Documents and
> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:119:
> The following error occurred while executing this line:
> C:\Documents and
> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20:
> The following error occurred while executing this line:
> C:\Documents and
> Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67: Execute
> failed: java.io.IOException: Cannot run program "sh" (in directory
> "C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc"):
> CreateProcess error=2, The system cannot find the file specified
> The following error occurred while executing this line:
> C:\Documents and
> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20:
> The following error occurred while executing this line:
> C:\Documents and
> Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67: Execute
> failed: java.io.IOException: Cannot run program "sh" (in directory
> "C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc"):
> CreateProcess error=2, The system cannot find the file specified
> C:\Documents and
> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:119:
> The following error occurred while executing this line:
> C:\Documents and
> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20:
> The following error occurred while executing this line:
> C:\Documents and
> Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67: Execute
> failed: java.io.IOException: Cannot run program "sh" (in directory
> "C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc"):
> CreateProcess error=2, The system cannot find the file specified
> The following error occurred while executing this line:
> C:\Documents and
> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20:
> The following error occurred while executing this line:
> C:\Documents and
> Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67: Execute
> failed: java.io.IOException: Cannot run program "sh" (in directory
> "C:\Documents and Settings\rladan\workspace\org.eclipse.m2m.atl.doc"):
> CreateProcess error=2, The system cannot find the file specified
>
> I included the following projects:
> org.eclipse.m2m.atl
> org.eclipse.m2m.atl-feature
> org.eclipse.m2m.atl.doc-feature
> org.eclipse.m2m.atl.drivers.mdr4atl-feature
> org.eclipse.m2m.atl.examples-feature
> org.eclipse.m2m.atl.sdk-feature
> org.eclipse.m2m.atl.tests-feature
> org.antlr.runtime
> org.eclipse.m2m.atl.adt.builder
> org.eclipse.m2m.atl.adt.debug
> org.eclipse.m2m.atl.adt.editor
> org.eclipse.m2m.atl.adt.perspective
> org.eclipse.m2m.atl.adt.wizard
> org.eclipse.m2m.atl.compilers.atl2006
> org.eclipse.m2m.atl.doc
> org.eclipse.m2m.atl.drivers.emf4atl
> org.eclipse.m2m.atl.drivers.mdr4atl
> org.eclipse.m2m.atl.drivers.uml24atl
> org.eclipse.m2m.atl.engine
> org.eclipse.m2m.atl.engine.emfvm
> org.eclipse.m2m.atl.engine.vm
> org.eclipse.m2m.atl.examples
> org.eclipse.m2m.atl.ocl.core
> org.eclipse.m2m.atl.service.core
>
>
> org.eclipse.m2m.atl.tests was excluded, because it contains build errors
> (missing EMF plugin?) :
> Bundle 'org.eclipse.emf.compare.diff' cannot be resolved
> Bundle 'org.eclipse.emf.compare.match' cannot be resolved
>
> Regards,
> Rene
Re: [ATL] exporting plugin doesn't work [message #82956 is a reply to message #82867] Fri, 30 May 2008 14:09 Go to previous message
Eclipse UserFriend
Originally posted by: r.c.ladan.tue.nl

William Piers wrote:
> Hello,
>
> The doc plugin uses an external script to export itself, in order to
> build the Javadoc. That's why you encounter this error.
> So to correctly export the plugins the best thing is to avoid the doc
> plugin.
>
Thanks, it works now.

Rene

> Best regards,
>
> William
>
> Rene Ladan a écrit :
>> Hi,
>>
>> I tried to export the latest CVS version (2008-05-30) as a plugin
>> (individual files), but it fails with this message:
>>
>> Problems during export
>> C:\Documents and
>> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:119:
>> The following error occurred while executing this line:
>> C:\Documents and
>> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20:
>> The following error occurred while executing this line:
>> C:\Documents and
>> Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67:
>> Execute failed: java.io.IOException: Cannot run program "sh" (in
>> directory "C:\Documents and
>> Settings\rladan\workspace\org.eclipse.m2m.atl.doc"): CreateProcess
>> error=2, The system cannot find the file specified
>> The following error occurred while executing this line:
>> C:\Documents and
>> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20:
>> The following error occurred while executing this line:
>> C:\Documents and
>> Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67:
>> Execute failed: java.io.IOException: Cannot run program "sh" (in
>> directory "C:\Documents and
>> Settings\rladan\workspace\org.eclipse.m2m.atl.doc"): CreateProcess
>> error=2, The system cannot find the file specified
>> C:\Documents and
>> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:119:
>> The following error occurred while executing this line:
>> C:\Documents and
>> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20:
>> The following error occurred while executing this line:
>> C:\Documents and
>> Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67:
>> Execute failed: java.io.IOException: Cannot run program "sh" (in
>> directory "C:\Documents and
>> Settings\rladan\workspace\org.eclipse.m2m.atl.doc"): CreateProcess
>> error=2, The system cannot find the file specified
>> The following error occurred while executing this line:
>> C:\Documents and
>> Settings\rladan\workspace\.metadata\.plugins\org.eclipse.pde .core\temp\org.eclipse.pde.container.feature\build.xml:20:
>> The following error occurred while executing this line:
>> C:\Documents and
>> Settings\rladan\workspace\org.eclipse.m2m.atl.doc\build.xml: 67:
>> Execute failed: java.io.IOException: Cannot run program "sh" (in
>> directory "C:\Documents and
>> Settings\rladan\workspace\org.eclipse.m2m.atl.doc"): CreateProcess
>> error=2, The system cannot find the file specified
>>
>> I included the following projects:
>> org.eclipse.m2m.atl
>> org.eclipse.m2m.atl-feature
>> org.eclipse.m2m.atl.doc-feature
>> org.eclipse.m2m.atl.drivers.mdr4atl-feature
>> org.eclipse.m2m.atl.examples-feature
>> org.eclipse.m2m.atl.sdk-feature
>> org.eclipse.m2m.atl.tests-feature
>> org.antlr.runtime
>> org.eclipse.m2m.atl.adt.builder
>> org.eclipse.m2m.atl.adt.debug
>> org.eclipse.m2m.atl.adt.editor
>> org.eclipse.m2m.atl.adt.perspective
>> org.eclipse.m2m.atl.adt.wizard
>> org.eclipse.m2m.atl.compilers.atl2006
>> org.eclipse.m2m.atl.doc
>> org.eclipse.m2m.atl.drivers.emf4atl
>> org.eclipse.m2m.atl.drivers.mdr4atl
>> org.eclipse.m2m.atl.drivers.uml24atl
>> org.eclipse.m2m.atl.engine
>> org.eclipse.m2m.atl.engine.emfvm
>> org.eclipse.m2m.atl.engine.vm
>> org.eclipse.m2m.atl.examples
>> org.eclipse.m2m.atl.ocl.core
>> org.eclipse.m2m.atl.service.core
>>
>>
>> org.eclipse.m2m.atl.tests was excluded, because it contains build
>> errors (missing EMF plugin?) :
>> Bundle 'org.eclipse.emf.compare.diff' cannot be resolved
>> Bundle 'org.eclipse.emf.compare.match' cannot be resolved
>>
>> Regards,
>> Rene
Previous Topic:[ATL] How to trace the ATL rules
Next Topic:ATL: reserved keyword name clash
Goto Forum:
  


Current Time: Sat Oct 19 20:38:24 GMT 2019

Powered by FUDForum. Page generated in 0.01868 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top