Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Source Format and PHP Outline
Source Format and PHP Outline [message #81915] Tue, 14 October 2008 14:36 Go to next message
No real name is currently offline No real nameFriend
Messages: 1
Registered: July 2009
Junior Member
hi,

i'm new to this newsgroup and to Eclipse with PDT. i hope this is the
right place to ask my questions :)

i've got Ganymede with the latest PDT 2.0 integration build
(I200809241021) and like it so far. however, there are two things i would
like to change to make me perfectly happy.

first, i think the "source format" action is really great, but there are
some annoyances in the resulting code style. for example,
if(foobar)
____func();
turns into
if(foobar)
func();

(the underscores represent a tab, just in case this post would lose its
formatting)

where can i change the formatting rules?

the other thing is that i would like the PHP Outline to show all classes
in the whole project, not only those defined in the current file. what do
i have to do to make it work this way?

thank you in advance
Re: Source Format and PHP Outline [message #82168 is a reply to message #81915] Fri, 17 October 2008 01:29 Go to previous message
Eclipse UserFriend
Originally posted by: euthanasia_waltzNOSPAM.yahoo.co.jp

PDT doesn't support ordinary 'format' but it may be resolved some day.
See
Bug 187517 -- Indentation of IF Statements without brackets
https://bugs.eclipse.org/bugs/show_bug.cgi?id=187517
also
Bug 155227 -- Incorrect indentation of an IF statement if no brackets.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=155227
Bug 156373 -- Document format indents
https://bugs.eclipse.org/bugs/show_bug.cgi?id=156373

PHP Project Outline is under regression now in beta ;-)
See
Bug 240283 -- [regression] The button 'Show Groups' is missing in Outline
view
https://bugs.eclipse.org/bugs/show_bug.cgi?id=240283
Bug 240591 -- [regression] php project outline is missing the groups + it
behaves as regular outline
https://bugs.eclipse.org/bugs/show_bug.cgi?id=240591
Bug 250540 -- [regression] project outline displays content only when
editor is open
https://bugs.eclipse.org/bugs/show_bug.cgi?id=250540
etc.
Previous Topic:newPhp templates not working
Next Topic:PDT and Galileo
Goto Forum:
  


Current Time: Thu Feb 02 14:22:13 GMT 2023

Powered by FUDForum. Page generated in 0.02307 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top