Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Supporting multiple versions of Eclipse(I would like to be able to run one piece of code in version 3.5 and above and another in earlier versions.)
icon5.gif  Supporting multiple versions of Eclipse [message #740259] Tue, 18 October 2011 10:12
Alan Missing name is currently offline Alan Missing nameFriend
Messages: 17
Registered: November 2010
Junior Member

I have a a set of Eclipse plugins that make up a feature and I am trying to support version 3.1 or 3.2 of Eclipse as a baseline.

The problem I have is that one part of my code relies on version 3.5 or above of org.eclipse.ui. I have alternative code that works on earlier versions but I would rather not use it if I don't have to (performance reasons).

Is there a way that I can use the new code when Eclipse 3.5 or greater is being used and the alternative code when older versions of Eclipse are being used?

I have tried splitting my project up so that I have two identical classes in two different plugins (one targets 3.5 and above and the other targets 3.1 and above). This works in version 3.5 and above but not anything earlier because it is still trying to load the plugin that has been targeted towards 3.5.

Can anyone help?

Previous Topic:how to create an IFile in the same IFolder of another IFile?
Next Topic:Get something similar to bundleClasspathResolvers for development/compilation-time
Goto Forum:

Current Time: Wed Jun 29 11:03:20 GMT 2022

Powered by FUDForum. Page generated in 0.01929 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top