Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [teneo] EMF 2.2.1 vs EMF 2.3.x for Teneo 0.8x
[teneo] EMF 2.2.1 vs EMF 2.3.x for Teneo 0.8x [message #80787] Mon, 23 April 2007 21:03 Go to next message
Julia is currently offline JuliaFriend
Messages: 85
Registered: July 2009
Member
Hi,

Would Teneo 0.8x still work if I run it on EMF 2.2.1? I'm trying to get
teneo incorporated in my WebSphere application and it is currently using
EMF 2.2.1. Upgrading the EMF version in WebSphere is out of my hands...

Julia
Re: [teneo] EMF 2.2.1 vs EMF 2.3.x for Teneo 0.8x [message #80798 is a reply to message #80787] Mon, 23 April 2007 21:49 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Julia,
My best advice is to try it out, emf 2.3 and emf 2.2 are practically binary compatible. So using
Teneo as a jar file should work. However, another user reported problems that the teneo plugins
don't show up in the dependencies of other plugins (It's a post from Mark Geib on the 19th of
febr.). See also my reply for the differences between 0.7.5 and 0.8.0. I do not know if in the end
it all worked fine for Mark.

gr. Martin

Julia wrote:
> Hi,
>
> Would Teneo 0.8x still work if I run it on EMF 2.2.1? I'm trying to get
> teneo incorporated in my WebSphere application and it is currently using
> EMF 2.2.1. Upgrading the EMF version in WebSphere is out of my hands...
>
> Julia
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [teneo] EMF 2.2.1 vs EMF 2.3.x for Teneo 0.8x [message #80850 is a reply to message #80798] Tue, 24 April 2007 15:42 Go to previous message
Mark Geib is currently offline Mark GeibFriend
Messages: 432
Registered: July 2009
Senior Member
Martin,

I continued to have trouble with the Teneo plugins for 0.8.0 not appearing
in the list of available plugins when running Eclipse 3.2.2/EMF 2.2.0 on
Linux. I had no trouble on Windows XP.

I do most of my developing on Linux, and deploy on Windows. So, in the end
I decided to move to Eclipse 3.3M6/EMF ?? and now everything works great
on all platforms.

I am sorry, but I did not take the time to figure out what was wrong on
Linux. I believe the trouble started after an auto update of the
Eclipse/EMF/GEF plugins. I think everything was working on both Linux and
Windows with Eclipse 3.2.1 and EMF 2.1.0.

Mark.
Re: [teneo] EMF 2.2.1 vs EMF 2.3.x for Teneo 0.8x [message #604949 is a reply to message #80787] Mon, 23 April 2007 21:49 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Julia,
My best advice is to try it out, emf 2.3 and emf 2.2 are practically binary compatible. So using
Teneo as a jar file should work. However, another user reported problems that the teneo plugins
don't show up in the dependencies of other plugins (It's a post from Mark Geib on the 19th of
febr.). See also my reply for the differences between 0.7.5 and 0.8.0. I do not know if in the end
it all worked fine for Mark.

gr. Martin

Julia wrote:
> Hi,
>
> Would Teneo 0.8x still work if I run it on EMF 2.2.1? I'm trying to get
> teneo incorporated in my WebSphere application and it is currently using
> EMF 2.2.1. Upgrading the EMF version in WebSphere is out of my hands...
>
> Julia
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [teneo] EMF 2.2.1 vs EMF 2.3.x for Teneo 0.8x [message #604995 is a reply to message #80798] Tue, 24 April 2007 15:42 Go to previous message
Mark Geib is currently offline Mark GeibFriend
Messages: 432
Registered: July 2009
Senior Member
Martin,

I continued to have trouble with the Teneo plugins for 0.8.0 not appearing
in the list of available plugins when running Eclipse 3.2.2/EMF 2.2.0 on
Linux. I had no trouble on Windows XP.

I do most of my developing on Linux, and deploy on Windows. So, in the end
I decided to move to Eclipse 3.3M6/EMF ?? and now everything works great
on all platforms.

I am sorry, but I did not take the time to figure out what was wrong on
Linux. I believe the trouble started after an auto update of the
Eclipse/EMF/GEF plugins. I think everything was working on both Linux and
Windows with Eclipse 3.2.1 and EMF 2.1.0.

Mark.
Previous Topic:[Teneo] (newbie): More than one EClass with the same name
Next Topic:How to unregister a TransactionalEditingDomain?
Goto Forum:
  


Current Time: Mon Jan 18 08:59:57 GMT 2021

Powered by FUDForum. Page generated in 0.02008 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top