Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [Teneo] invalid Mapping Error / SAXParserException
[Teneo] invalid Mapping Error / SAXParserException [message #80526] Thu, 19 April 2007 17:14 Go to next message
Eclipse UserFriend
Originally posted by: cn.arcsolutions.de

Hi, im trying to migrate from eclipse 3.2 to 3.3 including the stepup to
Teneo 0.8. But since this change its imposible for me to generate a
mapping file. It always ends with following error:

Caused by: org.xml.sax.SAXParseException:
The content of element type "list" must match
(meta*,subselect?,cache?,synchronize*,comment?,key,
(index|list-index),(element|one-to-many|many-to-many|composi te-element|many-to-any),loader?,sql-insert?,sql-update?,sql- delete?,sql-delete-all?,filter*) ".

at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseExc eption
(Unknown Source)
at org.apache.xerces.util.ErrorHandlerWrapper.error(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.dtd.XMLDTDValidator.handleEndElement( Unknown
Source)
at org.apache.xerces.impl.dtd.XMLDTDValidator.endElement(Unknow n Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndEleme nt
(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$
FragmentContentDispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDo cument
(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at org.dom4j.io.SAXReader.read(SAXReader.java:465)
at org.dom4j.io.SAXReader.read(SAXReader.java:365)
at org.hibernate.cfg.Configuration.addXML(Configuration.java:43 5)

My runtime for Teneo 0.8 was eclipse 3.3 EMF 2.3 v20070329... and
Hibernate 3.2.2 ga . I've also tested it in eclipse 3.2.2 with EMF 2.2
v20060627... with the same error message.
I also tried to reload the model and IGNORE_EANNOTATIONS but after both
the error still occurs.
It seems to be a Teneo 0.8 problem, because after the switch back to
0.75 everything works fine.

Thanks in advance for any kind of help.
Christian
Re: [Teneo] invalid Mapping Error / SAXParserException [message #80541 is a reply to message #80526] Thu, 19 April 2007 17:27 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Christian,
Can you send me the hbm and the ecore? Then I can try it myself.

gr. Martin

Christian Neudert wrote:
> Hi, im trying to migrate from eclipse 3.2 to 3.3 including the stepup to
> Teneo 0.8. But since this change its imposible for me to generate a
> mapping file. It always ends with following error:
>
> Caused by: org.xml.sax.SAXParseException:
> The content of element type "list" must match
> (meta*,subselect?,cache?,synchronize*,comment?,key,
> (index|list-index),(element|one-to-many|many-to-many|composi te-element|many-to-any),loader?,sql-insert?,sql-update?,sql- delete?,sql-delete-all?,filter*) ".
>
>
> at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseExc eption
> (Unknown Source)
> at org.apache.xerces.util.ErrorHandlerWrapper.error(Unknown Source)
> at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
> at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
> at org.apache.xerces.impl.dtd.XMLDTDValidator.handleEndElement( Unknown
> Source)
> at org.apache.xerces.impl.dtd.XMLDTDValidator.endElement(Unknow n Source)
> at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndEleme nt
> (Unknown Source)
> at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$
> FragmentContentDispatcher.dispatch(Unknown Source)
> at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDo cument
> (Unknown Source)
> at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
> at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
> at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
> at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
> at org.dom4j.io.SAXReader.read(SAXReader.java:465)
> at org.dom4j.io.SAXReader.read(SAXReader.java:365)
> at org.hibernate.cfg.Configuration.addXML(Configuration.java:43 5)
>
> My runtime for Teneo 0.8 was eclipse 3.3 EMF 2.3 v20070329... and
> Hibernate 3.2.2 ga . I've also tested it in eclipse 3.2.2 with EMF 2.2
> v20060627... with the same error message.
> I also tried to reload the model and IGNORE_EANNOTATIONS but after both
> the error still occurs.
> It seems to be a Teneo 0.8 problem, because after the switch back to
> 0.75 everything works fine.
>
> Thanks in advance for any kind of help.
> Christian
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [Teneo] invalid Mapping Error / SAXParserException [message #604896 is a reply to message #80526] Thu, 19 April 2007 17:27 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Christian,
Can you send me the hbm and the ecore? Then I can try it myself.

gr. Martin

Christian Neudert wrote:
> Hi, im trying to migrate from eclipse 3.2 to 3.3 including the stepup to
> Teneo 0.8. But since this change its imposible for me to generate a
> mapping file. It always ends with following error:
>
> Caused by: org.xml.sax.SAXParseException:
> The content of element type "list" must match
> (meta*,subselect?,cache?,synchronize*,comment?,key,
> (index|list-index),(element|one-to-many|many-to-many|composi te-element|many-to-any),loader?,sql-insert?,sql-update?,sql- delete?,sql-delete-all?,filter*) ".
>
>
> at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseExc eption
> (Unknown Source)
> at org.apache.xerces.util.ErrorHandlerWrapper.error(Unknown Source)
> at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
> at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
> at org.apache.xerces.impl.dtd.XMLDTDValidator.handleEndElement( Unknown
> Source)
> at org.apache.xerces.impl.dtd.XMLDTDValidator.endElement(Unknow n Source)
> at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndEleme nt
> (Unknown Source)
> at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$
> FragmentContentDispatcher.dispatch(Unknown Source)
> at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDo cument
> (Unknown Source)
> at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
> at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
> at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
> at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
> at org.dom4j.io.SAXReader.read(SAXReader.java:465)
> at org.dom4j.io.SAXReader.read(SAXReader.java:365)
> at org.hibernate.cfg.Configuration.addXML(Configuration.java:43 5)
>
> My runtime for Teneo 0.8 was eclipse 3.3 EMF 2.3 v20070329... and
> Hibernate 3.2.2 ga . I've also tested it in eclipse 3.2.2 with EMF 2.2
> v20060627... with the same error message.
> I also tried to reload the model and IGNORE_EANNOTATIONS but after both
> the error still occurs.
> It seems to be a Teneo 0.8 problem, because after the switch back to
> 0.75 everything works fine.
>
> Thanks in advance for any kind of help.
> Christian
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Previous Topic:[Teneo] invalid Mapping Error / SAXParserException
Next Topic:EMFT-OQTV 1.0.1 Build Announcements
Goto Forum:
  


Current Time: Mon Jan 18 08:49:36 GMT 2021

Powered by FUDForum. Page generated in 0.01396 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top