Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » Generate UML2 model using api
Generate UML2 model using api [message #80477] Wed, 30 April 2008 02:53
Victor Hugo is currently offline Victor HugoFriend
Messages: 20
Registered: July 2009
Junior Member
Hi people!

i wanna to generate my uml2 model in xmi using coding, using uml24atl api.
i`m mergin two uml2 models that i read in program and should obtain
another uml2 model as result.
Actually i`m can get an empty xmi file, like that:
<?xml version="1.0" encoding="ISO-8859-1"?>
<xmi:XMI xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI"/>


i`m using these jars in :
<classpathentry kind="lib" path="lib_EMF/eclipse-uml2-1.1.1.jar"/>
<classpathentry kind="lib" path="lib_EMF/eclipse-uml2-common-1.1.1.jar"/>
<classpathentry kind="lib"
path="lib_EMF/eclipse-uml2-resources-1.1.0.jar"/>
<classpathentry kind="lib" path="lib/uml24atl.jar"/>
<classpathentry kind="lib" path="lib_EMF/emf-common-2.1.0.jar"/>
<classpathentry kind="lib" path="lib_EMF/emf-ecore.xmi-2.1.0.jar"/>
<classpathentry kind="lib" path="lib_EMF/emf-ecore-2.1.0.jar"/>

Someone can confirm if theses jars are correct? because i think that the
origin of problem is lib conflict.
grateful
Previous Topic:[ATL] allInstances() not delivering expected results, returns empty set instead
Next Topic:Error ATL launch with Ant tasks
Goto Forum:
  


Current Time: Wed Oct 16 18:46:16 GMT 2019

Powered by FUDForum. Page generated in 0.02199 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top