Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] error with oclAny
[ATL] error with oclAny [message #79200] Tue, 15 April 2008 11:01 Go to next message
Rasha is currently offline RashaFriend
Messages: 61
Registered: July 2009
Member
Hi all,

I try to copy some classes from a profiled source model to the target
model. I get this error

SEVERE: ERROR: get unsupported on OclAny.
java.lang.RuntimeException: ERROR: get unsupported on OclAny.
at
org.eclipse.m2m.atl.engine.vm.SimpleDebugger.error(SimpleDeb ugger.java:195)

Is this error means something wrong in my transformation code or a plug in
is missed.

Thanks very much in advance for your help.

Rasha
Re: [ATL] error with oclAny [message #79361 is a reply to message #79200] Wed, 16 April 2008 07:25 Go to previous messageGo to next message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------050007060306040804000703
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit

Hello,

Rasha a
Re: [ATL] error with oclAny [message #79521 is a reply to message #79361] Fri, 18 April 2008 02:32 Go to previous message
Rasha is currently offline RashaFriend
Messages: 61
Registered: July 2009
Member
Thanks William. The problem was in the getValue() method. I fixed the type
for its arguments. But I have another error

SEVERE: ****** BEGIN Stack Trace
SEVERE: exception:
SEVERE: null
java.lang.NullPointerException
at
org.eclipse.m2m.atl.drivers.uml24atl.ASMUMLModelElement.real Invoke(ASMUMLModelElement.java:624)
at
org.eclipse.m2m.atl.drivers.uml24atl.ASMUMLModelElement.invo ke(ASMUMLModelElement.java:581)
at
org.eclipse.m2m.atl.engine.vm.ASMOperation.realExec(ASMOpera tion.java:240)
at org.eclipse.m2m.atl.engine.vm.ASMOperation.exec(ASMOperation .java:171)
at
org.eclipse.m2m.atl.engine.vm.nativelib.ASMOclAny.invoke(ASM OclAny.java:143)
at
org.eclipse.m2m.atl.engine.vm.nativelib.ASMOclAny.invoke(ASM OclAny.java:101)

I think the problem is in these helpers as the rest of the code works fine
without them.

helper context UML!"uml::Element" def: getTaggedValue(stereo :
String ,tag : String) : UML!"uml::Element" =
self.getValue(self.getAppliedStereotype(stereo),tag);

helper context UML!"uml::Element" def : checkMyPropertyValue() : Boolean =
if (self.hasStereotype('MyStereotype')) then
if (self.getTaggedValue('MyStereotype','myProperty')-> exists (s| s.name
<> 'value1')) then ...


Any hint will be great,

Rasha
Previous Topic:[QVTO]Incompatible input type 'modelparam::ResourceEObject', expected 'uml::Model'
Next Topic:[QVTO] transforming profile-based models
Goto Forum:
  


Current Time: Sun Aug 18 23:27:40 GMT 2019

Powered by FUDForum. Page generated in 0.01732 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top