Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » eclipse does not recognize PIL module
eclipse does not recognize PIL module [message #731942] Mon, 03 October 2011 14:29 Go to next message
nethero  is currently offline nethero Friend
Messages: 1
Registered: October 2011
Junior Member
I'm running this code in Eclipse...

from PIL import Image
im = Image.open("download.png")
im.rotate(45).show()


This code runs using my command line python interpreter. My problem is that the PIL package always shows an error in Eclipse. It keeps saying that this import is "Unresolved" even though the code runs fine. Why is this happening? The /usr/lib/python2.7/dist-packages/PIL is in the System PYTHONPATH in Eclipse. I tried deleting and recreating the interpreter in Eclipse and there was still an error.

Using...
Eclipse 3.7
pyDev 2.2.2.2011082312
Ubuntu 11.04
python 2.7.1
Re: eclipse does not recognize PIL module [message #731963 is a reply to message #731942] Mon, 03 October 2011 14:43 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32440
Registered: July 2009
Senior Member
There might not be anyone here familiar with that. Likely you're better
off to ask here: https://lists.sourceforge.net/lists/listinfo/pydev-code

On 03/10/2011 7:29 AM, nethero wrote:
> I'm running this code in Eclipse...
>
> from PIL import Image
> im = Image.open("download.png")
> im.rotate(45).show()
>
> This code runs using my command line python interpreter. My problem is
> that the PIL package always shows an error in Eclipse. It keeps
> saying that this import is "Unresolved" even though the code runs
> fine. Why is this happening? The
> /usr/lib/python2.7/dist-packages/PIL is in the System PYTHONPATH in
> Eclipse. I tried deleting and recreating the interpreter in Eclipse
> and there was still an error.
>
> Using...
> Eclipse 3.7
> pyDev 2.2.2.2011082312
> Ubuntu 11.04
> python 2.7.1


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:How to use ยข
Next Topic:eclipse indigo 3.7.1 java EE IDE hangs
Goto Forum:
  


Current Time: Sun Aug 14 19:54:40 GMT 2022

Powered by FUDForum. Page generated in 0.02443 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top