Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Can't install by Update - wst.web_ui dependency
Can't install by Update - wst.web_ui dependency [message #77650] Sat, 02 August 2008 21:23 Go to next message
Poletto Guillaume is currently offline Poletto GuillaumeFriend
Messages: 4
Registered: July 2009
Junior Member
Hello,

I tried during some hours to find PDT dependencies to install it
through Software Update tool.
Now, i think the needed package is already installed but for some
reason, it doesn't "satisfy the requirements"

"Cannot complete the request. See the details.
Cannot find a solution satisfying the following requirements
Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.web_ui.feature.fea ture.group/[3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP ,3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP]]. "

I installed all the packages provided by the "Web Tools Project" update
site, and the "WST Web UI" package seems to have been included.

Maybe, it's an x86_64 issue (my system is amd64 and so is the jre and
the base eclipse).
The base eclipse installation was a CDT bundle, but i also tried with
the J2EE pack, same problem.
I tried the PDT bundle but i couldn't launch it (perhaps it's only
designed for x86)

Thanks
Re: Can't install by Update - wst.web_ui dependency [message #77682 is a reply to message #77650] Sun, 03 August 2008 06:23 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: codeslave.ca.ibm.com

Try this:

http://wiki.eclipse.org/PDT/Installation#Eclipse_3.4_.2F_Gan ymede_.2F_PDT_2.0

And note this:

http://wiki.eclipse.org/PDT/Installation#Known_Problems

I tried it last night and it worked fine... with
eclipse-jee-ganymede-linux-gtk.tar.gz, Sun JDK 5, Linux x86 32-bit,
kernel 2.6.22.

There's nothing in PDT that should be OS-specific, but you must use the
OS-specific platform (Eclipse "Classic" or "Ganymede JEE bundle" for
64-bit). Or use the 32-bit one with a 32-bit JVM.

See also:

http://ubuntuforums.org/archive/index.php/t-320899.html
http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourc eid=navclient&gfns=1&q=eclipse+amd_64

And if your system has more than one JVM installed (eg., 32- and 64-bit
versions), you'll want to launch Eclipse like this:

../eclipse -vm /path/to/the/right/bin/java

http://wiki.eclipse.org/IRC_FAQ#How_do_I_start_Eclipse.3F

Good luck!

Guillaume Poletto wrote:
> Hello,
>
> I tried during some hours to find PDT dependencies to install it
> through Software Update tool.
> Now, i think the needed package is already installed but for some
> reason, it doesn't "satisfy the requirements"
>
> "Cannot complete the request. See the details.
> Cannot find a solution satisfying the following requirements
> Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.wst.web_ui.feature.fea ture.group/[3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP ,3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP]]. "
>
> I installed all the packages provided by the "Web Tools Project" update
> site, and the "WST Web UI" package seems to have been included.
>
> Maybe, it's an x86_64 issue (my system is amd64 and so is the jre and
> the base eclipse).
> The base eclipse installation was a CDT bundle, but i also tried with
> the J2EE pack, same problem.
> I tried the PDT bundle but i couldn't launch it (perhaps it's only
> designed for x86)
>
> Thanks
>

--
Nick Boldt :: Release Engineer, IBM Toronto Lab
Eclipse Modeling :: http://www.eclipse.org/modeling
http://wiki.eclipse.org/index.php/User:Nickb
Re: Can't install by Update - wst.web_ui dependency [message #77699 is a reply to message #77682] Sun, 03 August 2008 10:24 Go to previous message
Poletto Guillaume is currently offline Poletto GuillaumeFriend
Messages: 4
Registered: July 2009
Junior Member
It worked with this
http://wiki.eclipse.org/PDT/Installation#Eclipse_3.4_.2F_Gan ymede_.2F_PDT_2..0 !

Thanks!
Regards,
G.

Le Sun, 03 Aug 2008 02:23:46 -0400,
Nick Boldt <codeslave@ca.ibm.com> a écrit :

> Try this:
>
> http://wiki.eclipse.org/PDT/Installation#Eclipse_3.4_.2F_Gan ymede_.2F_PDT_2.0
>
> And note this:
>
> http://wiki.eclipse.org/PDT/Installation#Known_Problems
>
> I tried it last night and it worked fine... with
> eclipse-jee-ganymede-linux-gtk.tar.gz, Sun JDK 5, Linux x86 32-bit,
> kernel 2.6.22.
>
> There's nothing in PDT that should be OS-specific, but you must use
> the OS-specific platform (Eclipse "Classic" or "Ganymede JEE bundle"
> for 64-bit). Or use the 32-bit one with a 32-bit JVM.
>
> See also:
>
> http://ubuntuforums.org/archive/index.php/t-320899.html
> http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourc eid=navclient&gfns=1&q=eclipse+amd_64
>
> And if your system has more than one JVM installed (eg., 32- and
> 64-bit versions), you'll want to launch Eclipse like this:
>
> ./eclipse -vm /path/to/the/right/bin/java
>
> http://wiki.eclipse.org/IRC_FAQ#How_do_I_start_Eclipse.3F
>
> Good luck!
>
> Guillaume Poletto wrote:
> > Hello,
> >
> > I tried during some hours to find PDT dependencies to install it
> > through Software Update tool.
> > Now, i think the needed package is already installed but for some
> > reason, it doesn't "satisfy the requirements"
> >
> > "Cannot complete the request. See the details.
> > Cannot find a solution satisfying the following requirements
> > Match[requiredCapability:
> > org.eclipse.equinox.p2.iu/org.eclipse.wst.web_ui.feature.fea ture.group/[3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP ,3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP]]. "
> >
> > I installed all the packages provided by the "Web Tools Project"
> > update site, and the "WST Web UI" package seems to have been
> > included.
> >
> > Maybe, it's an x86_64 issue (my system is amd64 and so is the jre
> > and the base eclipse).
> > The base eclipse installation was a CDT bundle, but i also tried
> > with the J2EE pack, same problem.
> > I tried the PDT bundle but i couldn't launch it (perhaps it's only
> > designed for x86)
> >
> > Thanks
> >
>
Previous Topic:Auto-Complete takes too long
Next Topic:PHP items on "Run as..." menu still visible in Java and other perspectives
Goto Forum:
  


Current Time: Sat Feb 24 19:55:05 GMT 2024

Powered by FUDForum. Page generated in 0.02508 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top