Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » Opening project takes 1-2 minutes with validation OFF
Opening project takes 1-2 minutes with validation OFF [message #722411] Mon, 05 September 2011 17:31 Go to next message
Twelve Eighty is currently offline Twelve EightyFriend
Messages: 2
Registered: September 2011
Junior Member
I am running Eclipse 3.7; WTP 3.3.0.

It takes 1-2 minutes opening my Web project, even after I have turned OFF all validation. There is no CPU activity to speak of during this wait. No errors are thrown in the .log file.

When I trace the network with tcpdump, I see a lot of requests going to:

0:48:57.804453 IP hans-moleman.w3.org.http > 192.168.1.100.40050: Flags [FP.], seq 8689:9207, ack 162, win 6432, options [nop,nop,TS val 41973237 ecr 3295182], length 518
10:48:57.804977 IP 192.168.1.100.40050 > hans-moleman.w3.org.http: Flags [F.], seq 162, ack 92

Which leads me to believe there is STILL some kind of W3 validation going on that I am waiting for. I believe that is what this hans-moleman.w3.org.http host is used for...

Can someone point me to the right direction? How can I speed up opening this project?

(When I have no network connection at all, the project opens instantly.)

Since I already have all the validation turned off, what else can I do to have Eclipse/WTP not use the network?
Re: Opening project takes 1-2 minutes with validation OFF [message #722836 is a reply to message #722411] Tue, 06 September 2011 21:13 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2702
Registered: July 2009
Senior Member

Without knowing what was in your project, it's difficult to tell which parts of WTP, if it was a part of WTP, that is trying to open network connections.

Nitin Dahyabhai
Eclipse WTP
IBM Emerging Technologies
Re: Opening project takes 1-2 minutes with validation OFF [message #724690 is a reply to message #722836] Mon, 12 September 2011 20:18 Go to previous messageGo to next message
Twelve Eighty is currently offline Twelve EightyFriend
Messages: 2
Registered: September 2011
Junior Member
This is a Dynamic Web project; I'm using Struts2 with JSP pages and Axis.

Would you know any debug options I can try to narrow down which component is trying to connect to the Internet?

If I open another Dynamic Web Project without Struts2 or Axis, there is no delay or network access...

If not validation (since I turned all validation off), what would try to connect to the Internet?
Re: Opening project takes 1-2 minutes with validation OFF [message #724729 is a reply to message #724690] Tue, 13 September 2011 01:18 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2702
Registered: July 2009
Senior Member

I'm not sure, but are there tools installed in relation to Struts2 and Axis, or are those just jars on the project's build path?

Nitin Dahyabhai
Eclipse WTP
IBM Emerging Technologies
Previous Topic:Node "Faces Configuration" shown many times in Project Explorer
Next Topic:Modern Source Editor Tutorial
Goto Forum:
  


Current Time: Fri Jul 29 12:11:11 GMT 2016

Powered by FUDForum. Page generated in 0.01823 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software