Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Newbie: teneo configuration question
Newbie: teneo configuration question [message #76302] Thu, 22 March 2007 17:49 Go to next message
Julia is currently offline JuliaFriend
Messages: 85
Registered: July 2009
Member
I get this error when I generate EMF-JDO/JPOX OR Mapping (superclass):
The java class is not found: javax.jdo.JDOUnsupportedOptionException

I'm using Eclipse 3.3, EMF 2.3 and jre5.

I did the following steps:
1) Followed the library.xsd tutorial (Step 4 didn't work here)
2) Added EMF 2.3, Teneo EMF persistency and EMF-JPOX plugin using the
update manager, downloaded jpox-1.1.7 and jpox-enhancer-1.1.7.jar and
included them in a plugin called jpox_1.1.7 with the manifest changes.
3) Updated the plugin.xml of the model and editor with the changes listed
in elver.org install instructions. Enable jpox support.

Am I missing a step? Thanks

Julia
Re: Newbie: teneo configuration question [message #76322 is a reply to message #76302] Thu, 22 March 2007 17:57 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Julia,
Did you also download the dependencies of jpox and placed them in the same plugin as the jpox jars
(and added the packages to the runtime/export of the plugin)?
See here for the dependencies:
http://www.jpox.org/docs/1_1/dependencies.html

gr. Martin

Julia wrote:
> I get this error when I generate EMF-JDO/JPOX OR Mapping (superclass):
> The java class is not found: javax.jdo.JDOUnsupportedOptionException
>
> I'm using Eclipse 3.3, EMF 2.3 and jre5.
>
> I did the following steps:
> 1) Followed the library.xsd tutorial (Step 4 didn't work here)
> 2) Added EMF 2.3, Teneo EMF persistency and EMF-JPOX plugin using the
> update manager, downloaded jpox-1.1.7 and jpox-enhancer-1.1.7.jar and
> included them in a plugin called jpox_1.1.7 with the manifest changes.
> 3) Updated the plugin.xml of the model and editor with the changes
> listed in elver.org install instructions. Enable jpox support.
>
> Am I missing a step? Thanks
>
> Julia
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Newbie: teneo configuration question [message #603806 is a reply to message #76302] Thu, 22 March 2007 17:57 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Julia,
Did you also download the dependencies of jpox and placed them in the same plugin as the jpox jars
(and added the packages to the runtime/export of the plugin)?
See here for the dependencies:
http://www.jpox.org/docs/1_1/dependencies.html

gr. Martin

Julia wrote:
> I get this error when I generate EMF-JDO/JPOX OR Mapping (superclass):
> The java class is not found: javax.jdo.JDOUnsupportedOptionException
>
> I'm using Eclipse 3.3, EMF 2.3 and jre5.
>
> I did the following steps:
> 1) Followed the library.xsd tutorial (Step 4 didn't work here)
> 2) Added EMF 2.3, Teneo EMF persistency and EMF-JPOX plugin using the
> update manager, downloaded jpox-1.1.7 and jpox-enhancer-1.1.7.jar and
> included them in a plugin called jpox_1.1.7 with the manifest changes.
> 3) Updated the plugin.xml of the model and editor with the changes
> listed in elver.org install instructions. Enable jpox support.
>
> Am I missing a step? Thanks
>
> Julia
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Previous Topic:Newbie: teneo configuration question
Next Topic:[Teneo]Supported DB vendor/versions
Goto Forum:
  


Current Time: Sat Oct 31 05:18:11 GMT 2020

Powered by FUDForum. Page generated in 0.01608 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top