Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » JET Transformation fails when EMF model editor plugin installed
JET Transformation fails when EMF model editor plugin installed [message #713490] Mon, 08 August 2011 14:35
Gabriel Telerman is currently offline Gabriel TelermanFriend
Messages: 1
Registered: August 2011
Junior Member
Hi, I'm using an eclipse based product (WebSphere Integration Developer) and I created a set of JET2 templates to generate code. These worked fine until I created a model editor to have a friendly way to create input models.

I created the editor by describing the model as ecore, then generating the genmodel plus model and edit classes.

Now when I deploy the EMF model editor to the plugins directory the JET generation fails.

I tried a number of modelLoader alternatives in the JET transformation's plugin.xml but nothing seems to work.

If I remove the model editor plugin, then the code generation works fine again.

Has anyone seen this kind of behaviour before and can share what needs done to fix it?

Many thanks.
Previous Topic:multiple packages problem
Next Topic:[Acceleo] Direct access to the elements in a Collection or Sequence
Goto Forum:

Current Time: Wed May 31 11:49:47 GMT 2023

Powered by FUDForum. Page generated in 0.02073 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top