Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] newbie question: what is the right ATL version to work with RSA7?
[ATL] newbie question: what is the right ATL version to work with RSA7? [message #75221] Thu, 21 February 2008 13:16 Go to next message
Eclipse UserFriend
Originally posted by: zhuj.in.tum.de

Hi everyone,

I have a newbie question about ATL:

* I am now working with RSA7(based on Eclipse 3.2), and I'm transforming
of a UML2 model in RSA/RSM format(.emx) using ATL, which version of ATL
should i use?

I downloaded the version (Feb 16 2007), which is for Eclipse 3.2, but the
UML2 model handler is not included.


thx in advance.
Re: [ATL] newbie question: what is the right ATL version to work with RSA7? [message #75371 is a reply to message #75221] Tue, 26 February 2008 19:10 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: zhuj.in.tum.de

Maybe the question sounds a little silly, let me put it another way:

I want to transform the stereotype-application between 2 UML2 Models(i.e.
apply stereotypes to the target model according to the source model).
Because of the fact that the execution order of bindings can't be (or is
not) garanteed by the ATL engine, I need the UML Model Handler, otherwise
this kind of stereotype-application could not be achieved (am I right?
profiles must be first applied, then stereotypes)

So for this UML Handler, I need the newest version of ATL. (version 2.0.0,
right?)

now the problem: this new version seems not to be compatible with
RSA7/Eclipse:
Problems I have include:
* editor doest work (even syntax mistakes can't be captured.)
* after I save the *.atl, no *.asm file is generated.


I hope I have made my situation clear.
So does anyone know a solution to this problem:
transforming profiled UML2 Model in RSA7/Eclipse3.2?

thx in advance.
Re: [ATL] newbie question: what is the right ATL version to work with RSA7? [message #75423 is a reply to message #75221] Wed, 27 February 2008 12:12 Go to previous message
Eclipse UserFriend
Originally posted by: zhuj.in.tum.de

Sorry for being so annoying, but I really can't figure out the problem.

The same problem happens if I download and extract the "AMW Model Handler"
into my RSA plugin directory: They just don't show as Model Handlers in
the ATL run configuration!

So what's wrong with my configuration?
I am using:
* RSA7.0.0.4
* ATL from "February 16, 2007"
* AMW from "March 30th, 2007"

any advice will be appreciated.

Jinhui
Previous Topic:[Announce] Eclipse/OMG Symposium at EclipseCon 2008
Next Topic:[ATL] Re: AMW Model Handler (mwplugins-20070330) doesn't appear in RSA7(Eclipse3.2)
Goto Forum:
  


Current Time: Sat May 25 17:42:48 GMT 2019

Powered by FUDForum. Page generated in 0.01769 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top