Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Latest Integration Build won't install
Latest Integration Build won't install [message #75127] Tue, 08 July 2008 03:18 Go to next message
David Muir is currently offline David MuirFriend
Messages: 63
Registered: July 2009
Member
An error occurred while collecting items to be installed
No repository found containing:
org.eclipse.php/osgi.bundle/2.0.0.v20080707
No repository found containing:
org.eclipse.php.core/osgi.bundle/2.0.0.v20080707
No repository found containing:
org.eclipse.php.debug.core/osgi.bundle/2.0.0.v20080707
No repository found containing:
org.eclipse.php.debug.daemon/osgi.bundle/2.0.0.v20080707
No repository found containing:
org.eclipse.php.debug.ui/osgi.bundle/2.0.0.v20080707
No repository found containing:
org.eclipse.php.help/osgi.bundle/2.0.0.v20080707
No repository found containing:
org.eclipse.php.server.core/osgi.bundle/2.0.0.v20080707
No repository found containing:
org.eclipse.php.server.ui/osgi.bundle/2.0.0.v20080707
No repository found containing:
org.eclipse.php.ui/osgi.bundle/2.0.0.v20080707
No repository found containing:
org.eclipse.php_feature/org.eclipse.update.feature/2.0.0.v20 080707-7H--E7QYGHNHEHE

Can anyone help?
Re: Latest Integration Build won't install [message #75143 is a reply to message #75127] Tue, 08 July 2008 06:14 Go to previous messageGo to next message
Alon Peled is currently offline Alon PeledFriend
Messages: 22
Registered: July 2009
Junior Member
Can you provide some more details about how you tried to install?
See http://wiki.eclipse.org/PDT/Installation for instructions.

Alon

On 8/7/08 6:18 AM, in article
d0b81b381e1320f308454e0be65a5c73$1@www.eclipse.org, "David Muir"
<david@davidkmuir.com> wrote:

> An error occurred while collecting items to be installed
> No repository found containing:
> org.eclipse.php/osgi.bundle/2.0.0.v20080707
> No repository found containing:
> org.eclipse.php.core/osgi.bundle/2.0.0.v20080707
> No repository found containing:
> org.eclipse.php.debug.core/osgi.bundle/2.0.0.v20080707
> No repository found containing:
> org.eclipse.php.debug.daemon/osgi.bundle/2.0.0.v20080707
> No repository found containing:
> org.eclipse.php.debug.ui/osgi.bundle/2.0.0.v20080707
> No repository found containing:
> org.eclipse.php.help/osgi.bundle/2.0.0.v20080707
> No repository found containing:
> org.eclipse.php.server.core/osgi.bundle/2.0.0.v20080707
> No repository found containing:
> org.eclipse.php.server.ui/osgi.bundle/2.0.0.v20080707
> No repository found containing:
> org.eclipse.php.ui/osgi.bundle/2.0.0.v20080707
> No repository found containing:
> org.eclipse.php_feature/org.eclipse.update.feature/2.0.0.v20 080707-7H--E7QYGHN
> HEHE
>
> Can anyone help?
>
Re: Latest Integration Build won't install [message #75389 is a reply to message #75143] Wed, 09 July 2008 01:26 Go to previous messageGo to next message
David Muir is currently offline David MuirFriend
Messages: 63
Registered: July 2009
Member
I installed by downloading and unzipping the integration build. I then
went to Help->Software Updates...

I then clicked on PDT Feature 1.1.0.HEAD797729qMqC, then Update.
It then gives me the option of installing PDT Feature 2.0.0v20080707...
I tick the checkbox, and click Finish. It then gives me the error I gave
before.

It gives the same error when trying to install with the nightly.
Re: Latest Integration Build won't install [message #75406 is a reply to message #75389] Wed, 09 July 2008 02:01 Go to previous messageGo to next message
David Muir is currently offline David MuirFriend
Messages: 63
Registered: July 2009
Member
Got it working.
Had to remove the old update site and then add it again. Odd, since the
paths were the same for both. Would this be a bug with the update manager,
or with pdt?
Re: Latest Integration Build won't install [message #75422 is a reply to message #75406] Wed, 09 July 2008 02:15 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: codeslave.ca.ibm.com

Sounds like a caching problem w/ Eclipse 3.4's p2 install manager. If
you can reproduce it easily, please open a bug in Equinox.p2:

https://bugs.eclipse.org/bugs/enter_bug.cgi?product=equinox& amp;component=p2

Or, try using the "refresh" button instead of removing and re-adding the
same site. Does that work?

David Muir wrote:
> Got it working.
> Had to remove the old update site and then add it again. Odd, since the
> paths were the same for both. Would this be a bug with the update
> manager, or with pdt?
>

--
Nick Boldt :: Release Engineer, IBM Toronto Lab
Eclipse Modeling :: http://www.eclipse.org/modeling
http://wiki.eclipse.org/index.php/User:Nickb
Re: Latest Integration Build won't install [message #75438 is a reply to message #75422] Wed, 09 July 2008 02:34 Go to previous messageGo to next message
David Muir is currently offline David MuirFriend
Messages: 63
Registered: July 2009
Member
Refreshing didn't work. I also tried un-installing pdt, refreshing, then
re-installing pdt, and that didn't work either. I'll wait for the next
nightly, so that it can more easily be reproduced.
Re: Latest Integration Build won't install [message #76276 is a reply to message #75438] Fri, 18 July 2008 00:58 Go to previous messageGo to next message
David Muir is currently offline David MuirFriend
Messages: 63
Registered: July 2009
Member
I submitted a bug report with Equinox and this is their reply:

--- Comment #2 from John Arthorne <john_arthorne@ca.ibm.com> 2008-07-16
14:05:58 -0400 ---
From looking at the PDT nightly builds, I can see they use a version
number of
"2.0.0.HEAD". This also means that every build has the same version
number, so
p2 can't make any sense of it. They need to have unique version numbers per
build for install/update technology to work properly.
Re: Latest Integration Build won't install [message #76292 is a reply to message #76276] Fri, 18 July 2008 03:05 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: codeslave.ca.ibm.com

FYI, this can be fixed with the forceContextQualifier or by building
from tags instead of HEAD.

http://wiki.eclipse.org/Modeling_Project_Releng/Building#Bui lt_features_.26_plugins_have_.22HEAD.22_in_their_version_qua lifier

David Muir wrote:
> I submitted a bug report with Equinox and this is their reply:
>
> --- Comment #2 from John Arthorne <john_arthorne@ca.ibm.com> 2008-07-16
> 14:05:58 -0400 ---
> From looking at the PDT nightly builds, I can see they use a version
> number of
> "2.0.0.HEAD". This also means that every build has the same version
> number, so
> p2 can't make any sense of it. They need to have unique version numbers per
> build for install/update technology to work properly.
>

--
Nick Boldt :: Release Engineer, IBM Toronto Lab
Eclipse Modeling :: http://www.eclipse.org/modeling
http://wiki.eclipse.org/index.php/User:Nickb
Re: Latest Integration Build won't install [message #76517 is a reply to message #76292] Mon, 21 July 2008 02:08 Go to previous messageGo to next message
David Muir is currently offline David MuirFriend
Messages: 63
Registered: July 2009
Member
Isn't this something that the PDT people should be doing?
Re: Latest Integration Build won't install [message #76533 is a reply to message #76517] Mon, 21 July 2008 02:15 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: codeslave.ca.ibm.com

Well, yeah, but they read this newsgroup so they should see this. Just
in case I'll copy pdt-dev@eclipse.org too.

If you reassign the bug to PDT or paste its number here, we can make
sure they know about this item.

Nick

David Muir wrote:
> Isn't this something that the PDT people should be doing?

>> FYI, this can be fixed with the forceContextQualifier or by building from tags instead of HEAD.

>> http://wiki.eclipse.org/Modeling_Project_Releng/Building#Bui lt_features_.26_plugins_have_.22HEAD.22_in_their_version_qua lifier

>> David Muir wrote:
>>> I submitted a bug report with Equinox and this is their reply:

>>> --- Comment #2 from John Arthorne <john_arthorne@ca.ibm.com> 2008-07-16 14:05:58 -0400 ---
>>> From looking at the PDT nightly builds, I can see they use a version number of
>>> "2.0.0.HEAD". This also means that every build has the same version number, so
>>> p2 can't make any sense of it. They need to have unique version numbers per
>>> build for install/update technology to work properly.

--
Nick Boldt :: Release Engineer, IBM Toronto Lab
Eclipse Modeling :: http://www.eclipse.org/modeling
http://wiki.eclipse.org/index.php/User:Nickb
Re: Latest Integration Build won't install [message #76579 is a reply to message #76533] Mon, 21 July 2008 03:00 Go to previous message
David Muir is currently offline David MuirFriend
Messages: 63
Registered: July 2009
Member
Added here:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=241341
Previous Topic:Word Wrap in "Debug Output"?
Next Topic:PDT Build I20080721
Goto Forum:
  


Current Time: Thu Feb 02 15:54:03 GMT 2023

Powered by FUDForum. Page generated in 0.03319 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top