Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Persistent error when generating Teneo Hibernate mapping file
Persistent error when generating Teneo Hibernate mapping file [message #74219] Thu, 08 March 2007 13:59 Go to next message
Duncan Alexander is currently offline Duncan AlexanderFriend
Messages: 90
Registered: July 2009
Member
Hi all,
Im currently attempting to use Teneo to provide a hibernate mapping for
my EMF model of a statistical metamodel.

Teneo does not seem to want to generate the mapping and therefore I have
now stripped my project back to a very simple .ecore file with only 3
classes, Person, Male and Female...each with a couple of attributes.
I generated the .ecore file from a Rose model.

Whenever I attempt to generate the Hibernate mapping using Teneo I get
the following error:

--------------
08-Mar-2007 13:29:12 org.eclipse.emf.teneo.hibernate.mapper.GenerateHBM main
SEVERE: Exception while instantiating , message:

--------------

There is no detail in the message at all....it always comes out blank.

I am using Eclipse 3.2 with EMF 2.2 and Teneo 0.8, JDK 1.5.

Any help, greatly appreciated.

regards

Duncan
Re: Persistent error when generating Teneo Hibernate mapping file [message #74239 is a reply to message #74219] Thu, 08 March 2007 14:08 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Duncan,
For eclipse 3.2 and emf 2.2 you need to use teneo 0.7.5 (the maintenance build).

If you still get the error after switching versions:
Are you generating through a right-click on the ecore file and then select a teneo submenu?
In this case you can check the error log (see windows > show view and then select error log).
See also this page:
http://www.elver.org/hibernate/troubleshooting.html#manualor mapper

You can also programmatically generate the mapping file through the HbHelper:
http://www.elver.org/hibernate/hbdatastore.html#Getting+the+ Hibernate+Mapping+XML

Just write a small main class and generate it from there.

gr. Martin

Duncan ALexander wrote:
> Hi all,
> Im currently attempting to use Teneo to provide a hibernate mapping
> for my EMF model of a statistical metamodel.
>
> Teneo does not seem to want to generate the mapping and therefore I have
> now stripped my project back to a very simple .ecore file with only 3
> classes, Person, Male and Female...each with a couple of attributes.
> I generated the .ecore file from a Rose model.
>
> Whenever I attempt to generate the Hibernate mapping using Teneo I get
> the following error:
>
> --------------
> 08-Mar-2007 13:29:12 org.eclipse.emf.teneo.hibernate.mapper.GenerateHBM
> main
> SEVERE: Exception while instantiating , message:
>
> --------------
>
> There is no detail in the message at all....it always comes out blank.
>
> I am using Eclipse 3.2 with EMF 2.2 and Teneo 0.8, JDK 1.5.
>
> Any help, greatly appreciated.
>
> regards
>
> Duncan


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Persistent error when generating Teneo Hibernate mapping file [message #74294 is a reply to message #74239] Thu, 08 March 2007 15:57 Go to previous message
Duncan Alexander is currently offline Duncan AlexanderFriend
Messages: 90
Registered: July 2009
Member
Hi ,
Brilliant, thanks for the speedy response.

That seems to have solved my problem.

I've got another now but Ill start a new thread.

Duncan


Martin Taal wrote:
> Hi Duncan,
> For eclipse 3.2 and emf 2.2 you need to use teneo 0.7.5 (the maintenance
> build).
>
> If you still get the error after switching versions:
> Are you generating through a right-click on the ecore file and then
> select a teneo submenu?
> In this case you can check the error log (see windows > show view and
> then select error log).
> See also this page:
> http://www.elver.org/hibernate/troubleshooting.html#manualor mapper
>
> You can also programmatically generate the mapping file through the
> HbHelper:
> http://www.elver.org/hibernate/hbdatastore.html#Getting+the+ Hibernate+Mapping+XML
>
>
> Just write a small main class and generate it from there.
>
> gr. Martin
>
> Duncan ALexander wrote:
>> Hi all,
>> Im currently attempting to use Teneo to provide a hibernate
>> mapping for my EMF model of a statistical metamodel.
>>
>> Teneo does not seem to want to generate the mapping and therefore I
>> have now stripped my project back to a very simple .ecore file with
>> only 3 classes, Person, Male and Female...each with a couple of
>> attributes.
>> I generated the .ecore file from a Rose model.
>>
>> Whenever I attempt to generate the Hibernate mapping using Teneo I get
>> the following error:
>>
>> --------------
>> 08-Mar-2007 13:29:12
>> org.eclipse.emf.teneo.hibernate.mapper.GenerateHBM main
>> SEVERE: Exception while instantiating , message:
>>
>> --------------
>>
>> There is no detail in the message at all....it always comes out blank.
>>
>> I am using Eclipse 3.2 with EMF 2.2 and Teneo 0.8, JDK 1.5.
>>
>> Any help, greatly appreciated.
>>
>> regards
>>
>> Duncan
>
>
Re: Persistent error when generating Teneo Hibernate mapping file [message #603277 is a reply to message #74219] Thu, 08 March 2007 14:08 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Duncan,
For eclipse 3.2 and emf 2.2 you need to use teneo 0.7.5 (the maintenance build).

If you still get the error after switching versions:
Are you generating through a right-click on the ecore file and then select a teneo submenu?
In this case you can check the error log (see windows > show view and then select error log).
See also this page:
http://www.elver.org/hibernate/troubleshooting.html#manualor mapper

You can also programmatically generate the mapping file through the HbHelper:
http://www.elver.org/hibernate/hbdatastore.html#Getting+the+ Hibernate+Mapping+XML

Just write a small main class and generate it from there.

gr. Martin

Duncan ALexander wrote:
> Hi all,
> Im currently attempting to use Teneo to provide a hibernate mapping
> for my EMF model of a statistical metamodel.
>
> Teneo does not seem to want to generate the mapping and therefore I have
> now stripped my project back to a very simple .ecore file with only 3
> classes, Person, Male and Female...each with a couple of attributes.
> I generated the .ecore file from a Rose model.
>
> Whenever I attempt to generate the Hibernate mapping using Teneo I get
> the following error:
>
> --------------
> 08-Mar-2007 13:29:12 org.eclipse.emf.teneo.hibernate.mapper.GenerateHBM
> main
> SEVERE: Exception while instantiating , message:
>
> --------------
>
> There is no detail in the message at all....it always comes out blank.
>
> I am using Eclipse 3.2 with EMF 2.2 and Teneo 0.8, JDK 1.5.
>
> Any help, greatly appreciated.
>
> regards
>
> Duncan


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Persistent error when generating Teneo Hibernate mapping file [message #603288 is a reply to message #74239] Thu, 08 March 2007 15:57 Go to previous message
Duncan Alexander is currently offline Duncan AlexanderFriend
Messages: 90
Registered: July 2009
Member
Hi ,
Brilliant, thanks for the speedy response.

That seems to have solved my problem.

I've got another now but Ill start a new thread.

Duncan


Martin Taal wrote:
> Hi Duncan,
> For eclipse 3.2 and emf 2.2 you need to use teneo 0.7.5 (the maintenance
> build).
>
> If you still get the error after switching versions:
> Are you generating through a right-click on the ecore file and then
> select a teneo submenu?
> In this case you can check the error log (see windows > show view and
> then select error log).
> See also this page:
> http://www.elver.org/hibernate/troubleshooting.html#manualor mapper
>
> You can also programmatically generate the mapping file through the
> HbHelper:
> http://www.elver.org/hibernate/hbdatastore.html#Getting+the+ Hibernate+Mapping+XML
>
>
> Just write a small main class and generate it from there.
>
> gr. Martin
>
> Duncan ALexander wrote:
>> Hi all,
>> Im currently attempting to use Teneo to provide a hibernate
>> mapping for my EMF model of a statistical metamodel.
>>
>> Teneo does not seem to want to generate the mapping and therefore I
>> have now stripped my project back to a very simple .ecore file with
>> only 3 classes, Person, Male and Female...each with a couple of
>> attributes.
>> I generated the .ecore file from a Rose model.
>>
>> Whenever I attempt to generate the Hibernate mapping using Teneo I get
>> the following error:
>>
>> --------------
>> 08-Mar-2007 13:29:12
>> org.eclipse.emf.teneo.hibernate.mapper.GenerateHBM main
>> SEVERE: Exception while instantiating , message:
>>
>> --------------
>>
>> There is no detail in the message at all....it always comes out blank.
>>
>> I am using Eclipse 3.2 with EMF 2.2 and Teneo 0.8, JDK 1.5.
>>
>> Any help, greatly appreciated.
>>
>> regards
>>
>> Duncan
>
>
Previous Topic:Teneo plan to support java5 annotations instead of EMF?
Next Topic:Missing model element when generating Teneo hibernate mapping
Goto Forum:
  


Current Time: Wed Oct 21 14:48:14 GMT 2020

Powered by FUDForum. Page generated in 0.02129 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top