Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Diagram is not present in resource
Diagram is not present in resource [message #708976] Wed, 03 August 2011 11:05 Go to next message
Johan Van Noten is currently offline Johan Van NotenFriend
Messages: 87
Registered: July 2009
* Eclipse RCP application
* Eclipse Helios
* One editor contains a diagram based on GMF Tooling

When we open that editor from the exported RCP application,
we get the message "Diagram is not present in resource".

Already tried:
* Running it inside Eclipse (debug or run) works fine
The problem only occurs when we export the RCP product.
* With remote debugging, we can see that the list of providers
that could handle our CreateDiagramViewOperation is empty.
We do have the correct extension point in our plugin.xml though:
points to our diagram's generated viewProvider.
* It has worked before and still works on an old version of the app,
but we fail to see the differences...

* We don't onderstand the difference in behaviour between:
- Inside Eclipse
- From the exported RCP app
* Does anybody know of issues with such viewProviders?
Re: Diagram is not present in resource [message #709029 is a reply to message #708976] Wed, 03 August 2011 12:20 Go to previous message
Johan Van Noten is currently offline Johan Van NotenFriend
Messages: 87
Registered: July 2009
Guys... Solved!
Well, I should say: the problem is gone, but don't understand why Eclipse acts this way.

In my previous post I told you that my plugin.xml was fine and it was.
But in the it didn't have a check, so it was not included in the bundle.
Stupid manipulation mistake, but ok, so be it.
Checked it, exported again, works.

But... I don't understand why Eclipse doesn't fail when you run the product inside Eclipse.
The plugin.xml is then automagically found?
I guess the real "bundling" is then not done. Ok, can accept that.
But it is quite annoying that this kind of error checking is not done automatically.

Is there a solution for this Eclipse behaviour?

Previous Topic:Copy & Paste within CompartmentEditParts
Next Topic:GMF & EMF synergy
Goto Forum:

Current Time: Fri Mar 05 20:36:16 GMT 2021

Powered by FUDForum. Page generated in 0.02210 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top