Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » GMF Tooling in Indigo
GMF Tooling in Indigo [message #696181] Wed, 13 July 2011 12:26 Go to next message
Eclipse UserFriend
Originally posted by: Christian Krause

Hi,
I tried for like to install GMF Tooling in Indigo without success. I
used the GMP releases update site in a freshly install Modeling version
of Indigo. The update manager complains about some unresolved dependencies:

Cannot complete the install because one or more required items could not
be found.
Software being installed: Graphical Modeling Framework Xpand
2.3.0.v20100421-2359-787CA7CcNBGKCUHr9WVVZ
(org.eclipse.gmf.xpand.feature.group
2.3.0.v20100421-2359-787CA7CcNBGKCUHr9WVVZ)
Missing requirement: Graphical Modeling Framework Xpand
2.3.0.v20100421-2359-787CA7CcNBGKCUHr9WVVZ
(org.eclipse.gmf.xpand.feature.group
2.3.0.v20100421-2359-787CA7CcNBGKCUHr9WVVZ) requires
'org.eclipse.m2m.qvt.oml.common [2.0.0,3.0.0)' but it could not be found

When I try to install the missing plugin I get:

Cannot complete the install because of a conflicting dependency.
Software being installed: Operational QVT Common
2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7
(org.eclipse.m2m.qvt.oml.common.feature.group
2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7)
Software currently installed: Operational QVT SDK
3.1.0.v20110314-1530-7U7A-CL5RuMpMxGq9lWcafWQlGUu
(org.eclipse.m2m.qvt.oml.sdk.feature.group
3.1.0.v20110314-1530-7U7A-CL5RuMpMxGq9lWcafWQlGUu)
Only one of the following can be installed at once:
QVT Operational EMF Utilities 2.0.0.v20090526-1940
(org.eclipse.m2m.qvt.oml.emf.util 2.0.0.v20090526-1940)
QVT Operational EMF Utilities 2.0.1.v20090722-1630
(org.eclipse.m2m.qvt.oml.emf.util 2.0.1.v20090722-1630)
QVT Operational EMF Utilities 3.1.0.v20101214-1530
(org.eclipse.m2m.qvt.oml.emf.util 3.1.0.v20101214-1530)
Cannot satisfy dependency:
From: Operational QVT Common
2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7
(org.eclipse.m2m.qvt.oml.common.feature.group
2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7)
To: org.eclipse.m2m.qvt.oml.emf.util [2.0.0,3.0.0)
Cannot satisfy dependency:
From: Operational QVT SDK
3.1.0.v20110314-1530-7U7A-CL5RuMpMxGq9lWcafWQlGUu
(org.eclipse.m2m.qvt.oml.sdk.feature.group
3.1.0.v20110314-1530-7U7A-CL5RuMpMxGq9lWcafWQlGUu)
To: org.eclipse.m2m.qvt.oml.emf.util [3.0.0,4.0.0)

At this point I was lost.

Is there an easier way to install GMF Tooling in Indigo? When will GMF
Tooling be available at the Indigo update site?

Christian
Re: GMF Tooling in Indigo [message #696182 is a reply to message #696181] Wed, 13 July 2011 12:31 Go to previous message
Eclipse UserFriend
Originally posted by: Christian Krause

Sorry, I just saw the earlier message.

http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/dev-snapshots/

works. Thanks.

On 07/13/11 14:26, Christian Krause wrote:
> Hi,
> I tried for like to install GMF Tooling in Indigo without success. I
> used the GMP releases update site in a freshly install Modeling version
> of Indigo. The update manager complains about some unresolved dependencies:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: Graphical Modeling Framework Xpand
> 2.3.0.v20100421-2359-787CA7CcNBGKCUHr9WVVZ
> (org.eclipse.gmf.xpand.feature.group
> 2.3.0.v20100421-2359-787CA7CcNBGKCUHr9WVVZ)
> Missing requirement: Graphical Modeling Framework Xpand
> 2.3.0.v20100421-2359-787CA7CcNBGKCUHr9WVVZ
> (org.eclipse.gmf.xpand.feature.group
> 2.3.0.v20100421-2359-787CA7CcNBGKCUHr9WVVZ) requires
> 'org.eclipse.m2m.qvt.oml.common [2.0.0,3.0.0)' but it could not be found
>
> When I try to install the missing plugin I get:
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Operational QVT Common
> 2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7
> (org.eclipse.m2m.qvt.oml.common.feature.group
> 2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7)
> Software currently installed: Operational QVT SDK
> 3.1.0.v20110314-1530-7U7A-CL5RuMpMxGq9lWcafWQlGUu
> (org.eclipse.m2m.qvt.oml.sdk.feature.group
> 3.1.0.v20110314-1530-7U7A-CL5RuMpMxGq9lWcafWQlGUu)
> Only one of the following can be installed at once:
> QVT Operational EMF Utilities 2.0.0.v20090526-1940
> (org.eclipse.m2m.qvt.oml.emf.util 2.0.0.v20090526-1940)
> QVT Operational EMF Utilities 2.0.1.v20090722-1630
> (org.eclipse.m2m.qvt.oml.emf.util 2.0.1.v20090722-1630)
> QVT Operational EMF Utilities 3.1.0.v20101214-1530
> (org.eclipse.m2m.qvt.oml.emf.util 3.1.0.v20101214-1530)
> Cannot satisfy dependency:
> From: Operational QVT Common 2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7
> (org.eclipse.m2m.qvt.oml.common.feature.group
> 2.0.1.v20090722-1630-79-0AkF77g7UDT3BcL7)
> To: org.eclipse.m2m.qvt.oml.emf.util [2.0.0,3.0.0)
> Cannot satisfy dependency:
> From: Operational QVT SDK
> 3.1.0.v20110314-1530-7U7A-CL5RuMpMxGq9lWcafWQlGUu
> (org.eclipse.m2m.qvt.oml.sdk.feature.group
> 3.1.0.v20110314-1530-7U7A-CL5RuMpMxGq9lWcafWQlGUu)
> To: org.eclipse.m2m.qvt.oml.emf.util [3.0.0,4.0.0)
>
> At this point I was lost.
>
> Is there an easier way to install GMF Tooling in Indigo? When will GMF
> Tooling be available at the Indigo update site?
>
> Christian
>
Previous Topic:Synchronization between model editor and diagram editor
Next Topic:Dynamic Figure at runtime
Goto Forum:
  


Current Time: Mon Mar 08 09:42:41 GMT 2021

Powered by FUDForum. Page generated in 0.02342 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top