Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » ATL transformation from UML2 to OWL
ATL transformation from UML2 to OWL [message #68363] Fri, 07 December 2007 14:56 Go to next message
Eclipse UserFriend
Originally posted by: valerio.summo.gmail.com

Hi all,
I'm trying to develop a Java Launcher for an ATL transformation from UML2 to
OWL, but I have some problem in loading the UML2 ecore model.
I have extracted the UML.ecore file from the package
"org.eclipse.uml2.uml_2.1.0.v200706251652.jar" and copied into my project.
My environment is: emf 2.3.0, org.eclipse.core 3.3.0, uml 2.1.0

My code is:

AtlModelHandler emfamh =
AtlModelHandler.getDefault(AtlModelHandler.AMH_EMF);
URL onemmurl = ATLTransformations.class.getResource(
"/metamodels/ecore/UML.ecore");
UMLPackage umlPackage = UMLPackage.eINSTANCE;
ASMModel oneMM_EMF = emfamh.loadModel("UML", emfamh.getMof(),
onemmurl.openStream());

but when I execute it, the last code line causes a long series of identical
WARNING:
Dec 7, 2007 3:15:39 PM org.eclipse.m2m.atl.drivers.emf4atl.ASMEMFModel
addReferencedExtentsFor
WARNING: Resource for org.eclipse.emf.ecore.impl.EClassImpl@31a031a0
(eProxyURI:
platform:/plugin/org.eclipse.emf.ecore/model/Ecore.ecore#//E ModelElement) is
null; cannot be referenced

Thank you in advance!

Valerio
Re: ATL transformation from UML2 to OWL [message #68420 is a reply to message #68363] Mon, 10 December 2007 09:02 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 33
Registered: July 2009
Member
Hi,

why not loading the uml metamodel by

uml2Mm = emfMh.loadModel("uml", this.emfMh.getMof(),
"uri:http://www.eclipse.org/uml2/2.1.0/UML");


Best regards

Sebastian


Valerio Summo schrieb:
> Hi all,
> I'm trying to develop a Java Launcher for an ATL transformation from UML2 to
> OWL, but I have some problem in loading the UML2 ecore model.
> I have extracted the UML.ecore file from the package
> "org.eclipse.uml2.uml_2.1.0.v200706251652.jar" and copied into my project.
> My environment is: emf 2.3.0, org.eclipse.core 3.3.0, uml 2.1.0
>
> My code is:
>
> AtlModelHandler emfamh =
> AtlModelHandler.getDefault(AtlModelHandler.AMH_EMF);
> URL onemmurl = ATLTransformations.class.getResource(
> "/metamodels/ecore/UML.ecore");
> UMLPackage umlPackage = UMLPackage.eINSTANCE;
> ASMModel oneMM_EMF = emfamh.loadModel("UML", emfamh.getMof(),
> onemmurl.openStream());
>
> but when I execute it, the last code line causes a long series of identical
> WARNING:
> Dec 7, 2007 3:15:39 PM org.eclipse.m2m.atl.drivers.emf4atl.ASMEMFModel
> addReferencedExtentsFor
> WARNING: Resource for org.eclipse.emf.ecore.impl.EClassImpl@31a031a0
> (eProxyURI:
> platform:/plugin/org.eclipse.emf.ecore/model/Ecore.ecore#//E ModelElement) is
> null; cannot be referenced
>
> Thank you in advance!
>
> Valerio
>
>
Re: ATL transformation from UML2 to OWL [message #68451 is a reply to message #68420] Mon, 10 December 2007 09:36 Go to previous message
Eclipse UserFriend
Originally posted by: valerio.summo.gmail.com

Thank you!
That was my solution!

"bfeater" <sgebhardt1@gmx.de> wrote in message
news:fjivbi$aeg$1@build.eclipse.org...
> Hi,
>
> why not loading the uml metamodel by
>
> uml2Mm = emfMh.loadModel("uml", this.emfMh.getMof(),
> "uri:http://www.eclipse.org/uml2/2.1.0/UML");
>
>
> Best regards
>
> Sebastian
>
>
> Valerio Summo schrieb:
>> Hi all,
>> I'm trying to develop a Java Launcher for an ATL transformation from UML2
>> to OWL, but I have some problem in loading the UML2 ecore model.
>> I have extracted the UML.ecore file from the package
>> "org.eclipse.uml2.uml_2.1.0.v200706251652.jar" and copied into my
>> project.
>> My environment is: emf 2.3.0, org.eclipse.core 3.3.0, uml 2.1.0
>>
>> My code is:
>>
>> AtlModelHandler emfamh =
>> AtlModelHandler.getDefault(AtlModelHandler.AMH_EMF);
>> URL onemmurl = ATLTransformations.class.getResource(
>> "/metamodels/ecore/UML.ecore");
>> UMLPackage umlPackage = UMLPackage.eINSTANCE;
>> ASMModel oneMM_EMF = emfamh.loadModel("UML", emfamh.getMof(),
>> onemmurl.openStream());
>>
>> but when I execute it, the last code line causes a long series of
>> identical WARNING:
>> Dec 7, 2007 3:15:39 PM org.eclipse.m2m.atl.drivers.emf4atl.ASMEMFModel
>> addReferencedExtentsFor
>> WARNING: Resource for org.eclipse.emf.ecore.impl.EClassImpl@31a031a0
>> (eProxyURI:
>> platform:/plugin/org.eclipse.emf.ecore/model/Ecore.ecore#//E ModelElement)
>> is null; cannot be referenced
>>
>> Thank you in advance!
>>
>> Valerio
>>
Previous Topic:[ATL] : Bug report ? UML 2 Driver and Primitive types from pathmap
Next Topic:[ATL] AtlLauncher launch method parameter
Goto Forum:
  


Current Time: Sun Apr 11 02:20:41 GMT 2021

Powered by FUDForum. Page generated in 0.02143 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top