Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » No folding, no code completion... this used to work... what happened?
No folding, no code completion... this used to work... what happened? [message #67205] Fri, 14 March 2008 20:35 Go to next message
Eclipse UserFriend
Originally posted by: jacob.datajoe.com

A while back my folding and code completion just stopped working for
some unexplainable reason... I have folding enabled everywhere... I have
code completion enabled... My partner is using the same environment as I
am and his is working fine... Please help... I don't even know where to
go from here!
Re: No folding, no code completion... this used to work... what happened? [message #67235 is a reply to message #67205] Sat, 15 March 2008 05:47 Go to previous messageGo to next message
J. A. Boyd is currently offline J. A. BoydFriend
Messages: 1
Registered: July 2009
Junior Member
Hello Jacob !

I have this problem due damaged ".project" file.

Copy "...workspace/project_name/.project" file from your partner and
restart PDT for testing...

Boyd



Em Fri, 14 Mar 2008 14:35:48 -0600
Jacob Fogg <jacob@datajoe.com> escreveu:

> A while back my folding and code completion just stopped working for
> some unexplainable reason... I have folding enabled everywhere... I have
> code completion enabled... My partner is using the same environment as I
> am and his is working fine... Please help... I don't even know where to
> go from here!
Re: No folding, no code completion... this used to work... what happened? [message #67304 is a reply to message #67235] Mon, 17 March 2008 15:46 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jacob.datajoe.com

You are the MAN! If you were anywhere close by, I'd come over and take
you out to lunch!

Thanks!
Jacob

J. A. Boyd wrote:
> Hello Jacob !
>
> I have this problem due damaged ".project" file.
>
> Copy "...workspace/project_name/.project" file from your partner and
> restart PDT for testing...
>
> Boyd
>
>
>
> Em Fri, 14 Mar 2008 14:35:48 -0600
> Jacob Fogg <jacob@datajoe.com> escreveu:
>
>> A while back my folding and code completion just stopped working for
>> some unexplainable reason... I have folding enabled everywhere... I have
>> code completion enabled... My partner is using the same environment as I
>> am and his is working fine... Please help... I don't even know where to
>> go from here!
How does PDT corrupt .project files? (was Re: No folding, no code completion... this used to work... [message #69637 is a reply to message #67304] Tue, 29 April 2008 18:11 Go to previous message
Eclipse UserFriend
Originally posted by: codeslave.ca.ibm.com

How does a .project file get damaged, anyway? I've been using Eclipse
for 4 years and I've never seen that happen. (But I stopped using PDT a
while ago and switched back to PHPeclipse, so maybe that's why.)

What is PDT doing with .project files that they can get corrupt? Isn't
that more-or-less static information that's only ever written to once in
a blue moon if you add a new nature or builder, create the project in
the first place, or import it from some source where it doesn't already
exist?

BTW, there's also this hack if you need to shoehorn an existing project
to work w/ PDT:

http://wiki.eclipse.org/IRC_FAQ#How_do_I_manually_assign_a_p roject_Nature_or_BuildCommand.3F

Nick

Jacob Fogg wrote:
> You are the MAN! If you were anywhere close by, I'd come over and take
> you out to lunch!
>
> Thanks!
> Jacob
>
> J. A. Boyd wrote:
>> Hello Jacob !
>>
>> I have this problem due damaged ".project" file.
>>
>> Copy "...workspace/project_name/.project" file from your partner and
>> restart PDT for testing...
>>
>> Boyd
>>
>>
>>
>> Em Fri, 14 Mar 2008 14:35:48 -0600
>> Jacob Fogg <jacob@datajoe.com> escreveu:
>>
>>> A while back my folding and code completion just stopped working for
>>> some unexplainable reason... I have folding enabled everywhere... I
>>> have code completion enabled... My partner is using the same
>>> environment as I am and his is working fine... Please help... I
>>> don't even know where to go from here!
Previous Topic:PDT dependecies
Next Topic:PDT falling behind on purpose?
Goto Forum:
  


Current Time: Sun Feb 05 15:25:13 GMT 2023

Powered by FUDForum. Page generated in 9.84777 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top