Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » libphp4.so
libphp4.so [message #66974] Fri, 07 March 2008 09:21 Go to next message
Sasha is currently offline SashaFriend
Messages: 3
Registered: July 2009
Junior Member
Just installed Eclipse and PDT on up to date out of the box FC8 Linux box.

For some reason I cannot run Apache because it asks for php4, which
naturally I don't have (only php5). It fails with the following error:
httpd: Syntax error on line 15 of
/usr/share/eclipse/plugins/net.sourceforge.phpeclipse.extern altools_1.1.8/confs/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server:
/etc/httpd/modules/libphp4.so: cannot open shared object file: No such
file or directory


Manually changing httpd.conf to load php5 module instead of php4 did not
help either - the error message disappeared, but Eclipse still failed to
start Apache (without any error messages).

Any ideas ? Why the heck it is configured to use php4 by default ? Is
there a way to make it work with php5 ?


BrowserSeal - fast multi browser screenshots - http://www.browserseal.com
Re: libphp4.so [message #67029 is a reply to message #66974] Sun, 09 March 2008 08:30 Go to previous message
Eclipse UserFriend
Originally posted by: michael.zend.com

This is a mailing list for PDT, and PDT is not PHPEclipse.

Alexander Sirotkin wrote:
> Just installed Eclipse and PDT on up to date out of the box FC8 Linux box.
> For some reason I cannot run Apache because it asks for php4, which
> naturally I don't have (only php5). It fails with the following error:
> httpd: Syntax error on line 15 of
> /usr/share/eclipse/plugins/net.sourceforge.phpeclipse.extern altools_1.1.8/confs/httpd.conf:
> Cannot load /etc/httpd/modules/libphp4.so into server:
> /etc/httpd/modules/libphp4.so: cannot open shared object file: No such
> file or directory
>
>
> Manually changing httpd.conf to load php5 module instead of php4 did not
> help either - the error message disappeared, but Eclipse still failed to
> start Apache (without any error messages).
>
> Any ideas ? Why the heck it is configured to use php4 by default ? Is
> there a way to make it work with php5 ?
Previous Topic:PDT and PHPDoc
Next Topic:API_Document_for_Extension_Points missing
Goto Forum:
  


Current Time: Mon Jan 30 11:16:50 GMT 2023

Powered by FUDForum. Page generated in 0.15219 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top