Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] problem with UML2 and profile application
[ATL] problem with UML2 and profile application [message #66844] Wed, 28 November 2007 16:43 Go to next message
Eclipse UserFriend
Originally posted by: tristan.faure.c-s.fr

Hi again !
i have a problem with the profiles i explain :
I have a transformation from a UML file to UML file.
I use a metamodel ecore linked to UML metamodel and myprofile.uml (as we
have seen in example
http://ssel.vub.ac.be/viewvc/UML2CaseStudies/uml2cs-transfor mations)

to do my transformation i use superimposition
transformation : uml copy
superimpose 1 : profile copy
superimpose 2 : my personnal rules

and i use the uml2 driver (i don't know if i use the RC2 ...)

but when i run my transformation the profile application elements of
Package in the output uml file are empty ...

i don't understand why the matched rules of profile application don't
work. The objects are here but the profile is not referenced ...

to resolve that i had to erase the matched rules for the profile
application in the uml2copy and to erase the lines "profileApplication <-
s.profileApplication" in the umlcopy file and i had to do in a do section
in package matched rule the statement :
for (p in s.getAppliedProfiles()){
t.applyProfile(p);
}
s is the source package and t the target package

i think my solution is not very clean and i hope you know how i can use
the match of profileapplication ?
Re: [ATL] problem with UML2 and profile application [message #67570 is a reply to message #66844] Thu, 29 November 2007 12:32 Go to previous messageGo to next message
Dennis Wagelaar is currently offline Dennis WagelaarFriend
Messages: 147
Registered: July 2009
Senior Member
Tristan FAURE schreef:
> Hi again !
> i have a problem with the profiles i explain :
> I have a transformation from a UML file to UML file.
> I use a metamodel ecore linked to UML metamodel and myprofile.uml (as we
> have seen in example
> http://ssel.vub.ac.be/viewvc/UML2CaseStudies/uml2cs-transfor mations)
>
> to do my transformation i use superimposition transformation : uml copy
> superimpose 1 : profile copy
> superimpose 2 : my personnal rules
>
> and i use the uml2 driver (i don't know if i use the RC2 ...)

Do you get the same behaviour with the EMF driver? What happens if you
omit your personal rules and only do uml copy with profile copy?
--
Dennis

>
> but when i run my transformation the profile application elements of
> Package in the output uml file are empty ...
>
> i don't understand why the matched rules of profile application don't
> work. The objects are here but the profile is not referenced ...
>
> to resolve that i had to erase the matched rules for the profile
> application in the uml2copy and to erase the lines "profileApplication
> <- s.profileApplication" in the umlcopy file and i had to do in a do
> section in package matched rule the statement : for (p in
> s.getAppliedProfiles()){
> t.applyProfile(p);
> }
> s is the source package and t the target package
>
> i think my solution is not very clean and i hope you know how i can use
> the match of profileapplication ?
>
>
Re: [ATL] problem with UML2 and profile application [message #67880 is a reply to message #67570] Fri, 30 November 2007 15:48 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: tristan.faure.c-s.fr

hi
if we use EMF the Stereotypes are not recognized
if i omit my personnal rules the profile application is not copied too
Re: [ATL] problem with UML2 and profile application [message #68049 is a reply to message #67880] Mon, 03 December 2007 10:21 Go to previous messageGo to next message
Dennis Wagelaar is currently offline Dennis WagelaarFriend
Messages: 147
Registered: July 2009
Senior Member
Tristan FAURE schreef:
> hi
> if we use EMF the Stereotypes are not recognized

ProfileApplication should still work with the EMF driver. I'm trying to
discover if the EMF driver also has this problem, or if the problem is
specific to the UML driver.

> if i omit my personnal rules the profile application is not copied too
>

Just for completeness: you do have "Allow inter-model references"
enabled, right?
--
Dennis
Re: [ATL] problem with UML2 and profile application [message #68259 is a reply to message #68049] Wed, 05 December 2007 14:21 Go to previous message
Eclipse UserFriend
Originally posted by: tristan.faure.c-s.fr

Tristan FAURE schreef:

hi
if we use EMF the Stereotypes are not recognized


ProfileApplication should still work with the EMF driver. I'm trying to
discover if the EMF driver also has this problem, or if the problem is
specific to the UML driver.

if i omit my personnal rules the profile application is not copied too


Just for completeness: you do have "Allow inter-model references" enabled,
right?
--
Dennis

Yes i do
Previous Topic:M2 to M1 transformation (demotion?)
Next Topic:Problem with driver UML2 and UML PrimitiveTypes
Goto Forum:
  


Current Time: Sun Apr 11 23:14:23 GMT 2021

Powered by FUDForum. Page generated in 0.01967 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top