Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Getting started is like pulling teeth (and install is worse)...
Getting started is like pulling teeth (and install is worse)... [message #663815] Wed, 06 April 2011 14:56 Go to next message
jmc34 is currently offline jmc34Friend
Messages: 3
Registered: April 2011
Location: France
Junior Member
Hi everyone,
I am new to all of this Eclipse shebang but I must say that it is looking like it has been designed with being cryptic as a core feature!!!

I wanted to learn a few things, like Java and UML and started with installing "Eclipse Java EE IDE for Web Developers", I have version Helios SR2-20110218-0911. I am on a 64bits Windows 7 machine.

I did a bit of Java... Fine and enough to nunderstand that any class beyond schoolboy level would require a bit of design.

I am now trying to get all of this UML stuff off the ground and I must say it much much more painfull.

I first installed the UML2 packages using Help->Install new software, then choosing UML2 from the modeling group.

My installed software shows the following:
  UML2 Documentation	    3.1.0.v201005281015	org.eclipse.uml2.doc.feature.group
  UML2 End-User Features	3.1.2.v201010261927	org.eclipse.uml2.feature.group
  UML2 Examples	            3.1.1.v201008191505	org.eclipse.uml2.examples.feature.group
  UML2 Examples Source	    3.1.1.v201008191505	org.eclipse.uml2.examples.source.feature.group
  UML2 Extender SDK	        3.1.2.v201010261927	org.eclipse.uml2.sdk.feature.group
  UML2 Source	            3.1.2.v201010261927	org.eclipse.uml2.source.feature.group


I am now able to create UML files, but "the hard way" and started looking for a GUI tool, here come Papyrus and the begining of my woes...

I tried to follow the steps here, and added http://download.eclipse.org/modeling/mdt/papyrus/updates/rel eases/helios as an update site.
I first tried to install all Papyrus packages, but I ran into dependancy issues.
Cannot complete the install because one or more required items could not be found.
  Software being installed: MDT Papyrus - Backbone (Incubation) 0.7.2.v201101191114 (org.eclipse.papyrus.backbone.feature.group 0.7.2.v201101191114)
  Missing requirement for filter properties ~= $0: EPF Richtext 1.6.0.201101131810 (org.eclipse.epf.richtext.feature.group 1.6.0.201101131810) requires 'org.eclipse.epf.common.win32.win32.x86 [1.5.0.201101131810]' but it could not be found
  Cannot satisfy dependency:
    From: MDT Papyrus - Backbone (Incubation) 0.7.2.v201101191114 (org.eclipse.papyrus.backbone.feature.group 0.7.2.v201101191114)
    To: org.eclipse.epf.richtext.feature.group [1.6.0.201101131810]

I finally was able to install the "Papyrus UML" package, and my installed software now show:
  MDT Papyrus - Activity Diagram editor (Incubation)	    0.7.2.v201101191114	org.eclipse.papyrus.diagram.activity.feature.group
  MDT Papyrus - Class Diagram editor (Incubation)	        0.7.2.v201101191114	org.eclipse.papyrus.diagram.clazz.feature.group
  MDT Papyrus - Communication Diagram editor (Incubation)	0.7.2.v201101191114	org.eclipse.papyrus.diagram.communication.feature.group
  MDT Papyrus - Composite Diagram editor (Incubation)	    0.7.2.v201101191114	org.eclipse.papyrus.diagram.composite.feature.group
  MDT Papyrus - Direct editors for UML using XText (Incubation)	0.7.2.v201101191114	org.eclipse.papyrus.xtext.uml.feature.group
  MDT Papyrus - Menu for Papyrus editor (Incubation)	    0.7.2.v201101191114	org.eclipse.papyrus.diagram.menu.feature.group
  MDT Papyrus - Package Diagram editor (Incubation)	        0.7.2.v201101191114	org.eclipse.papyrus.uml.diagram.pkg.feature.group
  MDT Papyrus - Profile Diagram editor (Incubation)	        0.7.2.v201101191114	org.eclipse.papyrus.diagram.profile.feature.group
  MDT Papyrus - Sequence Diagram editor (Incubation)	    0.7.2.v201101191114	org.eclipse.papyrus.diagram.sequence.feature.group
  MDT Papyrus - StateMachine Diagram editor (Incubation)	0.7.2.v201101191114	org.eclipse.papyrus.diagram.statemachine.feature.group
  MDT Papyrus - UML core elements (Incubation)	            0.7.2.v201101191114	org.eclipse.papyrus.uml.feature.group
  MDT Papyrus - UseCase Diagram editor (Incubation)	        0.7.2.v201101191114	org.eclipse.papyrus.diagram.usecase.feature.group


My issue is that my Eclipse environment did not change at all and I have yet to see any button, menu or icon related to Papyrus or editing UML diagrams.

I assume I am missing somlethjing simple and fairly basic here, but I have been pulling my hair on this all day and I could really use some help.

If you have any pointers on a "getting started" guide, I am more than happy to get it.

Many thanks in advance for your help (and forgive my English, I am French, hope this is not why Papyrus is broken Wink ).

Jean-Michel
Re: Getting started is like pulling teeth (and install is worse)... [message #663826 is a reply to message #663815] Wed, 06 April 2011 15:08 Go to previous messageGo to next message
jmc34 is currently offline jmc34Friend
Messages: 3
Registered: April 2011
Location: France
Junior Member
It is to note that I have the same depandency issues with the Papyrus nightly build update site.

Thanks again for your help.

Jean-Michel

[Updated on: Wed, 06 April 2011 15:08]

Report message to a moderator

Re: Getting started is like pulling teeth (and install is worse)... [message #664038 is a reply to message #663815] Thu, 07 April 2011 09:15 Go to previous messageGo to next message
Thomas Neustupny is currently offline Thomas NeustupnyFriend
Messages: 75
Registered: October 2009
Member
This topic seems to address the curses and blessings of eclipse integrated tools in general, and then in a second step the usage of Papyrus.

First about eclipse integration: I'm using eclipse mainly as a Java IDE, and I'm wondering how beneficial it is to also have other tools like MDT Papyrus integrated in eclipse. The dependencies issues and the management of update sites seems to be a source for problems rather than a help. Personally, I prefer to decouple UML modelling from my current eclipse installation and find task switching with ALT+TAB more easy than handling multiple projects and views inside eclipse. Maybe things will change when code and model are more tightly bounded to each other. (Furthermore, I've got the impression that eclipe MDT is so IDE centric, I even couldn't believe that that people would accept modeling without diagrams so I don't really understand the MDT user base.)

Secondly, about how to "see" Papyrus: have you tried creating a Papyrus project ("New -> Project...")? That's the starting point.
Re: Getting started is like pulling teeth (and install is worse)... [message #664293 is a reply to message #664038] Fri, 08 April 2011 10:07 Go to previous messageGo to next message
jmc34 is currently offline jmc34Friend
Messages: 3
Registered: April 2011
Location: France
Junior Member
Hi Thomas,
thanks for your message.

After creating a Papyrus model, the Papyrus menu magicly appeared Wink.

I was a bit diaspointed to see that you cannot directly generate Java (squeleton) classes from Papyrus...

It feels the the UI to edit the UML diagrams is basic as well (and not that responsive).

You are syaing that you have decoupled UML modeling from Eclipse.
If you can say, what modeling tool are you using?

I tried ArgoUML, but I found the Java code generation a bit crude and it is only "one way".

Thanks.

Jean-Michel
Re: Getting started is like pulling teeth (and install is worse)... [message #664305 is a reply to message #663815] Fri, 08 April 2011 10:29 Go to previous messageGo to next message
Thomas Neustupny is currently offline Thomas NeustupnyFriend
Messages: 75
Registered: October 2009
Member
Actually I am an ArgoUML developer and user as well of course. Smile
I'm using MDT Papyrus too, because both share exactly the same metamodel (eclipse UML2), so I can compare the models directly. Obviously, both tools are not in a final state... Rolling Eyes

(With ArgoUML I'm using reverse engineering much more often than code generation, and for code generation I played around with a template based approach (velocity). For the built-in code generation, all is implemented within just one class(!) and can easily modified once you checkout the argouml-java sources. Bottom line: development is needed. But that's off-topic.)

Regarding the code generation features of MDT Papyrus: that's what I was talking about. I too would expect that an eclipse based tool sooner or later would have some decent code engineering support, as it is living next door to a great IDE platform.
Re: Getting started is like pulling teeth (and install is worse)... [message #667483 is a reply to message #663815] Fri, 29 April 2011 03:07 Go to previous messageGo to next message
Freddy Angel is currently offline Freddy AngelFriend
Messages: 4
Registered: April 2011
Location: Brisbane, Australia
Junior Member
Same problem here.

Cannot complete the install because one or more required items could not be found.
  Software being installed: MDT Papyrus - Backbone (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.backbone.feature.group 0.7.3.v201104270854)
  Missing requirement for filter properties ~= $0: EPF Richtext 1.6.0.201101131810 (org.eclipse.epf.richtext.feature.group 1.6.0.201101131810) requires 'org.eclipse.epf.common.win32.win32.x86 [1.5.0.201101131810]' but it could not be found
  Cannot satisfy dependency:
    From: MDT Papyrus - Backbone (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.backbone.feature.group 0.7.3.v201104270854)
    To: org.eclipse.epf.richtext.feature.group [1.6.0.201101131810]


Any idea how can I overcome this error?

Thanks in advance

[Updated on: Fri, 29 April 2011 03:44]

Report message to a moderator

Re: Getting started is like pulling teeth (and install is worse)... [message #673310 is a reply to message #667483] Mon, 23 May 2011 08:08 Go to previous messageGo to next message
Patrick Tessier is currently offline Patrick TessierFriend
Messages: 238
Registered: July 2009
Location: Paris Saclay, France
Senior Member
Normally this bug has been resolved last week.
Re: Getting started is like pulling teeth (and install is worse)... [message #677573 is a reply to message #663815] Wed, 08 June 2011 20:48 Go to previous message
Yann Tanguy is currently offline Yann TanguyFriend
Messages: 80
Registered: July 2009
Member
See my post for install procedure: http://www.eclipse.org/forums/index.php/mv/msg/210607/677561/#msg_677561

I suspect some issue with Win 64 Bit version of Eclipse (the EPF plug-in we are using may not by available for this platform), prefer Eclipse Windows 32 Bit.

Hope this helps in saving some of your teeth.

[Updated on: Wed, 08 June 2011 20:49]

Report message to a moderator

Previous Topic:Interaction Overview Diagram
Next Topic:Forum participation
Goto Forum:
  


Current Time: Mon Jan 20 06:14:54 GMT 2020

Powered by FUDForum. Page generated in 0.02036 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top