Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Teneo : where is the last release ?
Teneo : where is the last release ? [message #66489] Thu, 04 January 2007 20:19 Go to next message
Eclipse UserFriend
Originally posted by: mat.loo.gmail.com

Hi,

I want to update my Teneo from the release 1 week ago. But I cannot access
it, the 20061228 does not seem to be available for download on eclise.org.

Is there something I'm missing ?

Thx
Re: Teneo : where is the last release ? [message #66571 is a reply to message #66489] Thu, 04 January 2007 21:49 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Mat,
There was a problem at eclipse.org which resulted in the builds not being copied to the download
server. This should be solved now.
The last build I did a few minutes ago can be downloaded.

gr. Martin

Mat Lo wrote:
> Hi,
>
> I want to update my Teneo from the release 1 week ago. But I cannot
> access it, the 20061228 does not seem to be available for download on
> eclise.org.
>
> Is there something I'm missing ?
>
> Thx
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo : where is the last release ? [message #66611 is a reply to message #66571] Fri, 05 January 2007 09:30 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mat.loo.gmail.com

Ok, it works now, thanks !

Just a quick question : I have an null pointer error when Teneo tries to
recover the extension point "org.jpox.cache_level1", in JpoxDataStore:269.

I use PMFConfiguration."org.jpox.cache.level1.type" to set my Level1 cache
but no extension point ; am I not parameterizing well ?

Thx
Re: Teneo : where is the last release ? [message #66632 is a reply to message #66571] Fri, 05 January 2007 09:30 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mat.loo.gmail.com

Ok, it works now, thanks !

Just a quick question : I have an null pointer error when Teneo tries to
recover the extension point "org.jpox.cache_level1", in JpoxDataStore:269.

I use PMFConfiguration."org.jpox.cache.level1.type" to set my Level1 cache
but no extension point ; am I not parameterizing well ?
I tried to add this extensoin point, but Eclipse does not show it as an
available extension point.

Thx
Re: Teneo : where is the last release ? [message #66653 is a reply to message #66632] Fri, 05 January 2007 09:44 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Which version of jpox are you using (teneo is on 1.1.3)?

See also here:
http://www.jpox.org/docs/1_1/extensions/level1_cache.html

gr. Martin

Mat Lo wrote:
> Ok, it works now, thanks !
>
> Just a quick question : I have an null pointer error when Teneo tries to
> recover the extension point "org.jpox.cache_level1", in JpoxDataStore:269.
>
> I use PMFConfiguration."org.jpox.cache.level1.type" to set my Level1
> cache but no extension point ; am I not parameterizing well ?
> I tried to add this extensoin point, but Eclipse does not show it as an
> available extension point.
>
> Thx
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo : where is the last release ? [message #66719 is a reply to message #66653] Fri, 05 January 2007 13:42 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mat.loo.gmail.com

Hi again.

My problem was that I use 1.1.2, indeed !

But, I use jpox.jar as a library and not as a plugin of my dev platform.
But to have the extension point, I have to use it as a plugin. The problem
it seems to require some packages I feel strange :
oracle.*

So oracle is a requirement ?!

Furtermore, if I want to set up my environment correctly I have to ensure
the dependency from to Jpox to jdo.jar.

Till now, I had created a plugin with all needed .jar (jpox, jdo, log4j,
bcel...) and everything was great.

Since I want to update to 1.1.3, it seems mandatory to extend the
cache_level1 extension point and it causes problem..

Any idea ?

Thx
Re: Teneo : where is the last release ? [message #66737 is a reply to message #66719] Fri, 05 January 2007 14:22 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Mat,
Did you read this page:
http://www.jpox.org/docs/1_1/extensions/plugins.html

I can't imagine that jpox has a dependency on oracle. I think that the jpox forum will give you some
more info (they are very responsive).

gr. Martin

Mat Lo wrote:
> Hi again.
>
> My problem was that I use 1.1.2, indeed !
>
> But, I use jpox.jar as a library and not as a plugin of my dev platform.
> But to have the extension point, I have to use it as a plugin. The
> problem it seems to require some packages I feel strange :
> oracle.*
>
> So oracle is a requirement ?!
>
> Furtermore, if I want to set up my environment correctly I have to
> ensure the dependency from to Jpox to jdo.jar.
>
> Till now, I had created a plugin with all needed .jar (jpox, jdo, log4j,
> bcel...) and everything was great.
>
> Since I want to update to 1.1.3, it seems mandatory to extend the
> cache_level1 extension point and it causes problem..
>
> Any idea ?
>
> Thx
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo : where is the last release ? [message #600694 is a reply to message #66489] Thu, 04 January 2007 21:49 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Mat,
There was a problem at eclipse.org which resulted in the builds not being copied to the download
server. This should be solved now.
The last build I did a few minutes ago can be downloaded.

gr. Martin

Mat Lo wrote:
> Hi,
>
> I want to update my Teneo from the release 1 week ago. But I cannot
> access it, the 20061228 does not seem to be available for download on
> eclise.org.
>
> Is there something I'm missing ?
>
> Thx
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo : where is the last release ? [message #600716 is a reply to message #66571] Fri, 05 January 2007 09:30 Go to previous message
Eclipse UserFriend
Originally posted by: mat.loo.gmail.com

Ok, it works now, thanks !

Just a quick question : I have an null pointer error when Teneo tries to
recover the extension point "org.jpox.cache_level1", in JpoxDataStore:269.

I use PMFConfiguration."org.jpox.cache.level1.type" to set my Level1 cache
but no extension point ; am I not parameterizing well ?

Thx
Re: Teneo : where is the last release ? [message #600723 is a reply to message #66571] Fri, 05 January 2007 09:30 Go to previous message
Eclipse UserFriend
Originally posted by: mat.loo.gmail.com

Ok, it works now, thanks !

Just a quick question : I have an null pointer error when Teneo tries to
recover the extension point "org.jpox.cache_level1", in JpoxDataStore:269.

I use PMFConfiguration."org.jpox.cache.level1.type" to set my Level1 cache
but no extension point ; am I not parameterizing well ?
I tried to add this extensoin point, but Eclipse does not show it as an
available extension point.

Thx
Re: Teneo : where is the last release ? [message #600729 is a reply to message #66632] Fri, 05 January 2007 09:44 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Which version of jpox are you using (teneo is on 1.1.3)?

See also here:
http://www.jpox.org/docs/1_1/extensions/level1_cache.html

gr. Martin

Mat Lo wrote:
> Ok, it works now, thanks !
>
> Just a quick question : I have an null pointer error when Teneo tries to
> recover the extension point "org.jpox.cache_level1", in JpoxDataStore:269.
>
> I use PMFConfiguration."org.jpox.cache.level1.type" to set my Level1
> cache but no extension point ; am I not parameterizing well ?
> I tried to add this extensoin point, but Eclipse does not show it as an
> available extension point.
>
> Thx
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: Teneo : where is the last release ? [message #600763 is a reply to message #66653] Fri, 05 January 2007 13:42 Go to previous message
Eclipse UserFriend
Originally posted by: mat.loo.gmail.com

Hi again.

My problem was that I use 1.1.2, indeed !

But, I use jpox.jar as a library and not as a plugin of my dev platform.
But to have the extension point, I have to use it as a plugin. The problem
it seems to require some packages I feel strange :
oracle.*

So oracle is a requirement ?!

Furtermore, if I want to set up my environment correctly I have to ensure
the dependency from to Jpox to jdo.jar.

Till now, I had created a plugin with all needed .jar (jpox, jdo, log4j,
bcel...) and everything was great.

Since I want to update to 1.1.3, it seems mandatory to extend the
cache_level1 extension point and it causes problem..

Any idea ?

Thx
Re: Teneo : where is the last release ? [message #600766 is a reply to message #66719] Fri, 05 January 2007 14:22 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Mat,
Did you read this page:
http://www.jpox.org/docs/1_1/extensions/plugins.html

I can't imagine that jpox has a dependency on oracle. I think that the jpox forum will give you some
more info (they are very responsive).

gr. Martin

Mat Lo wrote:
> Hi again.
>
> My problem was that I use 1.1.2, indeed !
>
> But, I use jpox.jar as a library and not as a plugin of my dev platform.
> But to have the extension point, I have to use it as a plugin. The
> problem it seems to require some packages I feel strange :
> oracle.*
>
> So oracle is a requirement ?!
>
> Furtermore, if I want to set up my environment correctly I have to
> ensure the dependency from to Jpox to jdo.jar.
>
> Till now, I had created a plugin with all needed .jar (jpox, jdo, log4j,
> bcel...) and everything was great.
>
> Since I want to update to 1.1.3, it seems mandatory to extend the
> cache_level1 extension point and it causes problem..
>
> Any idea ?
>
> Thx
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Previous Topic:Using Jet Transformation with EMF documents
Next Topic:Teneo: AnyTypeEObject class not found
Goto Forum:
  


Current Time: Fri Feb 26 11:07:55 GMT 2021

Powered by FUDForum. Page generated in 0.02471 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top