Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Eclipse 3.6.2 SWT issue - .UnsatisfiedLinkError: Activator._isCompizSet()Z
Eclipse 3.6.2 SWT issue - .UnsatisfiedLinkError: Activator._isCompizSet()Z [message #663588] Tue, 05 April 2011 17:57 Go to next message
Vijay Raj is currently offline Vijay RajFriend
Messages: 4
Registered: April 2011
Junior Member
Hi -
I am writing this plugin on the Eclipse platform, developing on Linux platform (ubuntu 10.04 64-bit) .

Eclipse version:
Eclipse Java EE IDE for Web Developers.
Version: Helios Service Release 2
Build id: 20110218-0911

$ java -version
java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02, mixed mode)


On launching the plugin , I get the following error.

Caused by: java.lang.UnsatisfiedLinkError: org.eclipse.wb.internal.os.linux.Activator._isCompizSet()Z .

The entire error log is available as an attachment herewith.

What could have been missing here in this case, to cause that error , about the missing method:.

Thanks for helping with the same.
Re: Eclipse 3.6.2 SWT issue - .UnsatisfiedLinkError: Activator._isCompizSet()Z [message #663590 is a reply to message #663588] Tue, 05 April 2011 17:59 Go to previous messageGo to next message
Vijay Raj is currently offline Vijay RajFriend
Messages: 4
Registered: April 2011
Junior Member
!SESSION 2011-04-04 22:40:31.915 -----------------------------------------------
eclipse.buildId=M20110210-1200
java.version=1.6.0_24
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments: -product org.eclipse.platform.ide
Command-line arguments: -product org.eclipse.platform.ide -data /home/vijay/workspace/../runtime-EclipseApplication -dev file:/home/vijay/workspace/.metadata/.plugins/org.eclipse.pd e.core/Eclipse Application/dev.properties -os linux -ws gtk -arch x86_64 -consoleLog

!ENTRY org.eclipse.jface 2 0 2011-04-04 22:40:40.897
!MESSAGE Keybinding conflicts occurred. They may interfere with normal accelerator operation.
!SUBENTRY 1 org.eclipse.jface 2 0 2011-04-04 22:40:40.897
!MESSAGE A conflict occurred for ALT+SHIFT+D G:
Binding(ALT+SHIFT+D G,
ParameterizedCommand(Command(com.google.gdt.eclipse.designer .launch.gwtLaunchShortcut.debug,Debug GWT Application,
Debug GWT Application,
Category(org.eclipse.debug.ui.category.run,Run/Debug,Run/Deb ug command category,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)
Binding(ALT+SHIFT+D G,
ParameterizedCommand(Command(org.testng.eclipse.shortcut.tes tngSuite.debug,Debug TestNG Suite,
Debug TestNG Suite,
Category(org.eclipse.debug.ui.category.run,Run/Debug,Run/Deb ug command category,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)
!SUBENTRY 1 org.eclipse.jface 2 0 2011-04-04 22:40:40.897
!MESSAGE A conflict occurred for ALT+SHIFT+X G:
Binding(ALT+SHIFT+X G,
ParameterizedCommand(Command(com.google.gdt.eclipse.designer .launch.gwtLaunchShortcut.run,Run GWT Application,
Run GWT Application,
Category(org.eclipse.debug.ui.category.run,Run/Debug,Run/Deb ug command category,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)
Binding(ALT+SHIFT+X G,
ParameterizedCommand(Command(org.testng.eclipse.shortcut.tes tngSuite.run,Run TestNG Suite,
Run TestNG Suite,
Category(org.eclipse.debug.ui.category.run,Run/Debug,Run/Deb ug command category,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)

!ENTRY org.eclipse.ui 4 0 2011-04-04 22:40:42.163
!MESSAGE Unhandled event loop exception
!STACK 0
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.UnsatisfiedLinkError: org.eclipse.wb.internal.os.linux.Activator._isCompizSet()Z)
at org.eclipse.swt.SWT.error(SWT.java:4083)
at org.eclipse.swt.SWT.error(SWT.java:3998)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:137)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3515)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3164)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2640)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:24 38)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:115)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 620)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
at org.eclipse.equinox.launcher.Main.main(Main.java:1384)
Caused by: java.lang.UnsatisfiedLinkError: org.eclipse.wb.internal.os.linux.Activator._isCompizSet()Z
at org.eclipse.wb.internal.os.linux.Activator._isCompizSet(Nati ve Method)
at org.eclipse.wb.internal.os.linux.Activator.isCompizSet(Activ ator.java:173)
at org.eclipse.wb.internal.os.linux.Activator.access$1(Activato r.java:172)
at org.eclipse.wb.internal.os.linux.Activator$2.run(Activator.j ava:183)
at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockL istener.java:164)
at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer. java:158)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:134)
... 23 more
Re: Eclipse 3.6.2 SWT issue - .UnsatisfiedLinkError: Activator._isCompizSet()Z [message #663767 is a reply to message #663590] Wed, 06 April 2011 12:38 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

On 04/05/2011 01:59 PM, Vijay Raj wrote:
> Caused by: java.lang.UnsatisfiedLinkError:
> org.eclipse.wb.internal.os.linux.Activator._isCompizSet()Z
> at org.eclipse.wb.internal.os.linux.Activator._isCompizSet(Nati ve
> Method)
> at org.eclipse.wb.internal.os.linux.Activator.isCompizSet(Activ
> ator.java:173)

This is not SWT related, but a problem with your org.eclipse.wb plugin
.... you should ask in eclipse.platform

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Platform_Expression_Framework
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/helios/index.jsp?topic=/org.eclipse. platform.doc.isv/guide/workbench.htm


Previous Topic:Browser evaluate always returns null IE7
Next Topic:File Save Dialog - No Directory content is shown
Goto Forum:
  


Current Time: Fri Feb 21 19:49:50 GMT 2020

Powered by FUDForum. Page generated in 0.01673 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top