Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Can't install Papyrus at Helios at all(All means of Papyrus install result a error)
icon8.gif  Can't install Papyrus at Helios at all [message #656640] Sun, 27 February 2011 20:42 Go to next message
Sergey Metcherin is currently offline Sergey MetcherinFriend
Messages: 14
Registered: February 2011
Junior Member
Good day, colleagues!

I'm trying to install latest stable version of Papyrus

( http://www.eclipse.org/downloads/download.php?file=/modeling /mdt/papyrus/downloads/drops/0.8.0/S201102021119/Papyrus-Upd ate-S201102021119.zip)

on Helios Modelling Tools (http://www.eclipse.org/downloads/packages/node/508)

I've tried 3 cases and all failed.

First, I went to Help->Install Modelling Components and chose Papyrus. Click Finish and got window: "Problems occured while performing installation: Operation details." Without any explanation. Very nice.

Second, I downloaded this file, went to Help->Install New Software and added archive to Repository. Then I chose "Papyrus All" and get error:

Missing requirement: Papyrus Main Documentation plugin (Incubation) 0.8.0.v201012160313 (org.eclipse.papyrus.doc 0.8.0.v201012160313) requires 'bundle org.eclipse.ui [3.7.0,4.0.0)' but it could not be found

Third, I've tried to install Papyrus from repository http://download.eclipse.org/modeling/mdt/papyrus/updates/rel eases/ but get

"Could not find http://download.eclipse.org/modeling/mdt/papyrus/updates/rel eases/"

So how can I install Papyrus? Is it possible?
Re: Can't install Papyrus at Helios at all [message #656691 is a reply to message #656640] Mon, 28 February 2011 07:51 Go to previous messageGo to next message
nicolas h is currently offline nicolas hFriend
Messages: 60
Registered: February 2011
Location: Grenoble, France
Member
hi,

I can't help you for your two first cases, for me it works via "Install Modelling Components", but for the case number 3, the main update site is : http://download.eclipse.org/modeling/mdt/papyrus/updates/rel eases/helios

You'll find it here : http://www.eclipse.org/modeling/mdt/papyrus/updates/index.ph p .

Good luck.
Nicolas

[Updated on: Mon, 28 February 2011 07:52]

Report message to a moderator

Re: Can't install Papyrus at Helios at all [message #656839 is a reply to message #656691] Mon, 28 February 2011 18:26 Go to previous messageGo to next message
Sergey Metcherin is currently offline Sergey MetcherinFriend
Messages: 14
Registered: February 2011
Junior Member
I've tried update link you mentioned ( http://download.eclipse.org/modeling/mdt/papyrus/updates/rel eases/helios) but got this:

Cannot complete the install because one or more required items could not be found.
Software being installed: MDT Papyrus - SDK: Runtime, Tools, Documentation and sources (Incubation) 0.7.2.v201101191114 (org.eclipse.papyrus.sdk.feature.group 0.7.2.v201101191114)
Missing requirement for filter properties ~= $0: EPF Richtext 1.6.0.201101131810 (org.eclipse.epf.richtext.feature.group 1.6.0.201101131810) requires 'org.eclipse.epf.common.win32.win32.x86 [1.5.0.201101131810]' but it could not be found
Cannot satisfy dependency:
From: MDT Papyrus - Backbone (Incubation) 0.7.2.v201101191114 (org.eclipse.papyrus.backbone.feature.group 0.7.2.v201101191114)
To: org.eclipse.epf.richtext.feature.group [1.6.0.201101131810]
Cannot satisfy dependency:
From: MDT Papyrus - Runtime and Tools (Incubation) 0.7.2.v201101191114 (org.eclipse.papyrus.feature.group 0.7.2.v201101191114)
To: org.eclipse.papyrus.backbone.feature.group [0.7.2.v201101191114]
Cannot satisfy dependency:
From: MDT Papyrus - SDK: Runtime, Tools, Documentation and sources (Incubation) 0.7.2.v201101191114 (org.eclipse.papyrus.sdk.feature.group 0.7.2.v201101191114)
To: org.eclipse.papyrus.feature.group [0.7.2.v201101191114]

I'm in despair.
Re: Can't install Papyrus at Helios at all [message #657131 is a reply to message #656839] Tue, 01 March 2011 16:56 Go to previous messageGo to next message
Mehrdad Saadatmand is currently offline Mehrdad SaadatmandFriend
Messages: 6
Registered: March 2011
Junior Member
I have the same problem, but on my 64-bit version of Eclipse!!
Re: Can't install Papyrus at Helios at all [message #657155 is a reply to message #657131] Tue, 01 March 2011 18:16 Go to previous messageGo to next message
Sergey Metcherin is currently offline Sergey MetcherinFriend
Messages: 14
Registered: February 2011
Junior Member
Thank you, this behaviour was on 64-bit version, I've installed 32-bit version and now all is OK.
Re: Can't install Papyrus at Helios at all [message #657157 is a reply to message #656640] Tue, 01 March 2011 18:21 Go to previous messageGo to next message
Andres  is currently offline Andres Friend
Messages: 57
Registered: July 2010
Member
Hi,
i use this version of eclipse helios
http://www.eclipse.org/downloads/packages/eclipse-modeling-t ools-includes-incubating-components/heliossr2

I install Papyrus with the option Help->Install Modelling Components ->Papyrus

I use eclipse 64 and 32 bits in different computers, and i dont have problems(I use windows so in both cases),
my jdk is 1.5.022.

I dont remember, but i think that before install papyrus, i install emf and gmf( from Help->Install Modelling Components too).

Andrés


[Updated on: Tue, 01 March 2011 18:25]

Report message to a moderator

Re: Can't install Papyrus at Helios at all [message #657176 is a reply to message #657157] Tue, 01 March 2011 20:07 Go to previous messageGo to next message
Sergey Metcherin is currently offline Sergey MetcherinFriend
Messages: 14
Registered: February 2011
Junior Member
I've installed EMF, GMF, latest 64bit JDK but got the same mysterious error:

Problems occured while performing installation: Operation details.
Re: Can't install Papyrus at Helios x64 at all [message #659287 is a reply to message #656640] Fri, 11 March 2011 20:57 Go to previous message
Bob Fields is currently offline Bob FieldsFriend
Messages: 3
Registered: July 2009
Junior Member
Same problem for me too. Eclipse 3.6 x64, updating an existing Papyrus installation to 0.7.2.v201101191114. I really don't want to downgrade to the Eclipse x32 version, I use the same Eclipse for Modeling, development, and testing. Is there any place I can manually download this missing dependency, just to satisfy the installer? I can't find it on any Eclipse update site. Very annoying.

Software being installed: MDT Papyrus - SDK: Runtime, Tools, Documentation and sources (Incubation) 0.7.2.v201101191114 (org.eclipse.papyrus.sdk.feature.group 0.7.2.v201101191114)
Missing requirement for filter properties ~= $0: EPF Richtext 1.6.0.201101131810 (org.eclipse.epf.richtext.feature.group 1.6.0.201101131810) requires 'org.eclipse.epf.common.win32.win32.x86 [1.5.0.201101131810]' but it could not be found
Previous Topic:Papyrus and MARTE
Next Topic:Papyrus bugs?...UML2 doubts
Goto Forum:
  


Current Time: Fri Jan 17 23:58:20 GMT 2020

Powered by FUDForum. Page generated in 0.02351 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top