Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Problem with RAP+BIRT target platform(Build errors after adding BIRT to the target platform)
Problem with RAP+BIRT target platform [message #656171] Thu, 24 February 2011 12:41 Go to next message
Paul Ramsden is currently offline Paul RamsdenFriend
Messages: 84
Registered: February 2011
Location: BW, Germany
Member
I am trying to add BIRT to my RAP application but am getting build errors once I add BIRT to the target platform configuration.

I have a RAP application using the standard RAP 1.3 Target from the Eclispe+RAP download and this builds and runs fine.

I downloaded the RAP 1.3 und the BIRT 2.6 runtimes and saved them to D:\TARGETS

I created a new target definition and added D:\TARGETS\RAP13. The project build is ok.

I edited the target definition and added D:\TARGETS\BIRT26. The build has many errors.

What I see is that the target definition editor deselects duplicate bundles automatically leaving just one bundle of a pair selected. It seems that the errors are caused by excactly these bundles not being found. I tried selecting the just the other bundle in each pair but I have the impression that the selection is automatically reverted when the config is saved.

Am I doing something wrong here? What can I do to narrow down the problem?

thanks!
Re: Problem with RAP+BIRT target platform [message #656178 is a reply to message #656171] Thu, 24 February 2011 13:00 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
are you aware of this wiki page
http://wiki.eclipse.org/RAP/BIRT_Integration ?
This is a quotation from the "Target" chapter:
"When merging the two runtimes together, we should be sure that *no
bundle* is available *twice* as this results in same strange errors
during runtime. So first step is to remove all the duplicate bundles."
HTH,
Ivan

On 2/24/2011 2:41 PM, paulr wrote:
> I am trying to add BIRT to my RAP application but am getting build
> errors once I add BIRT to the target platform configuration.
>
> I have a RAP application using the standard RAP 1.3 Target from the
> Eclispe+RAP download and this builds and runs fine.
>
> I downloaded the RAP 1.3 und the BIRT 2.6 runtimes and saved them to
> D:\TARGETS
>
> I created a new target definition and added D:\TARGETS\RAP13. The
> project build is ok.
>
> I edited the target definition and added D:\TARGETS\BIRT26. The build
> has many errors.
>
> What I see is that the target definition editor deselects duplicate
> bundles automatically leaving just one bundle of a pair selected. It
> seems that the errors are caused by excactly these bundles not being
> found. I tried selecting the just the other bundle in each pair but I
> have the impression that the selection is automatically reverted when
> the config is saved.
>
> Am I doing something wrong here? What can I do to narrow down the
> problem?
>
> thanks!
Re: Problem with RAP+BIRT target platform [message #656189 is a reply to message #656178] Thu, 24 February 2011 13:41 Go to previous messageGo to next message
Paul Ramsden is currently offline Paul RamsdenFriend
Messages: 84
Registered: February 2011
Location: BW, Germany
Member
Ivan,

yes, I was following that page.

As I mentioned in my question, the target editor seems to be deselecting the duplicates automatically so I don't think that I have any duplicates. However, the symptoms are that the duplicated bundles don't seem to be present *at all*.

Paul
Re: Problem with RAP+BIRT target platform [message #656193 is a reply to message #656189] Thu, 24 February 2011 14:05 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Paul,
try to compose you target platform manually without a duplicates bundles.
Best,
Ivan

On 2/24/2011 3:41 PM, paulr wrote:
> Ivan,
>
> yes, I was following that page.
> As I mentioned in my question, the target editor seems to be
> deselecting the duplicates automatically so I don't think that I have
> any duplicates. However, the symptoms are that the duplicated bundles
> don't seem to be present *at all*.
>
> Paul
Re: Problem with RAP+BIRT target platform [message #657597 is a reply to message #656193] Thu, 03 March 2011 12:37 Go to previous message
Paul Ramsden is currently offline Paul RamsdenFriend
Messages: 84
Registered: February 2011
Location: BW, Germany
Member
Hi Ivan

ok, copied the RAP & BIRT manually as you suggested and it works fine.

NOTE the birt.api bundle needs to be deselected as it was causing a problem with com.ibm.icu.text.

Thanks

Paul
Previous Topic:[DateTime] Selection event lost
Next Topic:Runtime issue on rendering images in table?
Goto Forum:
  


Current Time: Wed Oct 20 02:06:36 GMT 2021

Powered by FUDForum. Page generated in 0.02324 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top