Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Moved a project to Win7 x86_64 from Linux_64, now get "Platform filter did not match:"
Moved a project to Win7 x86_64 from Linux_64, now get "Platform filter did not match:" [message #655613] Mon, 21 February 2011 22:52 Go to next message
David Wynter is currently offline David WynterFriend
Messages: 4624
Registered: July 2009
Senior Member
Hi,

I have Win7 64 bit, JDK 6 64 bit, Helios SR1 64 bit

I get the following when I validate the plugins:
org.eclipse.core.filesystem.win32.x86_64
Platform filter did not match: (& (osgi.os=win32)(osgi.arch=x86_64))
org.eclipse.core.net.win32.x86_64
Platform filter did not match: (& (osgi.os=win32)(osgi.arch=x86_64))
org.eclipse.equinox.launcher.win32.win32.x86_64
Platform filter did not match: (&
(osgi.ws=win32)(osgi.os=win32)(osgi.arch=x86_64))
org.eclipse.core.swt.win32.win32.x86_64
Platform filter did not match: (&
(osgi.ws=win32)(osgi.os=win32)(osgi.arch=x86_64))

Do I need something like
org.eclipse.core.swt.win64.win64.x86_64?

Thx.

David
Re: Moved a project to Win7 x86_64 from Linux_64, now get "Platform filter did not match:" [message #655626 is a reply to message #655613] Tue, 22 February 2011 02:23 Go to previous messageGo to next message
Olivier Thomann is currently offline Olivier ThomannFriend
Messages: 518
Registered: July 2009
Senior Member
You might need to adjust the platform settings in the preferences.
--
Olivier
Re: Moved a project to Win7 x86_64 from Linux_64, now get "Platform filter did not match:" [message #655661 is a reply to message #655626] Tue, 22 February 2011 08:27 Go to previous message
David Wynter is currently offline David WynterFriend
Messages: 4624
Registered: July 2009
Senior Member
On 22/02/11 02:23, Olivier Thomann wrote:
> You might need to adjust the platform settings in the preferences.
> --
> Olivier
Hi Olivier,

By 'platform in preferences' did you mean set up the default "Target
Platform" under "Plug-in Development" in the "Preferences"? That seemsed
to be the closet things I could find in preferences to what you hinted
at. I set up the target platform with OS == win32, WS == win32 and arch
== x86_64.


My stack trace is now longer than the bible. Mostly root causes of
"IllegalStateException: Workbench has not been created yet."

Also
£java.lang.NoClassDefFoundError:
org/eclipse/debug/ui/BreakpointTypeCategory"

Ideas welcome.

David
Previous Topic:Wizard page does not launch
Next Topic:Feature Versioning
Goto Forum:
  


Current Time: Thu Aug 13 08:56:49 GMT 2020

Powered by FUDForum. Page generated in 0.02184 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top