Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » [p2] carbon macosx package build problems
[p2] carbon macosx package build problems [message #65435] Wed, 24 June 2009 10:58 Go to next message
Eclipse UserFriend
Originally posted by: christian.dupuis.springsource.com

This is a multi-part message in MIME format.
--------------060904040907080709080204
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

All, I'm currently preparing a 3.5-based package build and hitting a
problem with the assembly of the carbon macosx package. All the other
packages work fine. Below is the error message. I've also attached a
logfile with the command I'm running.

[exec] Building package for IU com.springsource.sts.ide
[exec] ...EPP building com.springsource.sts.ide win32 win32 x86
[exec] ...successfully finished win32 win32 x86 package build:
springsource-tool-suite-2.1.0.RC0-e3.5-win32.win32.x86.zip
[exec] ...EPP building com.springsource.sts.ide linux gtk x86
[exec] ...successfully finished linux gtk x86 package build:
springsource-tool-suite-2.1.0.RC0-e3.5-linux.gtk.x86.tar.gz
[exec] ...EPP building com.springsource.sts.ide linux gtk x86_64
[exec] ...successfully finished linux gtk x86_64 package build:
springsource-tool-suite-2.1.0.RC0-e3.5-linux.gtk.x86_64.tar. gz
[exec] ...EPP building com.springsource.sts.ide macosx cocoa x86
[exec] ...successfully finished macosx cocoa x86 package build:
springsource-tool-suite-2.1.0.RC0-e3.5-macosx.cocoa.x86.tar. gz
[exec] ...EPP building com.springsource.sts.ide macosx cocoa x86_64
[exec] ...successfully finished macosx cocoa x86_64 package build:
springsource-tool-suite-2.1.0.RC0-e3.5-macosx.cocoa.x86_64.t ar.gz
[exec] ...EPP building com.springsource.sts.ide macosx carbon ppc
[exec] Cannot complete the install because one or more required
items could not be found.
[exec] Software being installed: SpringSource Tool Suite
2.1.0.200906231257-RC1 (com.springsource.sts.ide 2.1.0.200906231257-RC1)
[exec] Missing requirement for filter (& (osgi.ws=carbon)
(osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) ): Eclipse Product
Configuration 1.0.0.I20090611-1540
(org.eclipse.rcp.configuration.feature.group 1.0.0.I20090611-1540)
requires 'toolingorg.eclipse.equinox.launcher.carbon.macosx
[1.0.200.v20090520-1835]' but it could not be found
[exec] Cannot satisfy dependency:
[exec] From: SpringSource Tool Suite 2.1.0.200906231257-RC1
(com.springsource.sts.ide 2.1.0.200906231257-RC1)
[exec] To: org.eclipse.platform.ide 0.0.0
[exec] Cannot satisfy dependency:
[exec] From: Eclipse Platform 3.5.0.I20090611-1540
(org.eclipse.platform.ide 3.5.0.I20090611-1540)
[exec] To: org.eclipse.rcp.configuration.feature.group
[1.0.0.I20090611-1540]
[exec] Application failed, log file location:
/Users/cdupuis/Development/Java/work/spring-tool-suite/temp/ releng/com.springsource.sts.releng/tools/sdk-3.5RC4/eclipse/ configuration/1245838111363.log
[exec] ...failed while building package macosx carbon ppc
[exec] EPP package build finished.

Does anybody know what I need to do to solve that problem?

Thanks for your help.

--------------060904040907080709080204
Content-Type: text/plain; x-mac-type="0"; x-mac-creator="0";
name="com.springsource.sts.ide_macosx.carbon.ppc.log"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline;
filename="com.springsource.sts.ide_macosx.carbon.ppc.log"

!SESSION 2009-06-24 12:08:31.174 ----------------------------------------=
-------
eclipse.buildId=3DI20090605-1444
java.version=3D1.5.0_19
java.vendor=3DApple Inc.
BootLoader constants: OS=3Dmacosx, ARCH=3Dx86, WS=3Dcarbon, NL=3Den_US
Framework arguments: -product org.eclipse.epp.package.jee.product -appli=
cation org.eclipse.equinox.p2.director -m file:///Users/cdupuis/Developme=
nt/Java/work/spring-tool-suite/temp/releng/com.springsource. sts.releng/bu=
ild/update,file:///Users/cdupuis/Development/Java/work/sprin g-tool-suite/=
temp/releng/com.springsource.sts.releng/build/mirror-p2,http ://download.e=
clipse.org/releases/galileo -a file:///Users/cdupuis/Development/Java/wor=
k/spring-tool-suite/temp/releng/com.springsource.sts.releng/ build/update,=
file:///Users/cdupuis/Development/Java/work/spring-tool-suit e/temp/releng=
/com.springsource.sts.releng/build/mirror-p2,http://download .eclipse.org/=
releases/galileo -installIU com.springsource.sts.ide -destination /Users/=
cdupuis/Development/Java/work/spring-tool-suite/temp/releng/ com.springsou=
rce.sts.releng/build/build/com.springsource.sts.ide/macosx.c arbon.ppc/ecl=
ipse -profile com.springsource.sts.ide -flavor tooling -profileproperties=
org.eclipse.update.install.features=3Dtrue -bundlepool /Users/cdupuis/De=
velopment/Java/work/spring-tool-suite/temp/releng/com.spring source.sts.re=
leng/build/build/com.springsource.sts.ide/macosx.carbon.ppc/ eclipse -p2.o=
s macosx -p2.ws carbon -p2.arch ppc -roaming
Command-line arguments: -os macosx -ws carbon -arch x86 -product org.ecl=
ipse.epp.package.jee.product -consoleLog -application org.eclipse.equinox=
=2Ep2.director -m file:///Users/cdupuis/Development/Java/work/spring-tool=
-suite/temp/releng/com.springsource.sts.releng/build/update, file:///Users=
/cdupuis/Development/Java/work/spring-tool-suite/temp/releng /com.springso=
urce.sts.releng/build/mirror-p2,http://download.eclipse.org/ releases/gali=
leo -a file:///Users/cdupuis/Development/Java/work/spring-tool-suit e/temp=
/releng/com.springsource.sts.releng/build/update,file:///Use rs/cdupuis/De=
velopment/Java/work/spring-tool-suite/temp/releng/com.spring source.sts.re=
leng/build/mirror-p2,http://download.eclipse.org/releases/ga lileo -instal=
lIU com.springsource.sts.ide -destination /Users/cdupuis/Development/Java=
/work/spring-tool-suite/temp/releng/com.springsource.sts.rel eng/build/bui=
ld/com.springsource.sts.ide/macosx.carbon.ppc/eclipse -profile com.spring=
source.sts.ide -flavor tooling -profileproperties org.eclipse.update.inst=
all.features=3Dtrue -bundlepool /Users/cdupuis/Development/Java/work/spri=
ng-tool-suite/temp/releng/com.springsource.sts.releng/build/ build/com.spr=
ingsource.sts.ide/macosx.carbon.ppc/eclipse -p2.os macosx -p2.ws carbon -=
p2.arch ppc -roaming

!ENTRY org.eclipse.core.net 1 0 2009-06-24 12:08:32.664
!MESSAGE System property http.nonProxyHosts has been set to local|*.local=
|169.254/16|*.169.254/16 by an external source. This value will be overwr=
itten using the values from the preferences
Installing com.springsource.sts.ide 2.1.0.200906231257-RC1.

!ENTRY org.eclipse.equinox.p2.director 4 1 2009-06-24 12:09:55.495
!MESSAGE Cannot complete the install because one or more required items c=
ould not be found.
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2009-06-24 12:09:55.496
!MESSAGE Software being installed: SpringSource Tool Suite 2.1.0.20090623=
1257-RC1 (com.springsource.sts.ide 2.1.0.200906231257-RC1)
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2009-06-24 12:09:55.496
!MESSAGE Missing requirement for filter (& (osgi.ws=3Dcarbon) (osgi.os=3D=
macosx) (|(osgi.arch=3Dx86)(osgi.arch=3Dppc)) ): Eclipse Product Configur=
ation 1.0.0.I20090611-1540 (org.eclipse.rcp.configuration.feature.group 1=
=2E0.0.I20090611-1540) requires 'toolingorg.eclipse.equinox.launcher.carb=
on.macosx [1.0.200.v20090520-1835]' but it could not be found
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2009-06-24 12:09:55.496
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2009-06-24 12:09:55.496
!MESSAGE From: SpringSource Tool Suite 2.1.0.200906231257-RC1 (com.spring=
source.sts.ide 2.1.0.200906231257-RC1)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2009-06-24 12:09:55.497
!MESSAGE To: org.eclipse.platform.ide 0.0.0
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2009-06-24 12:09:55.497
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2009-06-24 12:09:55.497
!MESSAGE From: Eclipse Platform 3.5.0.I20090611-1540 (org.eclipse.platfor=
m.ide 3.5.0.I20090611-1540)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2009-06-24 12:09:55.497
!MESSAGE To: org.eclipse.rcp.configuration.feature.group [1.0.0.I20090611=
-1540]
FAILED

--------------060904040907080709080204--
Re: [p2] carbon macosx package build problems [message #65499 is a reply to message #65435] Wed, 24 June 2009 17:09 Go to previous messageGo to next message
Andrew Niefer is currently offline Andrew NieferFriend
Messages: 990
Registered: July 2009
Senior Member
Christian Dupuis wrote:
> [exec] Missing requirement for filter (& (osgi.ws=carbon)
> (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) ): Eclipse Product
> Configuration 1.0.0.I20090611-1540
> (org.eclipse.rcp.configuration.feature.group 1.0.0.I20090611-1540)

This error comes when the filter on the IU doesn't match the profile you
are installing into.
This doesn't quite make sense because you did run with
-p2.os macosx -p2.ws carbon -p2.arch ppc

So the only thing I can think of is that there already existed a profile
that got used instead of creating a new one.

I would have expected it to use
..../com.springsource.sts.ide/macosx.carbon.ppc/eclipse/p2
as the p2 data area, and I would expect that there aren't any profiles
already at that location.

I don't really have any suggestions, unless you want to run through the
debugger, you can look at DirectorApplication#initializeServices() and
DirectorApplication#initializeProfile()

-Andrew

> requires 'toolingorg.eclipse.equinox.launcher.carbon.macosx
> [1.0.200.v20090520-1835]' but it could not be found
> [exec] Cannot satisfy dependency:
> [exec] From: SpringSource Tool Suite 2.1.0.200906231257-RC1
> (com.springsource.sts.ide 2.1.0.200906231257-RC1)
> [exec] To: org.eclipse.platform.ide 0.0.0
> [exec] Cannot satisfy dependency:
> [exec] From: Eclipse Platform 3.5.0.I20090611-1540
> (org.eclipse.platform.ide 3.5.0.I20090611-1540)
> [exec] To: org.eclipse.rcp.configuration.feature.group
> [1.0.0.I20090611-1540]
> [exec] Application failed, log file location:
> /Users/cdupuis/Development/Java/work/spring-tool-suite/temp/ releng/com.springsource.sts.releng/tools/sdk-3.5RC4/eclipse/ configuration/1245838111363.log
>
> [exec] ...failed while building package macosx carbon ppc
> [exec] EPP package build finished.
>
> Does anybody know what I need to do to solve that problem?
>
> Thanks for your help.
>
Re: [p2] carbon macosx package build problems [message #65648 is a reply to message #65499] Thu, 25 June 2009 15:39 Go to previous message
Eclipse UserFriend
Originally posted by: christian.dupuis.springsource.com

Andrew Niefer wrote:
> Christian Dupuis wrote:
>> [exec] Missing requirement for filter (& (osgi.ws=carbon)
>> (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) ): Eclipse Product
>> Configuration 1.0.0.I20090611-1540
>> (org.eclipse.rcp.configuration.feature.group 1.0.0.I20090611-1540)
>
> This error comes when the filter on the IU doesn't match the profile you
> are installing into.
> This doesn't quite make sense because you did run with
> -p2.os macosx -p2.ws carbon -p2.arch ppc
>
> So the only thing I can think of is that there already existed a profile
> that got used instead of creating a new one.
>
> I would have expected it to use
> .../com.springsource.sts.ide/macosx.carbon.ppc/eclipse/p2
> as the p2 data area, and I would expect that there aren't any profiles
> already at that location.
>
> I don't really have any suggestions, unless you want to run through the
> debugger, you can look at DirectorApplication#initializeServices() and
> DirectorApplication#initializeProfile()
>
> -Andrew
>
>> requires 'toolingorg.eclipse.equinox.launcher.carbon.macosx
>> [1.0.200.v20090520-1835]' but it could not be found
>> [exec] Cannot satisfy dependency:
>> [exec] From: SpringSource Tool Suite 2.1.0.200906231257-RC1
>> (com.springsource.sts.ide 2.1.0.200906231257-RC1)
>> [exec] To: org.eclipse.platform.ide 0.0.0
>> [exec] Cannot satisfy dependency:
>> [exec] From: Eclipse Platform 3.5.0.I20090611-1540
>> (org.eclipse.platform.ide 3.5.0.I20090611-1540)
>> [exec] To: org.eclipse.rcp.configuration.feature.group
>> [1.0.0.I20090611-1540]
>> [exec] Application failed, log file location:
>> /Users/cdupuis/Development/Java/work/spring-tool-suite/temp/ releng/com.springsource.sts.releng/tools/sdk-3.5RC4/eclipse/ configuration/1245838111363.log
>>
>> [exec] ...failed while building package macosx carbon ppc
>> [exec] EPP package build finished.
>>
>> Does anybody know what I need to do to solve that problem?
>>
>> Thanks for your help.
>>

Thanks Andrew for your comments. I managed to fix this by pointing to
the Galileo release update sites. All fine now.

Christian
Re: [p2] carbon macosx package build problems [message #598541 is a reply to message #65435] Wed, 24 June 2009 17:09 Go to previous message
Andrew Niefer is currently offline Andrew NieferFriend
Messages: 990
Registered: July 2009
Senior Member
Christian Dupuis wrote:
> [exec] Missing requirement for filter (& (osgi.ws=carbon)
> (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) ): Eclipse Product
> Configuration 1.0.0.I20090611-1540
> (org.eclipse.rcp.configuration.feature.group 1.0.0.I20090611-1540)

This error comes when the filter on the IU doesn't match the profile you
are installing into.
This doesn't quite make sense because you did run with
-p2.os macosx -p2.ws carbon -p2.arch ppc

So the only thing I can think of is that there already existed a profile
that got used instead of creating a new one.

I would have expected it to use
..../com.springsource.sts.ide/macosx.carbon.ppc/eclipse/p2
as the p2 data area, and I would expect that there aren't any profiles
already at that location.

I don't really have any suggestions, unless you want to run through the
debugger, you can look at DirectorApplication#initializeServices() and
DirectorApplication#initializeProfile()

-Andrew

> requires 'toolingorg.eclipse.equinox.launcher.carbon.macosx
> [1.0.200.v20090520-1835]' but it could not be found
> [exec] Cannot satisfy dependency:
> [exec] From: SpringSource Tool Suite 2.1.0.200906231257-RC1
> (com.springsource.sts.ide 2.1.0.200906231257-RC1)
> [exec] To: org.eclipse.platform.ide 0.0.0
> [exec] Cannot satisfy dependency:
> [exec] From: Eclipse Platform 3.5.0.I20090611-1540
> (org.eclipse.platform.ide 3.5.0.I20090611-1540)
> [exec] To: org.eclipse.rcp.configuration.feature.group
> [1.0.0.I20090611-1540]
> [exec] Application failed, log file location:
> /Users/cdupuis/Development/Java/work/spring-tool-suite/temp/ releng/com.springsource.sts.releng/tools/sdk-3.5RC4/eclipse/ configuration/1245838111363.log
>
> [exec] ...failed while building package macosx carbon ppc
> [exec] EPP package build finished.
>
> Does anybody know what I need to do to solve that problem?
>
> Thanks for your help.
>
Re: [p2] carbon macosx package build problems [message #598574 is a reply to message #65499] Thu, 25 June 2009 15:39 Go to previous message
Christian Dupuis is currently offline Christian DupuisFriend
Messages: 8
Registered: July 2009
Junior Member
Andrew Niefer wrote:
> Christian Dupuis wrote:
>> [exec] Missing requirement for filter (& (osgi.ws=carbon)
>> (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) ): Eclipse Product
>> Configuration 1.0.0.I20090611-1540
>> (org.eclipse.rcp.configuration.feature.group 1.0.0.I20090611-1540)
>
> This error comes when the filter on the IU doesn't match the profile you
> are installing into.
> This doesn't quite make sense because you did run with
> -p2.os macosx -p2.ws carbon -p2.arch ppc
>
> So the only thing I can think of is that there already existed a profile
> that got used instead of creating a new one.
>
> I would have expected it to use
> .../com.springsource.sts.ide/macosx.carbon.ppc/eclipse/p2
> as the p2 data area, and I would expect that there aren't any profiles
> already at that location.
>
> I don't really have any suggestions, unless you want to run through the
> debugger, you can look at DirectorApplication#initializeServices() and
> DirectorApplication#initializeProfile()
>
> -Andrew
>
>> requires 'toolingorg.eclipse.equinox.launcher.carbon.macosx
>> [1.0.200.v20090520-1835]' but it could not be found
>> [exec] Cannot satisfy dependency:
>> [exec] From: SpringSource Tool Suite 2.1.0.200906231257-RC1
>> (com.springsource.sts.ide 2.1.0.200906231257-RC1)
>> [exec] To: org.eclipse.platform.ide 0.0.0
>> [exec] Cannot satisfy dependency:
>> [exec] From: Eclipse Platform 3.5.0.I20090611-1540
>> (org.eclipse.platform.ide 3.5.0.I20090611-1540)
>> [exec] To: org.eclipse.rcp.configuration.feature.group
>> [1.0.0.I20090611-1540]
>> [exec] Application failed, log file location:
>> /Users/cdupuis/Development/Java/work/spring-tool-suite/temp/ releng/com.springsource.sts.releng/tools/sdk-3.5RC4/eclipse/ configuration/1245838111363.log
>>
>> [exec] ...failed while building package macosx carbon ppc
>> [exec] EPP package build finished.
>>
>> Does anybody know what I need to do to solve that problem?
>>
>> Thanks for your help.
>>

Thanks Andrew for your comments. I managed to fix this by pointing to
the Galileo release update sites. All fine now.

Christian
Previous Topic:Dependencies leaking outside a bundle
Next Topic:[p2] config.ini files changes after installing plugins from the UI
Goto Forum:
  


Current Time: Thu Jun 24 07:26:52 GMT 2021

Powered by FUDForum. Page generated in 0.01464 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top