Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Tabbed browsing + FORM-authentication
Tabbed browsing + FORM-authentication [message #650753] Wed, 26 January 2011 12:21 Go to next message
Oliver B. is currently offline Oliver B.Friend
Messages: 38
Registered: November 2010
Member
I tried to enable tabbed browsing for my two RAP-applications. I followed the guide in the faq:
http://wiki.eclipse.org/RAP/FAQ#Tomcat

For one application everything worked fine out of the box. The other application has FORM-authentication enabled for the servlet url. The login over a simple jsp-page works fine. But after that the rap-application won't load.

I traced the problem with firebug. The request url for the JSLibraryServiceHandler does not contain the jsessionid. Therefore the server returns the login page, because the request is not authenticated.

I changed JSLibraryServiceHandler.java to use RWT.getResponse().encodeURL for the request url. After that the application was loaded without a problem.

Is this a bug in RAP or is something wrong with my web-application setup?
Re: Tabbed browsing + FORM-authentication [message #650877 is a reply to message #650753] Wed, 26 January 2011 23:41 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Hi,

I'm not aware of a bug regarding form-based authentication. Could you
open a new bug and provide a patch for the change you made?

Thank you!

Best regards, Ralf

--
Ralf Sternberg

Twitter: @ralfstx
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Tabbed browsing + FORM-authentication [message #650936 is a reply to message #650753] Thu, 27 January 2011 08:51 Go to previous messageGo to next message
Oliver B. is currently offline Oliver B.Friend
Messages: 38
Registered: November 2010
Member
I created the new bug and attached the patch:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=335545
Re: Tabbed browsing + FORM-authentication [message #651133 is a reply to message #650936] Thu, 27 January 2011 21:45 Go to previous message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Thank you for the patch!

Ralf

--
Ralf Sternberg

Twitter: @ralfstx
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:Is there future support for swt addPaintListener() and gef?
Next Topic:Missing Icons/Images in ISharedImages ?
Goto Forum:
  


Current Time: Sun Oct 17 18:51:26 GMT 2021

Powered by FUDForum. Page generated in 0.01567 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top