Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » [ANN] Updated JFace and workbench to 3.7
[ANN] Updated JFace and workbench to 3.7 [message #646587] Wed, 29 December 2010 01:07
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Hi all,

I just wanted to let you all know that we eventually updated the RAP
JFace, JFace databinding and workbench code to more recent versions. This
is a significant change in our code base, especially for the workbench,
which was still based on Eclipse 3.4.

The code that is currently in our CVS is based on 3.7 M2 and will be
updated again during this release cycle.

Please test your code early with the new bundles to give us enough time
to fix any potential problems with the new code before the RAP 1.4
release.

Note that there's a small change in the dependencies of the workbench
bundle that could not be avoided due to the broader use of databinding in
the workbench: org.eclipse.ui.workbench now has a dependency to
org.eclipse.rap.jface.databinding. In the previous version, this
dependency was optional. Remember to validate your target platforms.

Best regards, Ralf

--
Ralf Sternberg

Twitter: http://twitter.com/ralfstx
Blog: http://www.eclipsesource.com/blogs/

Professional support for RAP and RCP?
http://www.eclipsesource.com/support/
Previous Topic:Any plans to upgrade to Qooxdoo 1.3 or 1.2.2
Next Topic:Launching a dialog on startup
Goto Forum:
  


Current Time: Tue Oct 26 06:03:56 GMT 2021

Powered by FUDForum. Page generated in 0.02006 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top