Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » XSD » xml validation does not use latest xsd(xml validation using external xsd (how to reset cache?))
xml validation does not use latest xsd [message #640745] Tue, 23 November 2010 00:17 Go to next message
Tom is currently offline TomFriend
Messages: 3
Registered: November 2010
Junior Member
I have Eclipse IDE for Java EE Developers, 204 MB (Mac OSX 32 bit), which I downloaded 2 days ago.

Version: Helios Service Release 1, Build id: 20100917-0705

I created a Dynamic Web Project, and copied a leads.xml file into the WebContent folder. The xml file references an external xsd file like this:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<leads xmlns=""

I was then able to validate the leads.xml file in eclipse, and it correctly used the external leads.xsd and found a few errors.

The problem is that whenever I change the leads.xsd on the server, I cannot get eclipse to read in that new version, instead eclipse continues to validate the leads.xml file against an earlier version which apparently eclipse has cached.

I have added a -clean (on a separate line) at the end of my eclipse.ini file. I have tried refreshing eclipse, I have tried closing eclipse, and then restarting. Nothing has worked. Finally I removed eclipse from my system, reinstalled, and that worked.

How can I get eclipse to read in the new version of an external xsd file that has changed on the server? Or how can I get eclipse to clear its cache(s)?
Re: xml validation does not use latest xsd [message #646895 is a reply to message #640745] Sun, 02 January 2011 17:43 Go to previous messageGo to next message
Stefan  is currently offline Stefan Friend
Messages: 1
Registered: January 2011
Junior Member
Hi Tom,

go to: Window -> Preferences -> General -> Network Connections -> Cache

Best regards
Re: xml validation does not use latest xsd [message #697230 is a reply to message #646895] Fri, 15 July 2011 20:49 Go to previous message
Oz DiGennaro is currently offline Oz DiGennaroFriend
Messages: 1
Registered: July 2011
Junior Member
Very nice! A dirty cache can cause you all sorts of grief.
Previous Topic:XML-Reader to ecore-mapping fails
Next Topic:Xml editor
Goto Forum:

Current Time: Sat Feb 29 13:08:18 GMT 2020

Powered by FUDForum. Page generated in 0.02086 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top