Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Require-Bundle: org.eclipse.rap.ui not found(Require-Bundle: org.eclipse.rap.ui is not included. )
Require-Bundle: org.eclipse.rap.ui not found [message #639830] Thu, 18 November 2010 01:52 Go to next message
Lars Kaare Andersen is currently offline Lars Kaare AndersenFriend
Messages: 2
Registered: July 2009
Junior Member
Hi

I have tryed to install and use the RAP for the firste time.
I have downloaded the eclipse-rcp-helios-SR1-win32.zip file and unziped it on windows 7.
When I create a plugin project and the Hello world template, but the plugin org.eclipse.rap.ui can't be found. I have tryed to locate the plugin in the plugin directory, but it's not there.

I have tryed to install the http://download.eclipse.org/rt/rap/1.3/tooling, but still the org.eclipse.rap.ui is missing.

How do I get this plugin?

Regards Lars
Re: Require-Bundle: org.eclipse.rap.ui not found [message #639864 is a reply to message #639830] Thu, 18 November 2010 08:06 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Lars,
you have to install and switch the RAP target platform. Open Welcome
page in your IDE, than Overview ->Rich Ajax Platform (RAP) -> Install
Target Platform.
HTH,
Ivan

On 18.11.2010 3:53 AM, Lars Kaare Andersen wrote:
> Hi
> I have tryed to install and use the RAP for the firste time.
> I have downloaded the eclipse-rcp-helios-SR1-win32.zip file and
> unziped it on windows 7.
> When I create a plugin project and the Hello world template, but the
> plugin org.eclipse.rap.ui can't be found. I have tryed to locate the
> plugin in the plugin directory, but it's not there.
>
> I have tryed to install the
> http://download.eclipse.org/rt/rap/1.3/tooling, but still the
> org.eclipse.rap.ui is missing.
>
> How do I get this plugin?
>
> Regards Lars
Re: Require-Bundle: org.eclipse.rap.ui not found [message #717627 is a reply to message #639864] Sun, 21 August 2011 19:35 Go to previous message
Raj  is currently offline Raj Friend
Messages: 74
Registered: August 2011
Member
But how to resolve this when you are doing the build through maven. In the maven debug it says Require-Bundle: org.eclipse.rap.ui; bundle-version="1.4.0"
Previous Topic:Widget's border theming
Next Topic:Trying to use the PaperClips component
Goto Forum:
  


Current Time: Mon Oct 25 11:52:49 GMT 2021

Powered by FUDForum. Page generated in 0.01690 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top