Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Problems using Pydev(Eclipse does not find non standard python packages in Snow Leopard)
Problems using Pydev [message #638806] Fri, 12 November 2010 16:06 Go to next message
jcdx  is currently offline jcdx Friend
Messages: 3
Registered: November 2010
Junior Member
Hi group,

I am a beginner with Eclipse and Python. I am using Mac OS 10.6.4 (Snow Leopard)

The installation of Eclipse runs and I can also run Python.

I get the following error when using e.g. the pylab or sympy package:

...
ImportError: dlopen(/opt/local/lib/python2.5/site-packages/matplotlib/_pa th.so, 2): no suitable image found. Did find:
/opt/local/lib/python2.5/site-packages/matplotlib/_path.so: mach-o, but wrong architecture


I performed a platform check within eclipse:
platform.mac_ver() gives
('10.6.4', ('', '', ''), 'i386')

the same check in the terminal gives:
('4294967306.4294967302.4294967300', ('', '', ''), '')

I found that here might be a problem with the "architecture", however I did not find a solution.

What do I have to do get all python packages working in Eclipse?
Actually the same python script runs without errors in the terminal.

Really need help on this.

Best regards
jcdx
Re: Problems using Pydev [message #638819 is a reply to message #638806] Fri, 12 November 2010 16:35 Go to previous messageGo to next message
jcdx  is currently offline jcdx Friend
Messages: 3
Registered: November 2010
Junior Member
I have to be a little bit more precise:

The problem seems only be related to pylab and matplotlib

I needed to set:

backend MacOS

in the matplotlibrc in order to get figures plotted. But it has no effect on Eclipse if I comment it in or out.
[solved] Re: Problems using Pydev [message #638961 is a reply to message #638806] Sun, 14 November 2010 00:31 Go to previous message
jcdx  is currently offline jcdx Friend
Messages: 3
Registered: November 2010
Junior Member
Ok, problem solved.

In order to have matplotlib enabled I found out that I have to use at least python 2.6 on MacOS 64.

The path to the interpreter has to look in the framework path.
On my system:

/opt/local/Library/Frameworks/Python.framework/Versions/2.6/ Resources/Python.app/Contents/MacOS/Python

To get there use:

/opt/local/Library/Frameworks/Python.framework/Versions/2.6/ bin/python2.6

So everything is about finding the right path for the interpreter.

I am a little bit confused about the setup of Python on MacOS. Using /usr/bin/python2.6 e.g. does not work.

Have fun using eclipse.

Previous Topic:[Debug Platform] Stack Frame doesn't get focus
Next Topic:HELP! Had eclipse working, installed JDK (instead of using JRE) now does not start
Goto Forum:
  


Current Time: Sat Jan 16 13:04:34 GMT 2021

Powered by FUDForum. Page generated in 0.02283 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top